diff options
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch | 23 | ||||
-rw-r--r-- | recipes-core/busybox/busybox_1.32.%.bbappend (renamed from recipes-core/busybox/busybox_1.31.%.bbappend) | 0 |
2 files changed, 6 insertions, 17 deletions
diff --git a/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch index c14950a..4f4bbbd 100644 --- a/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch +++ b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch | |||
@@ -113,8 +113,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
113 | shell/ash.c | 5 ++--- | 113 | shell/ash.c | 5 ++--- |
114 | 4 files changed, 6 insertions(+), 7 deletions(-) | 114 | 4 files changed, 6 insertions(+), 7 deletions(-) |
115 | 115 | ||
116 | diff --git a/coreutils/test.c b/coreutils/test.c | ||
117 | index 868ffbecb..d11fccf5b 100644 | ||
118 | --- a/coreutils/test.c | 116 | --- a/coreutils/test.c |
119 | +++ b/coreutils/test.c | 117 | +++ b/coreutils/test.c |
120 | @@ -401,7 +401,7 @@ struct test_statics { | 118 | @@ -401,7 +401,7 @@ struct test_statics { |
@@ -126,11 +124,9 @@ index 868ffbecb..d11fccf5b 100644 | |||
126 | 124 | ||
127 | #define S (*test_ptr_to_statics) | 125 | #define S (*test_ptr_to_statics) |
128 | #define args (S.args ) | 126 | #define args (S.args ) |
129 | diff --git a/include/libbb.h b/include/libbb.h | ||
130 | index 111d1b790..a52265e77 100644 | ||
131 | --- a/include/libbb.h | 127 | --- a/include/libbb.h |
132 | +++ b/include/libbb.h | 128 | +++ b/include/libbb.h |
133 | @@ -341,7 +341,7 @@ struct BUG_off_t_size_is_misdetected { | 129 | @@ -342,7 +342,7 @@ struct BUG_off_t_size_is_misdetected { |
134 | #if defined(__GLIBC__) | 130 | #if defined(__GLIBC__) |
135 | /* glibc uses __errno_location() to get a ptr to errno */ | 131 | /* glibc uses __errno_location() to get a ptr to errno */ |
136 | /* We can just memorize it once - no multithreading in busybox :) */ | 132 | /* We can just memorize it once - no multithreading in busybox :) */ |
@@ -139,17 +135,15 @@ index 111d1b790..a52265e77 100644 | |||
139 | #undef errno | 135 | #undef errno |
140 | #define errno (*bb_errno) | 136 | #define errno (*bb_errno) |
141 | #endif | 137 | #endif |
142 | @@ -2152,7 +2152,7 @@ struct globals; | 138 | @@ -2168,7 +2168,7 @@ struct globals; |
143 | /* '*const' ptr makes gcc optimize code much better. | 139 | /* '*const' ptr makes gcc optimize code much better. |
144 | * Magic prevents ptr_to_globals from going into rodata. | 140 | * Magic prevents ptr_to_globals from going into rodata. |
145 | * If you want to assign a value, use SET_PTR_TO_GLOBALS(x) */ | 141 | * If you want to assign a value, use SET_PTR_TO_GLOBALS(x) */ |
146 | -extern struct globals *const ptr_to_globals; | 142 | -extern struct globals *const ptr_to_globals; |
147 | +extern struct globals *ptr_to_globals; | 143 | +extern struct globals *ptr_to_globals; |
148 | /* At least gcc 3.4.6 on mipsel system needs optimization barrier */ | 144 | |
149 | #define barrier() __asm__ __volatile__("":::"memory") | 145 | #if defined(__clang_major__) && __clang_major__ >= 9 |
150 | #define SET_PTR_TO_GLOBALS(x) do { \ | 146 | /* Clang/llvm drops assignment to "constant" storage. Silently. |
151 | diff --git a/libbb/lineedit.c b/libbb/lineedit.c | ||
152 | index fbabc6c12..026c42c4c 100644 | ||
153 | --- a/libbb/lineedit.c | 147 | --- a/libbb/lineedit.c |
154 | +++ b/libbb/lineedit.c | 148 | +++ b/libbb/lineedit.c |
155 | @@ -181,7 +181,7 @@ struct lineedit_statics { | 149 | @@ -181,7 +181,7 @@ struct lineedit_statics { |
@@ -161,11 +155,9 @@ index fbabc6c12..026c42c4c 100644 | |||
161 | 155 | ||
162 | #define S (*lineedit_ptr_to_statics) | 156 | #define S (*lineedit_ptr_to_statics) |
163 | #define state (S.state ) | 157 | #define state (S.state ) |
164 | diff --git a/shell/ash.c b/shell/ash.c | ||
165 | index c5588ea66..6f07f7d6d 100644 | ||
166 | --- a/shell/ash.c | 158 | --- a/shell/ash.c |
167 | +++ b/shell/ash.c | 159 | +++ b/shell/ash.c |
168 | @@ -297,10 +297,9 @@ typedef long arith_t; | 160 | @@ -300,10 +300,9 @@ typedef long arith_t; |
169 | * set "-DBB_GLOBAL_CONST=''" in CONFIG_EXTRA_CFLAGS to disable | 161 | * set "-DBB_GLOBAL_CONST=''" in CONFIG_EXTRA_CFLAGS to disable |
170 | * this optimization. | 162 | * this optimization. |
171 | */ | 163 | */ |
@@ -178,6 +170,3 @@ index c5588ea66..6f07f7d6d 100644 | |||
178 | 170 | ||
179 | /* ============ Hash table sizes. Configurable. */ | 171 | /* ============ Hash table sizes. Configurable. */ |
180 | 172 | ||
181 | -- | ||
182 | 2.23.0 | ||
183 | |||
diff --git a/recipes-core/busybox/busybox_1.31.%.bbappend b/recipes-core/busybox/busybox_1.32.%.bbappend index f26df7e..f26df7e 100644 --- a/recipes-core/busybox/busybox_1.31.%.bbappend +++ b/recipes-core/busybox/busybox_1.32.%.bbappend | |||