summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch')
-rw-r--r--recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch b/recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch
new file mode 100644
index 0000000..e22c0bd
--- /dev/null
+++ b/recipes-devtools/clang/clang/0023-fix-path-to-libffi.patch
@@ -0,0 +1,26 @@
1From cbcfe7d13dfc5644c9b8a48e951b43bc15d9f4cf Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Fri, 3 Apr 2020 15:10:37 +0800
4Subject: [PATCH] fix path to libffi
5
6FFI_LIBRARY_PATH is the full path to libffi so when building something that links to
7libLLVMInterpreter, we were looking for libffi in clang's recipe-sysroot instead of
8the recipe's sysroot.
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt b/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
17index 976219830d5e..9930e01559e9 100644
18--- a/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
19+++ b/llvm/lib/ExecutionEngine/Interpreter/CMakeLists.txt
20@@ -22,5 +22,5 @@ add_llvm_component_library(LLVMInterpreter
21 )
22
23 if( LLVM_ENABLE_FFI )
24- target_link_libraries( LLVMInterpreter PRIVATE ${FFI_LIBRARY_PATH} )
25+ target_link_libraries( LLVMInterpreter PRIVATE ffi )
26 endif()