diff options
Diffstat (limited to 'recipes-devtools/clang/clang/0035-Drop-the-git-suffix-from-various-version-variables.patch')
-rw-r--r-- | recipes-devtools/clang/clang/0035-Drop-the-git-suffix-from-various-version-variables.patch | 82 |
1 files changed, 82 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0035-Drop-the-git-suffix-from-various-version-variables.patch b/recipes-devtools/clang/clang/0035-Drop-the-git-suffix-from-various-version-variables.patch new file mode 100644 index 0000000..3ef66d4 --- /dev/null +++ b/recipes-devtools/clang/clang/0035-Drop-the-git-suffix-from-various-version-variables.patch | |||
@@ -0,0 +1,82 @@ | |||
1 | From ae81bf58c31d5c93190c3dd85a4100b86055193a Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Wed, 23 Jun 2021 16:25:06 +0800 | ||
4 | Subject: [PATCH] Drop the 'git' suffix from various version variables | ||
5 | |||
6 | Upstream-Status: Backport [cherry-picked from branch 12.0.0] | ||
7 | |||
8 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | libcxx/CMakeLists.txt | 2 +- | ||
12 | libcxxabi/CMakeLists.txt | 2 +- | ||
13 | libunwind/CMakeLists.txt | 2 +- | ||
14 | llvm/CMakeLists.txt | 2 +- | ||
15 | .../llvm-project-overlay/llvm/include/llvm/Config/llvm-config.h | 2 +- | ||
16 | 5 files changed, 5 insertions(+), 5 deletions(-) | ||
17 | |||
18 | diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt | ||
19 | index 06ee1d74a03e..1ead84c19fcb 100644 | ||
20 | --- a/libcxx/CMakeLists.txt | ||
21 | +++ b/libcxx/CMakeLists.txt | ||
22 | @@ -29,7 +29,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXX_STANDALONE_BUIL | ||
23 | project(libcxx CXX C) | ||
24 | |||
25 | set(PACKAGE_NAME libcxx) | ||
26 | - set(PACKAGE_VERSION 13.0.0git) | ||
27 | + set(PACKAGE_VERSION 13.0.0) | ||
28 | set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}") | ||
29 | set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org") | ||
30 | |||
31 | diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt | ||
32 | index 6a9ba8ec635d..dcd7b8765de3 100644 | ||
33 | --- a/libcxxabi/CMakeLists.txt | ||
34 | +++ b/libcxxabi/CMakeLists.txt | ||
35 | @@ -28,7 +28,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B | ||
36 | project(libcxxabi CXX C) | ||
37 | |||
38 | set(PACKAGE_NAME libcxxabi) | ||
39 | - set(PACKAGE_VERSION 11.0.0git) | ||
40 | + set(PACKAGE_VERSION 11.0.0) | ||
41 | set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}") | ||
42 | set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org") | ||
43 | |||
44 | diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt | ||
45 | index a2c03fd3f8aa..82424253c8da 100644 | ||
46 | --- a/libunwind/CMakeLists.txt | ||
47 | +++ b/libunwind/CMakeLists.txt | ||
48 | @@ -24,7 +24,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBUNWIND_STANDALONE_B | ||
49 | project(libunwind LANGUAGES C CXX ASM) | ||
50 | |||
51 | set(PACKAGE_NAME libunwind) | ||
52 | - set(PACKAGE_VERSION 13.0.0git) | ||
53 | + set(PACKAGE_VERSION 13.0.0) | ||
54 | set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}") | ||
55 | set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org") | ||
56 | |||
57 | diff --git a/llvm/CMakeLists.txt b/llvm/CMakeLists.txt | ||
58 | index 5d3ad7a4fd58..796b47a3d554 100644 | ||
59 | --- a/llvm/CMakeLists.txt | ||
60 | +++ b/llvm/CMakeLists.txt | ||
61 | @@ -20,7 +20,7 @@ if(NOT DEFINED LLVM_VERSION_PATCH) | ||
62 | set(LLVM_VERSION_PATCH 0) | ||
63 | endif() | ||
64 | if(NOT DEFINED LLVM_VERSION_SUFFIX) | ||
65 | - set(LLVM_VERSION_SUFFIX git) | ||
66 | + set(LLVM_VERSION_SUFFIX "") | ||
67 | endif() | ||
68 | |||
69 | if (NOT PACKAGE_VERSION) | ||
70 | diff --git a/utils/bazel/llvm-project-overlay/llvm/include/llvm/Config/llvm-config.h b/utils/bazel/llvm-project-overlay/llvm/include/llvm/Config/llvm-config.h | ||
71 | index ba85df023ae6..f19c22ad13c0 100644 | ||
72 | --- a/utils/bazel/llvm-project-overlay/llvm/include/llvm/Config/llvm-config.h | ||
73 | +++ b/utils/bazel/llvm-project-overlay/llvm/include/llvm/Config/llvm-config.h | ||
74 | @@ -80,7 +80,7 @@ | ||
75 | #define LLVM_VERSION_PATCH 0 | ||
76 | |||
77 | /* LLVM version string */ | ||
78 | -#define LLVM_VERSION_STRING "13.0.0git" | ||
79 | +#define LLVM_VERSION_STRING "13.0.0" | ||
80 | |||
81 | /* Whether LLVM records statistics for use with GetStatistics(), | ||
82 | * PrintStatistics() or PrintStatisticsJSON() | ||