diff options
Diffstat (limited to 'recipes-devtools/clang/compiler-rt_git.bb')
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 40 |
1 files changed, 19 insertions, 21 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 84878aa..080e53b 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -1,7 +1,11 @@ | |||
1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> | 1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | DESCRIPTION = "LLVM based C/C++ compiler Runtime" | 4 | SUMMARY = "LLVM based C/C++ compiler Runtime" |
5 | DESCRIPTIOM = "Simple builtin library that provides an \ | ||
6 | implementation of the low-level target-specific \ | ||
7 | hooks required by code generation and other runtime \ | ||
8 | components" | ||
5 | HOMEPAGE = "http://compiler-rt.llvm.org/" | 9 | HOMEPAGE = "http://compiler-rt.llvm.org/" |
6 | SECTION = "base" | 10 | SECTION = "base" |
7 | 11 | ||
@@ -22,28 +26,19 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
22 | 26 | ||
23 | DEPENDS += "ninja-native libgcc" | 27 | DEPENDS += "ninja-native libgcc" |
24 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc gcc-runtime" | 28 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc gcc-runtime" |
25 | DEPENDS:append:class-nativesdk = " clang-native clang-crosssdk-${SDK_ARCH} nativesdk-gcc-runtime" | 29 | DEPENDS:append:class-nativesdk = " clang-native clang-crosssdk-${SDK_SYS} nativesdk-gcc-runtime" |
26 | DEPENDS:append:class-native = " clang-native" | 30 | DEPENDS:append:class-native = " clang-native" |
27 | 31 | ||
28 | # Trick clang.bbclass into not creating circular dependencies | 32 | # Trick clang.bbclass into not creating circular dependencies |
29 | UNWINDLIB:class-nativesdk = "--unwindlib=libgcc" | 33 | UNWINDLIB:class-nativesdk:toolchain-clang = "--unwindlib=libgcc" |
30 | COMPILER_RT:class-nativesdk:toolchain-clang:runtime-llvm = "-rtlib=libgcc --unwindlib=libgcc" | 34 | COMPILER_RT:class-nativesdk:toolchain-clang = "-rtlib=libgcc --unwindlib=libgcc" |
31 | LIBCPLUSPLUS:class-nativesdk:toolchain-clang:runtime-llvm = "-stdlib=libstdc++" | 35 | LIBCPLUSPLUS:class-nativesdk:toolchain-clang = "-stdlib=libstdc++" |
32 | 36 | UNWINDLIB:class-native:toolchain-clang = "--unwindlib=libgcc" | |
33 | CXXFLAGS += "-stdlib=libstdc++" | 37 | COMPILER_RT:class-native:toolchain-clang = "-rtlib=libgcc --unwindlib=libgcc" |
34 | LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" | 38 | LIBCPLUSPLUS:class-native:toolchain-clang = "-stdlib=libstdc++" |
35 | BUILD_CXXFLAGS += "-stdlib=libstdc++" | 39 | UNWINDLIB:class-target:toolchain-clang = "--unwindlib=libgcc" |
36 | BUILD_LDFLAGS += "-unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" | 40 | COMPILER_RT:class-target:toolchain-clang = "-rtlib=libgcc --unwindlib=libgcc" |
37 | BUILD_CPPFLAGS:remove = "-stdlib=libc++" | 41 | LIBCPLUSPLUS:class-target:toolchain-clang = "-stdlib=libstdc++" |
38 | BUILD_LDFLAGS:remove = "-stdlib=libc++ -lc++abi" | ||
39 | |||
40 | BUILD_CC:toolchain-clang = "${CCACHE}clang" | ||
41 | BUILD_CXX:toolchain-clang = "${CCACHE}clang++" | ||
42 | BUILD_CPP:toolchain-clang = "${CCACHE}clang -E" | ||
43 | BUILD_CCLD:toolchain-clang = "${CCACHE}clang" | ||
44 | BUILD_RANLIB:toolchain-clang = "llvm-ranlib" | ||
45 | BUILD_AR:toolchain-clang = "llvm-ar" | ||
46 | BUILD_NM:toolchain-clang = "llvm-nm" | ||
47 | 42 | ||
48 | PACKAGECONFIG ??= "" | 43 | PACKAGECONFIG ??= "" |
49 | PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" | 44 | PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" |
@@ -128,5 +123,8 @@ BBCLASSEXTEND = "native nativesdk" | |||
128 | ALLOW_EMPTY:${PN} = "1" | 123 | ALLOW_EMPTY:${PN} = "1" |
129 | ALLOW_EMPTY:${PN}-dev = "1" | 124 | ALLOW_EMPTY:${PN}-dev = "1" |
130 | 125 | ||
131 | TOOLCHAIN:forcevariable = "clang" | 126 | TOOLCHAIN = "clang" |
127 | # Overrides defaults from clang.bbclass | ||
128 | TOOLCHAIN:class-nativesdk = "clang" | ||
129 | TOOLCHAIN:class-native = "clang" | ||
132 | SYSROOT_DIRS:append:class-target = " ${nonarch_libdir}" | 130 | SYSROOT_DIRS:append:class-target = " ${nonarch_libdir}" |