summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/llvm-common.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/clang/llvm-common.bb')
-rw-r--r--recipes-devtools/clang/llvm-common.bb22
1 files changed, 0 insertions, 22 deletions
diff --git a/recipes-devtools/clang/llvm-common.bb b/recipes-devtools/clang/llvm-common.bb
deleted file mode 100644
index 893abd1..0000000
--- a/recipes-devtools/clang/llvm-common.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "Helper script for OE's llvm support"
2LICENSE = "Apache-2.0-with-LLVM-exception"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0-with-LLVM-exception;md5=0bcd48c3bdfef0c9d9fd17726e4b7dab"
4
5SRC_URI = "file://llvm-config"
6
7S = "${WORKDIR}"
8
9ALLOW_EMPTY_${PN} = "1"
10SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
11
12llvm_common_sysroot_preprocess() {
13 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
14 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
15}
16
17do_install_class-native() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
20}
21
22BBCLASSEXTEND = "native"