diff options
Diffstat (limited to 'recipes-devtools/spirv-llvm-translator/spirv-llvm-translator/0001-cmake-allow-to-enable-disable-ccache.patch')
-rw-r--r-- | recipes-devtools/spirv-llvm-translator/spirv-llvm-translator/0001-cmake-allow-to-enable-disable-ccache.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator/0001-cmake-allow-to-enable-disable-ccache.patch b/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator/0001-cmake-allow-to-enable-disable-ccache.patch new file mode 100644 index 0000000..68cdda4 --- /dev/null +++ b/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator/0001-cmake-allow-to-enable-disable-ccache.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 13b679eb76e6877b40fd41b91e71cb172bcf7b26 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Thu, 4 Mar 2021 11:23:20 +0800 | ||
4 | Subject: [PATCH] cmake: allow to enable/disable ccache | ||
5 | |||
6 | By default ccache is enabled. | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/930] | ||
9 | |||
10 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
11 | --- | ||
12 | CMakeLists.txt | 3 ++- | ||
13 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
16 | index 0ddb55c..c7d0498 100644 | ||
17 | --- a/CMakeLists.txt | ||
18 | +++ b/CMakeLists.txt | ||
19 | @@ -50,8 +50,9 @@ if(LLVM_SPIRV_BUILD_EXTERNAL) | ||
20 | |||
21 | message(STATUS "Found LLVM: ${LLVM_VERSION}") | ||
22 | |||
23 | + option(CCACHE_ALLOWED "allow use of ccache" TRUE) | ||
24 | find_program(CCACHE_EXE_FOUND ccache) | ||
25 | - if(CCACHE_EXE_FOUND) | ||
26 | + if(CCACHE_EXE_FOUND AND CCACHE_ALLOWED) | ||
27 | message(STATUS "Found ccache: ${CCACHE_EXE_FOUND}") | ||
28 | set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache) | ||
29 | set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache) | ||
30 | -- | ||
31 | 2.17.1 | ||
32 | |||