summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb')
-rw-r--r--recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb b/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb
new file mode 100644
index 0000000..171d54f
--- /dev/null
+++ b/recipes-devtools/spirv-llvm-translator/spirv-llvm-translator_git.bb
@@ -0,0 +1,42 @@
1LICENSE = "NCSA"
2LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=47e311aa9caedd1b3abf098bd7814d1d"
3
4BRANCH = "llvm_release_120"
5SRC_URI = "git://github.com/KhronosGroup/SPIRV-LLVM-Translator/;protocol=https;branch=${BRANCH} \
6 file://0001-Use-12.0.0-for-base-llvm-version.patch \
7 file://0001-cmake-allow-to-enable-disable-ccache.patch \
8 "
9
10PV = "12.0.0"
11SRCREV = "c65388fcd4eac9ce070fc330d5fe263ba2c72d66"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "spirv-tools clang"
16
17inherit cmake pkgconfig python3native
18
19OECMAKE_GENERATOR = "Unix Makefiles"
20
21# Specify any options you want to pass to cmake using EXTRA_OECMAKE:
22EXTRA_OECMAKE = "\
23 -DBUILD_SHARED_LIBS=ON \
24 -DLLVM_SPIRV_BUILD_EXTERNAL=YES \
25 -DCMAKE_BUILD_TYPE=Release \
26 -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
27 -DCMAKE_SKIP_RPATH=ON \
28 -DLLVM_EXTERNAL_LIT=lit \
29 -DLLVM_INCLUDE_TESTS=ON \
30 -Wno-dev \
31 -DCCACHE_ALLOWED=FALSE \
32"
33
34do_compile_append() {
35 oe_runmake llvm-spirv
36}
37
38do_install_append() {
39 install -Dm755 ${B}/tools/llvm-spirv/llvm-spirv ${D}${bindir}/llvm-spirv
40}
41
42BBCLASSEXTEND = "native nativesdk"