diff options
-rw-r--r-- | meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend | 9 |
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend index 296e275..63f6064 100644 --- a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend +++ b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend | |||
@@ -8,7 +8,7 @@ SRC_URI += "file://ops-base.ldif" | |||
8 | LDAP_DN ?= "dc=my-domain,dc=com" | 8 | LDAP_DN ?= "dc=my-domain,dc=com" |
9 | LDAP_DATADIR ?= "/etc/openldap-data/" | 9 | LDAP_DATADIR ?= "/etc/openldap-data/" |
10 | 10 | ||
11 | OPENLDAP_LIBEXECDIR = "/usr/libexec" | 11 | OPENLDAP_LIBEXECDIR = "${libexecdir}" |
12 | 12 | ||
13 | EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}" | 13 | EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}" |
14 | 14 | ||
@@ -16,11 +16,12 @@ do_install_append() { | |||
16 | install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap | 16 | install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap |
17 | sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap | 17 | sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap |
18 | sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap | 18 | sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap |
19 | sed -i -e 's#%LIBEXEC%#${OPENLDAP_LIBEXECDIR}#g' ${D}${sysconfdir}/init.d/openldap | 19 | # Base openldat bb installs slapd under ${sbin} |
20 | sed -i -e 's#%LIBEXEC%#${sbindir}#g' ${D}${sysconfdir}/init.d/openldap | ||
20 | 21 | ||
21 | # This is duplicated in /etc/openldap and is for slapd | 22 | # This is duplicated in /etc/openldap and is for slapd |
22 | rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example | 23 | rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example |
23 | rmdir "${D}${localstatedir}/run" | 24 | rm -rf "${D}${localstatedir}/run" |
24 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | 25 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
25 | 26 | ||
26 | # remove symlinks for backends, recreating in postinstall | 27 | # remove symlinks for backends, recreating in postinstall |
@@ -68,5 +69,5 @@ inherit update-rc.d | |||
68 | INITSCRIPT_NAME = "openldap" | 69 | INITSCRIPT_NAME = "openldap" |
69 | INITSCRIPT_PARAMS = "defaults" | 70 | INITSCRIPT_PARAMS = "defaults" |
70 | 71 | ||
71 | FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/*" | 72 | FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/* ${sysconfdir}/openldap/ops-base.ldif" |
72 | FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug" | 73 | FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug" |