diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2023-02-07 09:39:40 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2023-02-07 11:35:46 +0800 |
commit | bd1b4f10262f12dd66a91383757ccba4eeda0b08 (patch) | |
tree | 0beae7b57cd2a3a368ed981f3d69048b36dc600e | |
parent | c995bda6b6c41953173528e532029ea5ab356e5f (diff) | |
download | meta-dpdk-bd1b4f10262f12dd66a91383757ccba4eeda0b08.tar.gz |
xdp-tools: build static librarylangdale
The problem with shared library is that generated object files are also
required additionally by libxdp. So build the static library instead of
installing .o files as well (which would need us to disable stripping
etc.)
Error log while building libxdp:
| libxdp: Couldn't find a BPF file with name xsk_def_xdp_prog.o
| xsk_configure(): Failed to create xsk socket
Enable production option too. Also see:
https://github.com/xdp-project/xdp-tools/issues/180
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb | 8 |
1 files changed, 3 insertions, 5 deletions
diff --git a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb index 99c435d..7cd49a0 100644 --- a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb +++ b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb | |||
@@ -21,13 +21,11 @@ S = "${WORKDIR}/git" | |||
21 | 21 | ||
22 | inherit pkgconfig | 22 | inherit pkgconfig |
23 | 23 | ||
24 | EXTRA_OEMAKE += "PREFIX=${D}${prefix} LIBDIR=${D}${libdir}" | 24 | EXTRA_OEMAKE += "PREFIX=${D}${prefix} LIBDIR=${D}${libdir} BUILD_STATIC_ONLY=1 PRODUCTION=1" |
25 | 25 | ||
26 | export STAGING_INCDIR | 26 | CFLAGS += "-fPIC" |
27 | 27 | ||
28 | do_configure:prepend () { | 28 | export STAGING_INCDIR |
29 | export DYNAMIC_LIBXDP=1 | ||
30 | } | ||
31 | 29 | ||
32 | do_install () { | 30 | do_install () { |
33 | oe_runmake install | 31 | oe_runmake install |