diff options
3 files changed, 0 insertions, 107 deletions
diff --git a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch deleted file mode 100644 index 55f0c15..0000000 --- a/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 4a86048d44cae812b227b857772aeeb839502706 Mon Sep 17 00:00:00 2001 | ||
2 | From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> | ||
3 | Date: Fri, 2 Sep 2016 15:48:52 +0800 | ||
4 | Subject: [PATCH] dpdk: fix for parellel make issue | ||
5 | |||
6 | To make sure that the path of libraries should be correct and | ||
7 | libraries will be build before, And available at the time of | ||
8 | linking example apps. | ||
9 | |||
10 | Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> | ||
11 | |||
12 | --- | ||
13 | examples/Makefile | 1 + | ||
14 | examples/ethtool/ethtool-app/Makefile | 1 + | ||
15 | 2 files changed, 2 insertions(+) | ||
16 | |||
17 | diff --git a/examples/Makefile b/examples/Makefile | ||
18 | index 17ecf7f64cda..2a8e805b85a7 100644 | ||
19 | --- a/examples/Makefile | ||
20 | +++ b/examples/Makefile | ||
21 | @@ -41,6 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_BBDEV) += bbdev_app | ||
22 | DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond | ||
23 | DIRS-y += cmdline | ||
24 | DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor | ||
25 | +DEPDIRS-y += examples/ethtool/lib | ||
26 | DIRS-y += ethtool | ||
27 | DIRS-y += exception_path | ||
28 | DIRS-$(CONFIG_RTE_LIBRTE_EFD) += server_node_efd | ||
29 | diff --git a/examples/ethtool/ethtool-app/Makefile b/examples/ethtool/ethtool-app/Makefile | ||
30 | index 4cd9efdd574b..d3c709ab2fef 100644 | ||
31 | --- a/examples/ethtool/ethtool-app/Makefile | ||
32 | +++ b/examples/ethtool/ethtool-app/Makefile | ||
33 | @@ -19,6 +19,7 @@ SRCS-y := main.c ethapp.c | ||
34 | CFLAGS += -O3 -D_GNU_SOURCE -pthread -I$(SRCDIR)/../lib | ||
35 | CFLAGS += $(WERROR_FLAGS) | ||
36 | |||
37 | +LDLIBS += -L$(ETHTOOL_LIB_PATH)/ | ||
38 | LDLIBS += -L$(subst ethtool-app,lib,$(RTE_OUTPUT))/lib | ||
39 | LDLIBS += -lrte_ethtool | ||
40 | |||
diff --git a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch b/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch deleted file mode 100644 index 70a8dec..0000000 --- a/recipes-extended/dpdk/dpdk/dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From a385972c3675dd2b4792ab5b3cf7a536e6f9846c Mon Sep 17 00:00:00 2001 | ||
2 | From: Reshma Pattan <reshma.pattan@intel.com> | ||
3 | Date: Thu, 2 May 2019 10:33:34 +0100 | ||
4 | Subject: [PATCH] mk: disable warning for packed member pointer | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | gcc 9 on Fedora 30 gives an error | ||
10 | "taking address of packed member may result in an | ||
11 | unaligned pointer value" warnings. | ||
12 | |||
13 | For clang builds this warning is already disabled, | ||
14 | so disable "-Waddress-of-packed-member" for gcc builds | ||
15 | also. | ||
16 | |||
17 | Snippet of build error: | ||
18 | lib/librte_eal/linux/eal/eal_memalloc.c: In function ‘alloc_seg_walk’: | ||
19 | lib/librte_eal/linux/eal/eal_memalloc.c:768:12: error: | ||
20 | taking address of packed member of ‘struct rte_mem_config’ may result | ||
21 | in an unaligned pointer value [-Werror=address-of-packed-member] | ||
22 | 768 | cur_msl = &mcfg->memsegs[msl_idx]; | ||
23 | | ^~~~~~~~~~~~~~~~~~~~~~~ | ||
24 | |||
25 | Signed-off-by: Reshma Pattan <reshma.pattan@intel.com> | ||
26 | Tested-by: David Marchand <david.marchand@redhat.com> | ||
27 | Upstream-Status: Backport | ||
28 | Signed-off-by: He Zhe <zhe.he@windriver.com> | ||
29 | --- | ||
30 | mk/toolchain/gcc/rte.vars.mk | 3 +++ | ||
31 | 1 file changed, 3 insertions(+) | ||
32 | |||
33 | diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk | ||
34 | index d8b99fa..b852fcf 100644 | ||
35 | --- a/mk/toolchain/gcc/rte.vars.mk | ||
36 | +++ b/mk/toolchain/gcc/rte.vars.mk | ||
37 | @@ -87,5 +87,8 @@ WERROR_FLAGS += -Wimplicit-fallthrough=2 | ||
38 | WERROR_FLAGS += -Wno-format-truncation | ||
39 | endif | ||
40 | |||
41 | +# disable packed member unalign warnings | ||
42 | +WERROR_FLAGS += -Wno-address-of-packed-member | ||
43 | + | ||
44 | export CC AS AR LD OBJCOPY OBJDUMP STRIP READELF | ||
45 | export TOOLCHAIN_CFLAGS TOOLCHAIN_LDFLAGS TOOLCHAIN_ASFLAGS | ||
46 | -- | ||
47 | 2.7.4 | ||
48 | |||
diff --git a/recipes-extended/dpdk/dpdk_17.11.8.bb b/recipes-extended/dpdk/dpdk_17.11.8.bb deleted file mode 100644 index 004e185..0000000 --- a/recipes-extended/dpdk/dpdk_17.11.8.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | include dpdk.inc | ||
2 | |||
3 | STABLE = "-stable" | ||
4 | BRANCH = "17.11" | ||
5 | SRCREV = "25d4497a91d2631397e541a32381c51cd4cdd2f3" | ||
6 | |||
7 | LICENSE = "LGPLv2 & GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe\ | ||
9 | file://LICENSE.LGPL;md5=4fbd65380cdd255951079008b364516c" | ||
10 | |||
11 | SRC_URI += "\ | ||
12 | file://dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch \ | ||
13 | file://dpdk-17.11-mk-disable-warning-for-packed-member-pointer.patch \ | ||
14 | " | ||
15 | |||
16 | do_install_append () { | ||
17 | # Remove the unneeded dir | ||
18 | rm -rf ${D}/${INSTALL_PATH}/${RTE_TARGET}/app | ||
19 | } | ||