diff options
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/dpdk/dpdk-module_20.11.6.bb (renamed from recipes-extended/dpdk/dpdk-module_20.11.5.bb) | 3 | ||||
-rw-r--r-- | recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch | 44 |
2 files changed, 1 insertions, 46 deletions
diff --git a/recipes-extended/dpdk/dpdk-module_20.11.5.bb b/recipes-extended/dpdk/dpdk-module_20.11.6.bb index 64defa8..29b055d 100644 --- a/recipes-extended/dpdk/dpdk-module_20.11.5.bb +++ b/recipes-extended/dpdk/dpdk-module_20.11.6.bb | |||
@@ -4,11 +4,10 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/dpdk:" | |||
4 | 4 | ||
5 | SRC_URI += " \ | 5 | SRC_URI += " \ |
6 | file://0001-Makefile-add-makefile.patch \ | 6 | file://0001-Makefile-add-makefile.patch \ |
7 | file://0002-kni-update-kernel-API-to-set-random-MAC-address.patch \ | ||
8 | " | 7 | " |
9 | STABLE = "-stable" | 8 | STABLE = "-stable" |
10 | BRANCH = "20.11" | 9 | BRANCH = "20.11" |
11 | SRCREV = "abf68ccc8b1f923f0eb0b6bf2a8b944378e1ebeb" | 10 | SRCREV = "73655c6414914c99a33010e9e7bdae9cafd24404" |
12 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
13 | 12 | ||
14 | inherit module | 13 | inherit module |
diff --git a/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch b/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch deleted file mode 100644 index dea9e12..0000000 --- a/recipes-extended/dpdk/dpdk/0002-kni-update-kernel-API-to-set-random-MAC-address.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From e0a23f3cf8410871d28fdd8f0806216848b357ce Mon Sep 17 00:00:00 2001 | ||
2 | From: Ferruh Yigit <ferruh.yigit@intel.com> | ||
3 | Date: Wed, 3 Nov 2021 12:59:50 +0000 | ||
4 | Subject: [PATCH] kni: update kernel API to set random MAC address | ||
5 | |||
6 | Previously used 'random_ether_addr()' API is removed in upstream kernel | ||
7 | with commit | ||
8 | Commit ba530fea8ca1 ("ethernet: remove random_ether_addr()") | ||
9 | |||
10 | Replacement API 'eth_random_addr()' is around since v3.6 [1], so | ||
11 | simply switching to this API without any version checks. | ||
12 | |||
13 | [1] | ||
14 | 0a4dd594982a ("etherdevice: Rename random_ether_addr to eth_random_addr") | ||
15 | |||
16 | Signed-off-by: Ferruh Yigit <ferruh.yigit@intel.com> | ||
17 | |||
18 | Upstream-Status: Backport [http://git.dpdk.org/dpdk/commit/?id=e6cbfd9bf30bbc4170fe8c7c04a16d9cf795fb90] | ||
19 | Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> | ||
20 | --- | ||
21 | kernel/linux/kni/kni_misc.c | 7 ++----- | ||
22 | 1 file changed, 2 insertions(+), 5 deletions(-) | ||
23 | |||
24 | diff --git a/kernel/linux/kni/kni_misc.c b/kernel/linux/kni/kni_misc.c | ||
25 | index 2b464c4381..f4944e1ddf 100644 | ||
26 | --- a/kernel/linux/kni/kni_misc.c | ||
27 | +++ b/kernel/linux/kni/kni_misc.c | ||
28 | @@ -399,11 +399,8 @@ kni_ioctl_create(struct net *net, uint32_t ioctl_num, | ||
29 | if (is_valid_ether_addr(dev_info.mac_addr)) | ||
30 | memcpy(net_dev->dev_addr, dev_info.mac_addr, ETH_ALEN); | ||
31 | else | ||
32 | - /* | ||
33 | - * Generate random mac address. eth_random_addr() is the | ||
34 | - * newer version of generating mac address in kernel. | ||
35 | - */ | ||
36 | - random_ether_addr(net_dev->dev_addr); | ||
37 | + /* Generate random MAC address. */ | ||
38 | + eth_random_addr(net_dev->dev_addr); | ||
39 | |||
40 | if (dev_info.mtu) | ||
41 | net_dev->mtu = dev_info.mtu; | ||
42 | -- | ||
43 | 2.32.0 | ||
44 | |||