diff options
author | Bogdan Oprescu <bogdan.oprescu@enea.com> | 2022-06-17 15:44:46 +0000 |
---|---|---|
committer | Bogdan Oprescu <bogdan.oprescu@enea.com> | 2022-08-02 09:44:43 +0200 |
commit | ce0397ba44158ff139c3d1bb98a81c29ff07aa99 (patch) | |
tree | 022ff9b550ef7dd70a52e25ceca0ff4f96743aba | |
parent | f1460b7ddf19fa67e8c8c822fd5e98cf7dac2d06 (diff) | |
download | meta-el-common-ce0397ba44158ff139c3d1bb98a81c29ff07aa99.tar.gz |
Update layer for kirkstone build
Change-Id: Iaf8381bd4e43bdbcae44325627ed99ebec3f6a34
Signed-off-by: Bogdan Oprescu <bogdan.oprescu@enea.com>
-rw-r--r-- | conf/distro/include/enea-mirrors.inc | 2 | ||||
-rw-r--r-- | conf/layer.conf | 2 | ||||
-rw-r--r-- | images/enea-image-extra.inc | 2 | ||||
-rw-r--r-- | recipes-connectivity/connman/connman_%.bbappend | 6 | ||||
-rw-r--r-- | recipes-core/busybox/busybox_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend | 2 | ||||
-rw-r--r-- | recipes-enea/bitcalc/bitcalc_1.0.bb | 6 | ||||
-rw-r--r-- | recipes-enea/linx/linx-mod_2.6.7.bb | 2 | ||||
-rw-r--r-- | recipes-enea/linx/linx.inc | 2 | ||||
-rw-r--r-- | recipes-extended/ltp/ltp_%.bbappend | 2 |
10 files changed, 14 insertions, 14 deletions
diff --git a/conf/distro/include/enea-mirrors.inc b/conf/distro/include/enea-mirrors.inc index ead2d72..3084f21 100644 --- a/conf/distro/include/enea-mirrors.inc +++ b/conf/distro/include/enea-mirrors.inc | |||
@@ -1,6 +1,6 @@ | |||
1 | MIRROR_ENEA_DISTRO = "${@d.getVar('DISTRO_NAME').replace(" ","")}${@d.getVar('DISTRO_VERSION_MAJOR').replace(" ","")}${@d.getVar('DISTRO_VERSION_MINOR').replace(" ","")}" | 1 | MIRROR_ENEA_DISTRO = "${@d.getVar('DISTRO_NAME').replace(" ","")}${@d.getVar('DISTRO_VERSION_MAJOR').replace(" ","")}${@d.getVar('DISTRO_VERSION_MINOR').replace(" ","")}" |
2 | 2 | ||
3 | MIRRORS_append = "\ | 3 | MIRRORS:append = "\ |
4 | cvs://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ | 4 | cvs://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ |
5 | svn://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ | 5 | svn://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ |
6 | git://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ | 6 | git://.*/.* http://linux.enea.com/${MIRROR_ENEA_DISTRO}/sources/ \n \ |
diff --git a/conf/layer.conf b/conf/layer.conf index 8884cca..69e8654 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -11,4 +11,4 @@ BBFILE_COLLECTIONS += "el-common" | |||
11 | BBFILE_PATTERN_el-common = "^${LAYERDIR}/" | 11 | BBFILE_PATTERN_el-common = "^${LAYERDIR}/" |
12 | BBFILE_PRIORITY_el-common = "5" | 12 | BBFILE_PRIORITY_el-common = "5" |
13 | 13 | ||
14 | LAYERSERIES_COMPAT_el-common = "dunfell zeus" | 14 | LAYERSERIES_COMPAT_el-common = "dunfell zeus kirkstone" |
diff --git a/images/enea-image-extra.inc b/images/enea-image-extra.inc index 98a88cb..c6ef28f 100644 --- a/images/enea-image-extra.inc +++ b/images/enea-image-extra.inc | |||
@@ -21,7 +21,7 @@ SDKIMAGE_FEATURES += " \ | |||
21 | 21 | ||
22 | IMAGE_INSTALL += " \ | 22 | IMAGE_INSTALL += " \ |
23 | binutils \ | 23 | binutils \ |
24 | dhcp-client \ | 24 | dhcpcd \ |
25 | fuse \ | 25 | fuse \ |
26 | gnutls \ | 26 | gnutls \ |
27 | kernel-dev \ | 27 | kernel-dev \ |
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend index a32d4b3..8e6a7ef 100644 --- a/recipes-connectivity/connman/connman_%.bbappend +++ b/recipes-connectivity/connman/connman_%.bbappend | |||
@@ -1,10 +1,10 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/connman:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/connman:" |
2 | 2 | ||
3 | SRC_URI += "file://0001-added-noipconfig-option.patch \ | 3 | SRC_URI += "file://0001-added-noipconfig-option.patch \ |
4 | file://connman.patch \ | 4 | file://connman.patch \ |
5 | " | 5 | " |
6 | 6 | ||
7 | python do_patch_prepend() { | 7 | python do_patch:prepend() { |
8 | import shutil | 8 | import shutil |
9 | workdir = d.getVar('WORKDIR', True) | 9 | workdir = d.getVar('WORKDIR', True) |
10 | source = d.getVar('S', True) | 10 | source = d.getVar('S', True) |
@@ -12,7 +12,7 @@ python do_patch_prepend() { | |||
12 | } | 12 | } |
13 | 13 | ||
14 | 14 | ||
15 | python do_patch_append() { | 15 | python do_patch:append() { |
16 | import shutil | 16 | import shutil |
17 | workdir = d.getVar('WORKDIR', True) | 17 | workdir = d.getVar('WORKDIR', True) |
18 | source = d.getVar('S', True) | 18 | source = d.getVar('S', True) |
diff --git a/recipes-core/busybox/busybox_%.bbappend b/recipes-core/busybox/busybox_%.bbappend index 7b61cf9..01d3379 100644 --- a/recipes-core/busybox/busybox_%.bbappend +++ b/recipes-core/busybox/busybox_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | do_prepare_config_append () { | 1 | do_prepare_config:append () { |
2 | sed -i -e 's/# CONFIG_CHRT is not set/CONFIG_CHRT=y/' .config | 2 | sed -i -e 's/# CONFIG_CHRT is not set/CONFIG_CHRT=y/' .config |
3 | sed -i -e 's/# CONFIG_TASKSET is not set/CONFIG_TASKSET=y/' .config | 3 | sed -i -e 's/# CONFIG_TASKSET is not set/CONFIG_TASKSET=y/' .config |
4 | sed -i -e 's/# CONFIG_FEATURE_TASKSET_FANCY is not set/CONFIG_FEATURE_TASKSET_FANCY=y/' .config | 4 | sed -i -e 's/# CONFIG_FEATURE_TASKSET_FANCY is not set/CONFIG_FEATURE_TASKSET_FANCY=y/' .config |
diff --git a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend index c800e85..3187b1f 100644 --- a/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend +++ b/recipes-devtools/run-postinsts/run-postinsts_1.0.bbappend | |||
@@ -1,5 +1,5 @@ | |||
1 | 1 | ||
2 | do_install_append() { | 2 | do_install:append() { |
3 | # Don't run 'dpkg --configure' for debs, because it is already executed by a | 3 | # Don't run 'dpkg --configure' for debs, because it is already executed by a |
4 | # service included in the dpkg recipe | 4 | # service included in the dpkg recipe |
5 | if ${@bb.utils.contains('PACKAGE_CLASSES', 'package_deb', 'true', 'false', d)}; then | 5 | if ${@bb.utils.contains('PACKAGE_CLASSES', 'package_deb', 'true', 'false', d)}; then |
diff --git a/recipes-enea/bitcalc/bitcalc_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb index c59cbb5..89096c4 100644 --- a/recipes-enea/bitcalc/bitcalc_1.0.bb +++ b/recipes-enea/bitcalc/bitcalc_1.0.bb | |||
@@ -9,7 +9,7 @@ PR = "r0" | |||
9 | DEPENDS = "gcc-sanitizers" | 9 | DEPENDS = "gcc-sanitizers" |
10 | RDEPENDS_${PN} = "bash" | 10 | RDEPENDS_${PN} = "bash" |
11 | 11 | ||
12 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}" | 12 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | 14 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ |
15 | file://0001-bitcalc-resolved-compilation-warnings.patch \ | 15 | file://0001-bitcalc-resolved-compilation-warnings.patch \ |
@@ -17,8 +17,8 @@ SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | |||
17 | file://0001-Fix-implicit-fallthrough-warnings.patch \ | 17 | file://0001-Fix-implicit-fallthrough-warnings.patch \ |
18 | " | 18 | " |
19 | 19 | ||
20 | DEPENDS_remove_aarch64 = "gcc-sanitizers" | 20 | DEPENDS:remove:aarch64 = "gcc-sanitizers" |
21 | SRC_URI_append_aarch64 = "file://0001-bitcalc-disable-gcc-address-sanitizer.patch" | 21 | SRC_URI:append:aarch64 = "file://0001-bitcalc-disable-gcc-address-sanitizer.patch" |
22 | 22 | ||
23 | SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a" | 23 | SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a" |
24 | 24 | ||
diff --git a/recipes-enea/linx/linx-mod_2.6.7.bb b/recipes-enea/linx/linx-mod_2.6.7.bb index 9bcf459..ae2e33f 100644 --- a/recipes-enea/linx/linx-mod_2.6.7.bb +++ b/recipes-enea/linx/linx-mod_2.6.7.bb | |||
@@ -19,7 +19,7 @@ S = "${WORKDIR}/linx-${PV}/net/linx" | |||
19 | 19 | ||
20 | inherit module | 20 | inherit module |
21 | 21 | ||
22 | module_do_compile_prepend () { | 22 | module_do_compile:prepend () { |
23 | 23 | ||
24 | if [ -z $(cat ${STAGING_KERNEL_BUILDDIR}/.config | grep "CONFIG_MODULES=y") ] ; then | 24 | if [ -z $(cat ${STAGING_KERNEL_BUILDDIR}/.config | grep "CONFIG_MODULES=y") ] ; then |
25 | echo "The specified Linux kernel has no support for pluggable modules (CONFIG_MODULES=y). Enable it before baking this." | 25 | echo "The specified Linux kernel has no support for pluggable modules (CONFIG_MODULES=y). Enable it before baking this." |
diff --git a/recipes-enea/linx/linx.inc b/recipes-enea/linx/linx.inc index 3388964..4b8ad56 100644 --- a/recipes-enea/linx/linx.inc +++ b/recipes-enea/linx/linx.inc | |||
@@ -15,7 +15,7 @@ S = "${WORKDIR}/linx-${PV}" | |||
15 | 15 | ||
16 | inherit autotools-brokensep | 16 | inherit autotools-brokensep |
17 | 17 | ||
18 | do_install_append () { | 18 | do_install:append () { |
19 | mkdir -p ${D}/etc | 19 | mkdir -p ${D}/etc |
20 | install -m 644 ${S}/linxgw/linxgws/example.conf ${D}/etc/linxgws.conf | 20 | install -m 644 ${S}/linxgw/linxgws/example.conf ${D}/etc/linxgws.conf |
21 | } | 21 | } |
diff --git a/recipes-extended/ltp/ltp_%.bbappend b/recipes-extended/ltp/ltp_%.bbappend index 59a4341..3c9ad05 100644 --- a/recipes-extended/ltp/ltp_%.bbappend +++ b/recipes-extended/ltp/ltp_%.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | do_compile_prepend () { | 1 | do_compile:prepend () { |
2 | ( make -C ${B}/testcases/open_posix_testsuite generate-makefiles conformance-all tools-all functional-all stress-all ) | 2 | ( make -C ${B}/testcases/open_posix_testsuite generate-makefiles conformance-all tools-all functional-all stress-all ) |
3 | } | 3 | } |