summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBogdan Oprescu <bogdan.oprescu@enea.com>2024-08-12 08:55:41 +0200
committerBogdan Oprescu <bogdan.oprescu@enea.com>2024-10-23 10:38:42 +0200
commit0e13e28d689ea8e5a8dd3f1ed80bee7e065f6d14 (patch)
treea97ad48bcc20b73bb8597aaa3e19a14fc9bee0b2
parentd6d26a8e8de787fd59fed6f7a3c1bd06f156e931 (diff)
downloadmeta-el-common-0e13e28d689ea8e5a8dd3f1ed80bee7e065f6d14.tar.gz
Add qemu support in scarthgapscarthgap
Change-Id: I50f975edfee9878af35fc9e6e34ad07f7851dfc8 Signed-off-by: Bogdan Oprescu <bogdan.oprescu@enea.com>
-rw-r--r--conf/distro/enea.conf6
-rw-r--r--recipes-enea/bitcalc/bitcalc_1.0.bb2
-rw-r--r--recipes-enea/count-ticks/count-ticks_1.1.bb2
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb2
4 files changed, 6 insertions, 6 deletions
diff --git a/conf/distro/enea.conf b/conf/distro/enea.conf
index 487521d..a8588f8 100644
--- a/conf/distro/enea.conf
+++ b/conf/distro/enea.conf
@@ -1,7 +1,7 @@
1require conf/distro/poky.conf 1require conf/distro/poky.conf
2DISTRO = "enea" 2DISTRO = "enea"
3DISTRO_NAME = "Enea Linux" 3DISTRO_NAME = "Enea Linux"
4DISTRO_VERSION_MAJOR = "8.4" 4DISTRO_VERSION_MAJOR = "9.0"
5DISTRO_VERSION_MINOR ??= "" 5DISTRO_VERSION_MINOR ??= ""
6DISTRO_VERSION = "${DISTRO_VERSION_MAJOR}${DISTRO_VERSION_MINOR}" 6DISTRO_VERSION = "${DISTRO_VERSION_MAJOR}${DISTRO_VERSION_MINOR}"
7 7
@@ -25,8 +25,8 @@ PRSERV_HOST ?= "localhost:0"
25BB_DANGLINGAPPENDS_WARNONLY ?= "1" 25BB_DANGLINGAPPENDS_WARNONLY ?= "1"
26 26
27PREFERRED_VERSION_linux-yocto = "6.8%" 27PREFERRED_VERSION_linux-yocto = "6.8%"
28PREFERRED_VERSION_linux-yocto:qemux86 = "6.8" 28PREFERRED_VERSION_linux-yocto:qemux86 = "6.6%"
29PREFERRED_VERSION_linux-yocto:qemux86-64 = "6.8%" 29PREFERRED_VERSION_linux-yocto:qemux86-64 = "6.6%"
30PREFERRED_VERSION_linux-yocto:qemuarm = "6.8%" 30PREFERRED_VERSION_linux-yocto:qemuarm = "6.8%"
31PREFERRED_VERSION_linux-yocto:qemumips = "6.8%" 31PREFERRED_VERSION_linux-yocto:qemumips = "6.8%"
32PREFERRED_VERSION_linux-yocto:qemumips64 = "6.8%" 32PREFERRED_VERSION_linux-yocto:qemumips64 = "6.8%"
diff --git a/recipes-enea/bitcalc/bitcalc_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb
index 2cfa879..5030c32 100644
--- a/recipes-enea/bitcalc/bitcalc_1.0.bb
+++ b/recipes-enea/bitcalc/bitcalc_1.0.bb
@@ -11,7 +11,7 @@ RDEPENDS:${PN} = "bash"
11 11
12FILESEXTRAPATHS:append := "${THISDIR}/${PN}" 12FILESEXTRAPATHS:append := "${THISDIR}/${PN}"
13 13
14SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 14SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \
15 file://0001-bitcalc-resolved-compilation-warnings.patch \ 15 file://0001-bitcalc-resolved-compilation-warnings.patch \
16 file://0001-bitcalc-resolved-memory-leaks.patch \ 16 file://0001-bitcalc-resolved-memory-leaks.patch \
17 file://0001-Fix-implicit-fallthrough-warnings.patch \ 17 file://0001-Fix-implicit-fallthrough-warnings.patch \
diff --git a/recipes-enea/count-ticks/count-ticks_1.1.bb b/recipes-enea/count-ticks/count-ticks_1.1.bb
index a33a0f9..29950c0 100644
--- a/recipes-enea/count-ticks/count-ticks_1.1.bb
+++ b/recipes-enea/count-ticks/count-ticks_1.1.bb
@@ -8,7 +8,7 @@ PR = "r1"
8 8
9RDEPENDS_${PN} = "bash" 9RDEPENDS_${PN} = "bash"
10 10
11SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 11SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \
12 file://run-ptest \ 12 file://run-ptest \
13 " 13 "
14 14
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
index 89863b4..430a6a9 100644
--- a/recipes-enea/partrt/partrt_1.1.bb
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
7RDEPENDS_${PN} = "bash coreutils" 7RDEPENDS_${PN} = "bash coreutils"
8RDEPENDS_${PN}-ptest += "python" 8RDEPENDS_${PN}-ptest += "python"
9 9
10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \
11 file://run-ptest \ 11 file://run-ptest \
12 " 12 "
13 13