diff options
author | Bogdan Oprescu <bogdan.oprescu@enea.com> | 2024-08-12 08:55:41 +0200 |
---|---|---|
committer | Bogdan Oprescu <bogdan.oprescu@enea.com> | 2024-10-23 10:38:42 +0200 |
commit | 0e13e28d689ea8e5a8dd3f1ed80bee7e065f6d14 (patch) | |
tree | a97ad48bcc20b73bb8597aaa3e19a14fc9bee0b2 | |
parent | d6d26a8e8de787fd59fed6f7a3c1bd06f156e931 (diff) | |
download | meta-el-common-0e13e28d689ea8e5a8dd3f1ed80bee7e065f6d14.tar.gz |
Add qemu support in scarthgapscarthgap
Change-Id: I50f975edfee9878af35fc9e6e34ad07f7851dfc8
Signed-off-by: Bogdan Oprescu <bogdan.oprescu@enea.com>
-rw-r--r-- | conf/distro/enea.conf | 6 | ||||
-rw-r--r-- | recipes-enea/bitcalc/bitcalc_1.0.bb | 2 | ||||
-rw-r--r-- | recipes-enea/count-ticks/count-ticks_1.1.bb | 2 | ||||
-rw-r--r-- | recipes-enea/partrt/partrt_1.1.bb | 2 |
4 files changed, 6 insertions, 6 deletions
diff --git a/conf/distro/enea.conf b/conf/distro/enea.conf index 487521d..a8588f8 100644 --- a/conf/distro/enea.conf +++ b/conf/distro/enea.conf | |||
@@ -1,7 +1,7 @@ | |||
1 | require conf/distro/poky.conf | 1 | require conf/distro/poky.conf |
2 | DISTRO = "enea" | 2 | DISTRO = "enea" |
3 | DISTRO_NAME = "Enea Linux" | 3 | DISTRO_NAME = "Enea Linux" |
4 | DISTRO_VERSION_MAJOR = "8.4" | 4 | DISTRO_VERSION_MAJOR = "9.0" |
5 | DISTRO_VERSION_MINOR ??= "" | 5 | DISTRO_VERSION_MINOR ??= "" |
6 | DISTRO_VERSION = "${DISTRO_VERSION_MAJOR}${DISTRO_VERSION_MINOR}" | 6 | DISTRO_VERSION = "${DISTRO_VERSION_MAJOR}${DISTRO_VERSION_MINOR}" |
7 | 7 | ||
@@ -25,8 +25,8 @@ PRSERV_HOST ?= "localhost:0" | |||
25 | BB_DANGLINGAPPENDS_WARNONLY ?= "1" | 25 | BB_DANGLINGAPPENDS_WARNONLY ?= "1" |
26 | 26 | ||
27 | PREFERRED_VERSION_linux-yocto = "6.8%" | 27 | PREFERRED_VERSION_linux-yocto = "6.8%" |
28 | PREFERRED_VERSION_linux-yocto:qemux86 = "6.8" | 28 | PREFERRED_VERSION_linux-yocto:qemux86 = "6.6%" |
29 | PREFERRED_VERSION_linux-yocto:qemux86-64 = "6.8%" | 29 | PREFERRED_VERSION_linux-yocto:qemux86-64 = "6.6%" |
30 | PREFERRED_VERSION_linux-yocto:qemuarm = "6.8%" | 30 | PREFERRED_VERSION_linux-yocto:qemuarm = "6.8%" |
31 | PREFERRED_VERSION_linux-yocto:qemumips = "6.8%" | 31 | PREFERRED_VERSION_linux-yocto:qemumips = "6.8%" |
32 | PREFERRED_VERSION_linux-yocto:qemumips64 = "6.8%" | 32 | PREFERRED_VERSION_linux-yocto:qemumips64 = "6.8%" |
diff --git a/recipes-enea/bitcalc/bitcalc_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb index 2cfa879..5030c32 100644 --- a/recipes-enea/bitcalc/bitcalc_1.0.bb +++ b/recipes-enea/bitcalc/bitcalc_1.0.bb | |||
@@ -11,7 +11,7 @@ RDEPENDS:${PN} = "bash" | |||
11 | 11 | ||
12 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}" | 12 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | 14 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \ |
15 | file://0001-bitcalc-resolved-compilation-warnings.patch \ | 15 | file://0001-bitcalc-resolved-compilation-warnings.patch \ |
16 | file://0001-bitcalc-resolved-memory-leaks.patch \ | 16 | file://0001-bitcalc-resolved-memory-leaks.patch \ |
17 | file://0001-Fix-implicit-fallthrough-warnings.patch \ | 17 | file://0001-Fix-implicit-fallthrough-warnings.patch \ |
diff --git a/recipes-enea/count-ticks/count-ticks_1.1.bb b/recipes-enea/count-ticks/count-ticks_1.1.bb index a33a0f9..29950c0 100644 --- a/recipes-enea/count-ticks/count-ticks_1.1.bb +++ b/recipes-enea/count-ticks/count-ticks_1.1.bb | |||
@@ -8,7 +8,7 @@ PR = "r1" | |||
8 | 8 | ||
9 | RDEPENDS_${PN} = "bash" | 9 | RDEPENDS_${PN} = "bash" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | 11 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \ |
12 | file://run-ptest \ | 12 | file://run-ptest \ |
13 | " | 13 | " |
14 | 14 | ||
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb index 89863b4..430a6a9 100644 --- a/recipes-enea/partrt/partrt_1.1.bb +++ b/recipes-enea/partrt/partrt_1.1.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4" | |||
7 | RDEPENDS_${PN} = "bash coreutils" | 7 | RDEPENDS_${PN} = "bash coreutils" |
8 | RDEPENDS_${PN}-ptest += "python" | 8 | RDEPENDS_${PN}-ptest += "python" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ | 10 | SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master;protocol=https \ |
11 | file://run-ptest \ | 11 | file://run-ptest \ |
12 | " | 12 | " |
13 | 13 | ||