summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo M. Duarte <rodrigo.duarte@ossystems.com.br>2025-04-04 14:37:36 -0300
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2025-04-15 20:47:38 +0000
commitf20149f587b7615090bb6beb3e71f485320103ad (patch)
treeebba78f56e1e2810c1d196c8c261069baaf5358e
parent9653ba32642d372ba21c9b5a95fc86aa70471331 (diff)
downloadmeta-freescale-f20149f587b7615090bb6beb3e71f485320103ad.tar.gz
u-boot-imx: Update source revision to e3219a5a734backport-2193-to-styhead
This commit update the u-boot-imx source revision and modify the recipe. e3219a5a734 LFU-832 imx8mp_evk: Burn the GP5_LOCK fuse at u-boot booting d3e281dde15 LFU-828 imx8m: soc: update vc8000e name d5f33691793 LF-14347: armv8/ls216xardb: sync RCWSR12 status in DCSR with CCSR 6dd466b4be5 LF-14440 iMX93/91: Fix isi kernel DTS node change in 6.12.y 81880df2d5b Pull request #150: MA-23272 [Android] Fix imx8mq can't boot without rpmb key 23fdab12bb7 Pull request #149: Encapsulate rbidx blob 0bc715c1f5e MA-23272 [Android] Fix imx8mq can't boot without rpmb key f9da896ed60 MA-23256 Add "rbidx_blob" defconfig for all i.MX 8 platforms de0d5a51933 MA-23203 Encapsulate the bootloader rollback index as a blob 23dc1f2a865 MA-23254 force assign secure memory to linux d592d6a16ec MA-23233-2 Load SRM before loading kernel f6bc9fb487a MA-23233 Support to provision SRM f7d5db534e9 LFU-823: configs: ls1088aqds: Add CONFIG_SYS_FLASH_CFI_WIDTH setting 3de49b5ebdd LF-13763-3 verdin-imx95: do the power cycle and reset to NETC 33776efa47d LF-13763-2 imx95_evk: do the power cycle and reset to NETC b40ee795724 LF-13763-1 net: fsl_enetc: Workaround XPCS issue on RX path 1d00ea83d9c Pull request #146: MA-23207 Generate the rpmb key blob before setting rpmb key 3bde1db8f1d MA-23207 Generate the rpmb key blob before setting rpmb key 22aa45c4587 LFU-824: board: freescale: ls1088a: add one more ifc-nor node to check ef9d27bf23c LFU-822 imx9: soc: Fix Declaring variable assignedparentclks without initializer 4493beff522 LFU-821 imx9: scmi: Fix Uninitialized scalar variable 7c14ad40a1b LFU-820 imx8m: Update DDR timing for iMX8M Series EVK boards cfd2f117d05 LFU-817 iMX95: Fixup kernel and uboot dtb based on fuses e5621fee8c3 LFU-818-02 imx9: Update frequency and parent of MEDIA_APB in LD mode ec735c88014 LFU-818-01 arm: dts: imx91: Update MEDIA_APB clock to 125Mhz b5ae121cede LF-13724-2 usb: xhci-imx8m: set USB_PWR pad to GPIO mode before boot linux 603c298ad53 LF-13724-1 imx8mp_evk: add "gpio" pinctrl for usb_dwc3_1 3da403c8843 LFU-819 imx95: verdin: switch to jh_root_mem 4b321a11fac MA-23157 android: Deprecate AVB_HASHTREE_ERROR_MODE_RESTART_AND_INVALIDATE Signed-off-by: Rodrigo M. Duarte <rodrigo.duarte@ossystems.com.br> (cherry picked from commit 16071e42d0b5e66a31d89eb296e9239da051b663)
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc8
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2024.04.bb4
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc b/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc
index 39ac4135..01e3bbca 100644
--- a/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc
+++ b/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc
@@ -3,11 +3,11 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
3LICENSE = "GPL-2.0-or-later" 3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5 5
6SRC_URI = "git://github.com/nxp-imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" 6SRC_URI = "${UBOOT_SRC};branch=${SRCBRANCH}"
7UBOOT_SRC ?= "git://github.com/nxp-imx/uboot-imx.git;protocol=https"
7SRCBRANCH = "lf_v2024.04" 8SRCBRANCH = "lf_v2024.04"
8LOCALVERSION ?= "-imx_v2024.04_6.6.52-2.2.0" 9LOCALVERSION ?= "-${SRCBRANCH}"
9SRCREV = "6c4545203d123c246c5d7995f2893959506d28e0" 10SRCREV = "e3219a5a73445219df605d1492687918d488055c"
10CVE_PRODUCT = "nxp:uboot_secondary_program_loader denx:u-boot"
11 11
12DEPENDS += " \ 12DEPENDS += " \
13 bc-native \ 13 bc-native \
diff --git a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
index 29d83527..69598780 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb
@@ -1,6 +1,6 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor 1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA. 2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright (C) 2017-2024 NXP 3# Copyright 2017-2024 NXP
4 4
5require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common_${PV}.inc 6require u-boot-imx-common_${PV}.inc
@@ -14,6 +14,8 @@ inherit uuu_bootloader_tag
14UUU_BOOTLOADER:mx8-generic-bsp = "" 14UUU_BOOTLOADER:mx8-generic-bsp = ""
15UUU_BOOTLOADER:mx9-generic-bsp = "" 15UUU_BOOTLOADER:mx9-generic-bsp = ""
16 16
17TOOLCHAIN_OPTIONS:append = " -Wno-error=implicit-function-declaration"
18
17do_deploy:append:mx8m-generic-bsp() { 19do_deploy:append:mx8m-generic-bsp() {
18 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
19 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]