diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2024-06-13 10:07:02 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2024-06-18 19:06:13 -0300 |
commit | 34723ef209c77ab2ca848833c986d4cff4e47ec4 (patch) | |
tree | 763047f82c6165d01fcc88044116c954da421f55 | |
parent | 556c09ef7192485a16d94b1c1f4b3c08a50edf2a (diff) | |
download | meta-freescale-34723ef209c77ab2ca848833c986d4cff4e47ec4.tar.gz |
imx-vpuwrap: fix compile time error
GCC-14 set more warnings to errors, patch the code so it compiles.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
(cherry picked from commit 1261040dba21994131ef519012ee4c35bf2cd9f9)
-rw-r--r-- | recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch | 28 | ||||
-rw-r--r-- | recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb | 5 |
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch new file mode 100644 index 00000000..459d8626 --- /dev/null +++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 482c639a0da4b093cfc029009604e9653ced33c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Thu, 13 Jun 2024 07:15:12 +0000 | ||
4 | Subject: [PATCH] vpu_wrapper_hantro_encoder: add sys/time.h for gettimeofday | ||
5 | |||
6 | Fixes: | ||
7 | | ../git/vpu_wrapper_hantro_encoder.c:953:3: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration] | ||
8 | |||
9 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
10 | --- | ||
11 | vpu_wrapper_hantro_encoder.c | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/vpu_wrapper_hantro_encoder.c b/vpu_wrapper_hantro_encoder.c | ||
15 | index 3819c389320c..635c98bf1f19 100755 | ||
16 | --- a/vpu_wrapper_hantro_encoder.c | ||
17 | +++ b/vpu_wrapper_hantro_encoder.c | ||
18 | @@ -24,6 +24,7 @@ | ||
19 | #include <stdlib.h> | ||
20 | #include <string.h> | ||
21 | #include <time.h> | ||
22 | +#include <sys/time.h> | ||
23 | #include <semaphore.h> | ||
24 | |||
25 | #include "headers/OMX_Video.h" | ||
26 | -- | ||
27 | 2.42.0 | ||
28 | |||
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb index af15e7b1..bae9c928 100644 --- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb +++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb | |||
@@ -10,7 +10,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2827219e81f28aba7c6a569f7c437fa7" | |||
10 | DEPENDS = "virtual/imxvpu" | 10 | DEPENDS = "virtual/imxvpu" |
11 | DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" | 11 | DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}" | 13 | SRC_URI = " \ |
14 | git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ | ||
15 | file://0001-vpu_wrapper_hantro_encoder-add-sys-time.h-for-gettim.patch \ | ||
16 | " | ||
14 | SRCBRANCH = "MM_04.08.03_2312_L6.6.y" | 17 | SRCBRANCH = "MM_04.08.03_2312_L6.6.y" |
15 | SRCREV = "f974cecdb00b4a214e4b5229f2279e772ee43306" | 18 | SRCREV = "f974cecdb00b4a214e4b5229f2279e772ee43306" |
16 | 19 | ||