summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-08-13 08:56:03 -0300
committerGitHub <noreply@github.com>2024-08-13 08:56:03 -0300
commitc525e0c19bdc46d45f71873b5f286f49abb69418 (patch)
treeec02420ee13e01c881767f5a6e4abc295109caf2
parent4c81b4161b99698b03332842b588dd8235ac47e4 (diff)
parentff7b5099bcb7a5d723c1808c2c15e42b5ed030f7 (diff)
downloadmeta-freescale-c525e0c19bdc46d45f71873b5f286f49abb69418.tar.gz
Merge pull request #1892 from sashko/kirkstone
Cherry-pick Qt 6 patches
-rw-r--r--conf/layer.conf3
-rw-r--r--dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend54
-rw-r--r--dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend6
3 files changed, 63 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 5ff2839d..387460c1 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -54,6 +54,9 @@ BBFILES_DYNAMIC += " \
54 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \ 54 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bb \
55 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \ 55 qt5-layer:${LAYERDIR}/dynamic-layers/qt5-layer/*/*/*.bbappend \
56 \ 56 \
57 qt6-layer:${LAYERDIR}/dynamic-layers/qt6-layer/*/*/*.bb \
58 qt6-layer:${LAYERDIR}/dynamic-layers/qt6-layer/*/*/*.bbappend \
59 \
57 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \ 60 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bb \
58 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \ 61 virtualization-layer:${LAYERDIR}/dynamic-layers/virtualization-layer/*/*/*.bbappend \
59" 62"
diff --git a/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend
new file mode 100644
index 00000000..1c51fc09
--- /dev/null
+++ b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtbase_%.bbappend
@@ -0,0 +1,54 @@
1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
2# Copyright (C) 2016 Freescale Semiconductor
3# Copyright (C) 2016, 2017 O.S. Systems Software LTDA.
4# Copyright (C) 2017-2018 NXP
5
6PACKAGECONFIG_GRAPHICS:imxpxp = " \
7 gles2"
8PACKAGECONFIG_GRAPHICS:imxgpu2d = " \
9 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)} \
10 ${PACKAGECONFIG_GRAPHICS_IMX_GPU}"
11PACKAGECONFIG_GRAPHICS:imxgpu3d = " \
12 gles2 \
13 ${PACKAGECONFIG_GRAPHICS_IMX_GPU}"
14PACKAGECONFIG_GRAPHICS_IMX_GPU = ""
15PACKAGECONFIG_GRAPHICS_IMX_GPU:mx8-nxp-bsp = " \
16 gbm kms"
17
18PACKAGECONFIG_GRAPHICS:use-mainline-bsp ?= " \
19 gles2 gbm kms"
20
21PACKAGECONFIG += " \
22 ${PACKAGECONFIG_PLATFORM}"
23
24PACKAGECONFIG_PLATFORM = ""
25PACKAGECONFIG_PLATFORM:imxgpu2d = " \
26 no-opengl \
27 linuxfb \
28 ${PACKAGECONFIG_PLATFORM_EGLFS}"
29PACKAGECONFIG_PLATFORM:imxgpu3d = " \
30 ${PACKAGECONFIG_PLATFORM_EGLFS}"
31
32PACKAGECONFIG_PLATFORM_EGLFS = ""
33PACKAGECONFIG_PLATFORM_EGLFS:imxgpu3d = " \
34 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
35 bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
36 'eglfs', d), d)}"
37PACKAGECONFIG_PLATFORM_EGLFS:mx8-nxp-bsp = " \
38 eglfs"
39
40PACKAGECONFIG_PLATFORM:use-mainline-bsp = " \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'eglfs', d)}"
42
43PACKAGECONFIG += " \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '${PACKAGECONFIG_WAYLAND}', '', d)}"
45PACKAGECONFIG_WAYLAND = "wayland"
46
47PACKAGECONFIG += " \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', '${PACKAGECONFIG_VULKAN}', '', d)}"
49PACKAGECONFIG_VULKAN = ""
50PACKAGECONFIG_VULKAN:imxgpu = " \
51 ${PACKAGECONFIG_VULKAN_IMX_GPU}"
52PACKAGECONFIG_VULKAN_IMX_GPU = ""
53PACKAGECONFIG_VULKAN_IMX_GPU:mx8-nxp-bsp = "vulkan"
54PACKAGECONFIG_VULKAN_IMX_GPU:mx8mm-nxp-bsp = ""
diff --git a/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend
new file mode 100644
index 00000000..ca011758
--- /dev/null
+++ b/dynamic-layers/qt6-layer/recipes-qt/qt6/qtwayland_%.bbappend
@@ -0,0 +1,6 @@
1# etnaviv mesa does not have glx
2PACKAGECONFIG:remove:use-mainline-bsp = "xcomposite-glx"
3
4PACKAGECONFIG:remove:mx6-nxp-bsp = "xcomposite-egl xcomposite-glx"
5PACKAGECONFIG:remove:mx7-nxp-bsp = "xcomposite-egl xcomposite-glx"
6PACKAGECONFIG:remove:mx8-nxp-bsp = "xcomposite-egl xcomposite-glx"