summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitor Soares <vitor.soares@toradex.com>2025-04-30 16:06:11 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2025-05-05 16:03:29 +0000
commita12537fc428da40e4ccc8394edcb1ba40b9d24e0 (patch)
tree67b7963f99a1e3a92060d1abeadbc8fd3704777b
parentf52fe2b709e70d1d864adfad2754213bce7abcd7 (diff)
downloadmeta-freescale-a12537fc428da40e4ccc8394edcb1ba40b9d24e0.tar.gz
kernel-module-nxp-wlan: add patch to lower PRINTM_MMSG() log level
Add a patch to change the log level used in the mwifiex driver's PRINTM_MMSG macro from KERN_ALERT to KERN_INFO. KERN_ALERT is meant for critical errors; using it for debug messages clutters logs. KERN_INFO is more appropriate for non-critical informational output. Signed-off-by: Vitor Soares <vitor.soares@toradex.com> (cherry picked from commit 6876b4fe789854f60765a4174e4838d298d19395)
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp-wlan/mlinux-moal_main-lower-PRINTM_MMSG-log-level-to-KERN_INFO.patch36
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/mlinux-moal_main-lower-PRINTM_MMSG-log-level-to-KERN_INFO.patch b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/mlinux-moal_main-lower-PRINTM_MMSG-log-level-to-KERN_INFO.patch
new file mode 100644
index 00000000..bb54750a
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/mlinux-moal_main-lower-PRINTM_MMSG-log-level-to-KERN_INFO.patch
@@ -0,0 +1,36 @@
1From b1b218757973fd6a293de5bdbdc75307db07998e Mon Sep 17 00:00:00 2001
2From: Vitor Soares <vitor.soares@toradex.com>
3Date: Wed, 30 Apr 2025 15:12:06 +0100
4Subject: [PATCH] mlinux: moal_main: lower PRINTM_MMSG() log level to KERN_INFO
5
6Currently, the PRINTM_MMSG macro uses KERN_ALERT for printing messages.
7KERN_ALERT is intended for critical conditions requiring immediate
8attention (e.g., hardware failure), and using it for normal debug output
9is misleading and can clutter system logs.
10
11This patch lowers the log level to KERN_INFO, which is more appropriate
12for informational messages that are not indicative of system-critical
13failures.
14
15Upstream-Status: Inappropriate [upstream not accepting patches]
16Signed-off-by: Vitor Soares <vitor.soares@toradex.com>
17---
18 mlinux/moal_main.h | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/mlinux/moal_main.h b/mlinux/moal_main.h
22index 6d87dcf4f5db..b4e7e4d4a5fd 100644
23--- a/mlinux/moal_main.h
24+++ b/mlinux/moal_main.h
25@@ -3517,7 +3517,7 @@ extern t_u32 drvdbg;
26 do { \
27 woal_print(level, msg); \
28 if (drvdbg & MMSG) \
29- printk(KERN_ALERT msg); \
30+ printk(KERN_INFO msg); \
31 } while (0)
32
33 static inline void woal_print(t_u32 level, char *fmt, ...)
34--
352.34.1
36
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
index cb47756c..e0790bd2 100644
--- a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
@@ -13,6 +13,7 @@ MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https"
13SRC_URI = " \ 13SRC_URI = " \
14 ${MRVL_SRC};branch=${SRCBRANCH} \ 14 ${MRVL_SRC};branch=${SRCBRANCH} \
15 file://wlan_src_driver_patch_release_lf-6.6.52-2.2.0.patch \ 15 file://wlan_src_driver_patch_release_lf-6.6.52-2.2.0.patch \
16 file://mlinux-moal_main-lower-PRINTM_MMSG-log-level-to-KERN_INFO.patch \
16" 17"
17SRCREV = "5ad19e194f49ed9447bee7864eb562618ccaf9b1" 18SRCREV = "5ad19e194f49ed9447bee7864eb562618ccaf9b1"
18 19