diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-04-28 12:52:19 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-04-28 12:52:19 -0300 |
commit | df2f3b068f51d0ce4fca8752c07761eea43c5d4e (patch) | |
tree | e05b4e944cb3492cdcc125d12368d765425c271b | |
parent | fe533cd4b95b6d3c88b6f553684a06c07c48a7bf (diff) | |
parent | e70573421b71279bddb816bf75d00a204740decb (diff) | |
download | meta-freescale-df2f3b068f51d0ce4fca8752c07761eea43c5d4e.tar.gz |
Merge pull request #2220 from tq-steina/scarthgap-imx-cst
Restore imx-cst in scarthgap again
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb new file mode 100644 index 00000000..0e0ebc6e --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "i.MX code signing tool" | ||
2 | DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library" | ||
3 | SECTION = "cst" | ||
4 | LICENSE = "BSD-3-Clause & Apache-2.0" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://LICENSE.bsd3;md5=14aba05f9fa6c25527297c8aac95fcf6 \ | ||
8 | file://LICENSE.hidapi;md5=e0ea014f523f64f0adb13409055ee59e \ | ||
9 | file://LICENSE.openssl;md5=3441526b1df5cc01d812c7dfc218cea6 \ | ||
10 | " | ||
11 | |||
12 | DEPENDS = "byacc-native flex-native openssl" | ||
13 | |||
14 | # debian: 3.4.0+dfsg-2 | ||
15 | DEBIAN_PGK_NAME = "imx-code-signing-tool" | ||
16 | DEBIAN_PGK_VERSION = "${PV}+dfsg" | ||
17 | |||
18 | SRC_URI = "\ | ||
19 | ${DEBIAN_MIRROR}/main/i/${DEBIAN_PGK_NAME}/${DEBIAN_PGK_NAME}_${DEBIAN_PGK_VERSION}.orig.tar.xz \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[sha256sum] = "52ee3cee3bc500a42095f73c4584e223b4b9d2dfc1cd3e5df965c5952eba8c8d" | ||
23 | |||
24 | S = "${WORKDIR}/${DEBIAN_PGK_NAME}-${DEBIAN_PGK_VERSION}" | ||
25 | |||
26 | EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"' | ||
27 | |||
28 | do_compile() { | ||
29 | oe_runmake -C code/obj.linux64 OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}" | ||
30 | oe_runmake -C add-ons/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" | ||
31 | } | ||
32 | |||
33 | do_install () { | ||
34 | install -d ${D}${bindir} | ||
35 | install -m 755 ${S}/code/obj.linux64/cst ${D}${bindir}/ | ||
36 | install -m 755 ${S}/code/obj.linux64/srktool ${D}${bindir} | ||
37 | install -m 755 ${S}/add-ons/hab_csf_parser/csf_parser ${D}${bindir} | ||
38 | } | ||
39 | |||
40 | BBCLASSEXTEND = "native nativesdk" | ||