summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Stein <alexander.stein@ew.tq-group.com>2025-04-28 15:48:27 +0200
committerAlexander Stein <alexander.stein@ew.tq-group.com>2025-04-28 15:50:24 +0200
commite70573421b71279bddb816bf75d00a204740decb (patch)
tree485f3bd666dfce8dcbd6dd17bd56006156a9478e
parent93ad3d265a0a95986f4e47e7001e0b1f1c6edbf1 (diff)
downloadmeta-freescale-e70573421b71279bddb816bf75d00a204740decb.tar.gz
Revert "imx-cst: Remove it now that it is in meta-oe"
meta-oe includes imx-cst only in styhead and above branches, but not in scarthgap. Revert the removal in order to provide imx-cst for scarthgap as well. This reverts commit 448312c35ca20d40ebfc515317246f6c227cdcf9. Signed-off-by: Alexander Stein <alexander.stein@ew.tq-group.com>
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
new file mode 100644
index 00000000..0e0ebc6e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.4.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "i.MX code signing tool"
2DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library"
3SECTION = "cst"
4LICENSE = "BSD-3-Clause & Apache-2.0"
5
6LIC_FILES_CHKSUM = "\
7 file://LICENSE.bsd3;md5=14aba05f9fa6c25527297c8aac95fcf6 \
8 file://LICENSE.hidapi;md5=e0ea014f523f64f0adb13409055ee59e \
9 file://LICENSE.openssl;md5=3441526b1df5cc01d812c7dfc218cea6 \
10"
11
12DEPENDS = "byacc-native flex-native openssl"
13
14# debian: 3.4.0+dfsg-2
15DEBIAN_PGK_NAME = "imx-code-signing-tool"
16DEBIAN_PGK_VERSION = "${PV}+dfsg"
17
18SRC_URI = "\
19 ${DEBIAN_MIRROR}/main/i/${DEBIAN_PGK_NAME}/${DEBIAN_PGK_NAME}_${DEBIAN_PGK_VERSION}.orig.tar.xz \
20"
21
22SRC_URI[sha256sum] = "52ee3cee3bc500a42095f73c4584e223b4b9d2dfc1cd3e5df965c5952eba8c8d"
23
24S = "${WORKDIR}/${DEBIAN_PGK_NAME}-${DEBIAN_PGK_VERSION}"
25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"'
27
28do_compile() {
29 oe_runmake -C code/obj.linux64 OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}"
30 oe_runmake -C add-ons/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
31}
32
33do_install () {
34 install -d ${D}${bindir}
35 install -m 755 ${S}/code/obj.linux64/cst ${D}${bindir}/
36 install -m 755 ${S}/code/obj.linux64/srktool ${D}${bindir}
37 install -m 755 ${S}/add-ons/hab_csf_parser/csf_parser ${D}${bindir}
38}
39
40BBCLASSEXTEND = "native nativesdk"