summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErnest Van Hoecke <ernest.vanhoecke@toradex.com>2025-04-24 15:42:39 +0200
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2025-04-25 16:12:49 +0000
commit039aacf10d89d068157b754360a0e8c57c4af8a1 (patch)
tree4344c5c06b198bce054443c67818d3e6c42fbb39
parent49183ed0c97b6e280e5a8c22e5eb793e62c157fe (diff)
downloadmeta-freescale-039aacf10d89d068157b754360a0e8c57c4af8a1.tar.gz
imx-boot: add LPDDR_FW_VERSION to mkimage arguments for iMX95
For the iMX95 it can be necessary to use a different DDR FW version than the one selected by default by the mkimage build. You might need newer FW binaries while still supporting an older NXP BSP. Pass LPDDR_FW_VERSION to make if it is set, otherwise do nothing such that the Makefile selects its default value just like before. When using a different FW version without setting LPDDR_FW_VERSION accordingly you will get a build error similar to the below: ``` | DEBUG: Executing shell function do_compile | NOTE: UBOOT_CONFIG = sd, UBOOT_DTB_NAME = | NOTE: i.MX 95 boot binary build | NOTE: i.MX 93 boot binary build | NOTE: Copy ddr_firmware: lpddr4x_dmem_v202409.bin from $BUILD_PATH/deploy/images/verdin-imx95 -> $BUILD_PATH/tmp/work/verdin_imx95-tdx-linux/imx-boot/1.0/git/iMX95 [...] | make[1]: *** No rule to make target 'lpddr4x_imem_v202311.bin', needed by 'm33-oei-ddrfw.bin'. Stop. ``` Above we are using `lpddr4x_imem_v202409.bin` but mkimage is not aware without this fix and setting LPDDR_FW_VERSION (i.e.: in the machine conf). Signed-off-by: Ernest Van Hoecke <ernest.vanhoecke@toradex.com> (cherry picked from commit 4f9e481e131aa7190535579e7ea208abf641bf8f)
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index 9d20aff3..7f2739f4 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -78,6 +78,7 @@ MKIMAGE_EXTRA_ARGS ?= ""
78MKIMAGE_EXTRA_ARGS:mx95-nxp-bsp ?= " \ 78MKIMAGE_EXTRA_ARGS:mx95-nxp-bsp ?= " \
79 OEI=${OEI_ENABLE} \ 79 OEI=${OEI_ENABLE} \
80 LPDDR_TYPE=${DDR_TYPE} \ 80 LPDDR_TYPE=${DDR_TYPE} \
81 ${@'LPDDR_FW_VERSION='+d.getVar('LPDDR_FW_VERSION') if d.getVar('LPDDR_FW_VERSION') else ''} \
81 ${@bb.utils.contains('SYSTEM_MANAGER_CONFIG', 'mx95alt', 'MSEL=1', '', d)}" 82 ${@bb.utils.contains('SYSTEM_MANAGER_CONFIG', 'mx95alt', 'MSEL=1', '', d)}"
82MKIMAGE_EXTRA_ARGS:imx95-19x19-verdin ?= " \ 83MKIMAGE_EXTRA_ARGS:imx95-19x19-verdin ?= " \
83 ${MKIMAGE_EXTRA_ARGS:mx95-nxp-bsp} \ 84 ${MKIMAGE_EXTRA_ARGS:mx95-nxp-bsp} \