summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2025-04-17 07:52:57 -0300
committerGitHub <noreply@github.com>2025-04-17 07:52:57 -0300
commit7220c7dff7bac05338dc19fd7894ef9bc56fa648 (patch)
treee6cd13f733539913189cfbd536ae19f137a91200
parent6decb130bd7847bd33a00a8a3c094fb076cb29a4 (diff)
parent106cc43ee3f5f6669794871fe81731f9abe94975 (diff)
downloadmeta-freescale-7220c7dff7bac05338dc19fd7894ef9bc56fa648.tar.gz
Merge pull request #2203 from Freescale/backport-2201-to-styhead
[Backport styhead] fix(opencv): do not try to install sample files
-rw-r--r--recipes-support/opencv/opencv_4.6.0.imx.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-support/opencv/opencv_4.6.0.imx.bb b/recipes-support/opencv/opencv_4.6.0.imx.bb
index 3afa2522..fe10da39 100644
--- a/recipes-support/opencv/opencv_4.6.0.imx.bb
+++ b/recipes-support/opencv/opencv_4.6.0.imx.bb
@@ -302,10 +302,12 @@ EXTRA_OECMAKE:append = " -DBUILD_opencv_cvv=OFF"
302 302
303do_install:append() { 303do_install:append() {
304 ln -sf opencv4/opencv2 ${D}${includedir}/opencv2 304 ln -sf opencv4/opencv2 ${D}${includedir}/opencv2
305 install -d ${D}${datadir}/OpenCV/samples/data 305 if ${@bb.utils.contains('PACKAGECONFIG', 'samples', 'true', 'false', d)}; then
306 cp -r ${S}/samples/data/* ${D}${datadir}/OpenCV/samples/data 306 install -d ${D}${datadir}/OpenCV/samples/data
307 install -d ${D}${datadir}/OpenCV/samples/bin/ 307 cp -r ${S}/samples/data/* ${D}${datadir}/OpenCV/samples/data
308 cp -f bin/example_* ${D}${datadir}/OpenCV/samples/bin/ 308 install -d ${D}${datadir}/OpenCV/samples/bin/
309 cp -f bin/example_* ${D}${datadir}/OpenCV/samples/bin/
310 fi
309 if ${@bb.utils.contains('PACKAGECONFIG', 'tests-imx', 'true', 'false', d)}; then 311 if ${@bb.utils.contains('PACKAGECONFIG', 'tests-imx', 'true', 'false', d)}; then
310 cp -r share/opencv4/testdata/cv/face/* ${D}${datadir}/opencv4/testdata/cv/face/ 312 cp -r share/opencv4/testdata/cv/face/* ${D}${datadir}/opencv4/testdata/cv/face/
311 fi 313 fi