diff options
author | Florian Vallee <fvallee@eukrea.fr> | 2015-06-24 11:27:02 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-03 14:33:54 -0300 |
commit | 0cfd36df4ebd246d872c1452bf93a14e21408d58 (patch) | |
tree | e4cc203e2cc83cf154b3658027449568ac1f52b6 | |
parent | 21c8b02665f9f2b175dcd73a4b35d932991ecee5 (diff) | |
download | meta-freescale-0cfd36df4ebd246d872c1452bf93a14e21408d58.tar.gz |
amd-gpu-x11-mx51: use x11 compatible eglplatform.h
Freescale's default eglplatform.h contains framebuffer headers while
X11 compatible headers are located in eglplatform_1.4.h [1], therefore
overwrite eglplatform.h with eglplatform_1.4.h during install.
This fixes EGL on X support through xcb.
For instance Qt5 would fail to enable CFG_EGL_X [2] due to the
following build error during configure :
invalid conversion from 'EGLNativeDisplayType {aka void*}' to
'Display* {aka _XDisplay*}' [-fpermissive]
This further resulted in a runtime error with Qt5_CinematicExperience:
QXcbIntegration: Cannot create platform OpenGL context, neither GLX
nor EGL are enabled
[1]: http://lists.busybox.net/pipermail/buildroot/2014-November/111475.html
[2]: https://codereview.qt-project.org/#/c/77523/
Signed-off-by: Florian Vallee <fvallee@eukrea.fr>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | meta-fsl-arm/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-fsl-arm/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/meta-fsl-arm/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb index d5dc8a8f..7fc351b0 100644 --- a/meta-fsl-arm/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb +++ b/meta-fsl-arm/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | |||
@@ -17,3 +17,9 @@ SRC_URI[sha256sum] = "c7a6fa03b7aa2a375556c59908876554ba720c1e744baba2debb84a408 | |||
17 | RCONFLICTS_${PN} = "amd-gpu-bin-mx51" | 17 | RCONFLICTS_${PN} = "amd-gpu-bin-mx51" |
18 | 18 | ||
19 | COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" | 19 | COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" |
20 | |||
21 | do_install_append() { | ||
22 | # eglplatform_1.4.h contains X11 compatible headers | ||
23 | rm ${D}${includedir}/EGL/eglplatform.h | ||
24 | mv ${D}${includedir}/EGL/eglplatform_1.4.h ${D}${includedir}/EGL/eglplatform.h | ||
25 | } | ||