diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-07-10 17:45:09 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-13 14:00:59 -0300 |
commit | 0e62e2e1fe38aff6a27921fd382e6dfd346654d5 (patch) | |
tree | 1967bbf608ea651eb0a4a2ead44c177dba4d99b8 | |
parent | 4e762924b52dd72af348c77850defacf5f89c37b (diff) | |
download | meta-freescale-0e62e2e1fe38aff6a27921fd382e6dfd346654d5.tar.gz |
u-boot-ls1: merge u-boot-ls1.inc into recipe
There is no benefit to having a separate .inc file when we only support one
version of u-boot-ls1.
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1.inc | 17 | ||||
-rw-r--r-- | meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb | 20 |
2 files changed, 18 insertions, 19 deletions
diff --git a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1.inc b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1.inc deleted file mode 100644 index ccd37c6f..00000000 --- a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1.inc +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards" | ||
2 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" | ||
3 | LIC_FILES_CHKSUM = " \ | ||
4 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
5 | file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \ | ||
6 | file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \ | ||
7 | file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
8 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ | ||
9 | " | ||
10 | |||
11 | SRCBRANCH = "sdk-v1.7.x" | ||
12 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" | ||
13 | SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" | ||
14 | |||
15 | LOCALVERSION ?= "-${SRCBRANCH}" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
diff --git a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb index 010d2cc2..ad1dd4b9 100644 --- a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb +++ b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb | |||
@@ -1,9 +1,25 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | 1 | require recipes-bsp/u-boot/u-boot.inc |
2 | require u-boot-ls1.inc | 2 | |
3 | inherit fsl-u-boot-localversion | 3 | DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards" |
4 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \ | ||
8 | file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \ | ||
9 | file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
10 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ | ||
11 | " | ||
12 | |||
13 | SRCBRANCH = "sdk-v1.7.x" | ||
14 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" | ||
15 | SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" | ||
4 | 16 | ||
5 | LOCALVERSION ?= "-${SRCBRANCH}" | 17 | LOCALVERSION ?= "-${SRCBRANCH}" |
6 | 18 | ||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | inherit fsl-u-boot-localversion | ||
22 | |||
7 | DEPENDS += "change-file-endianess-native" | 23 | DEPENDS += "change-file-endianess-native" |
8 | PROVIDES += "u-boot" | 24 | PROVIDES += "u-boot" |
9 | 25 | ||