diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-09-13 07:18:28 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-09-13 07:18:28 -0300 |
commit | 27684f03ee2efb10a99c4ebf8aa8a9980209038f (patch) | |
tree | 0209a07b77eabdf3418e3bd4279bde20c212e585 | |
parent | 8326241876794812434f74ed3fd3ea766eebf79c (diff) | |
parent | 0dad0e1e9d075a957cf334e68ec5f09afeb3c2bd (diff) | |
download | meta-freescale-27684f03ee2efb10a99c4ebf8aa8a9980209038f.tar.gz |
Merge pull request #1205 from YoeDistro/yoe/mut
gstreamer1.0-plugins-base: Fix build with clang
4 files changed, 86 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch b/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch new file mode 100644 index 00000000..b9cb31fb --- /dev/null +++ b/recipes-graphics/wayland/weston/0001-g2d-renderer.c-Include-sys-stat.h.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 4afe9b2f9ef24ce0c9bf1cd41f94ca45afa4f445 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 12 Sep 2022 20:58:14 -0700 | ||
4 | Subject: [PATCH] g2d-renderer.c: Include sys/stat.h | ||
5 | |||
6 | This is needed for getting stat() prototype, its flagged with clang-15 | ||
7 | as error. | ||
8 | |||
9 | | ../git/libweston/renderer-g2d/g2d-renderer.c:2057:6: error: call to undeclared function 'stat'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration] | ||
10 | | if (stat(gr->drm_device, &dev_stat) != 0) { | ||
11 | | ^ | ||
12 | | 1 error generated. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | libweston/renderer-g2d/g2d-renderer.c | 1 + | ||
18 | 1 file changed, 1 insertion(+) | ||
19 | |||
20 | diff --git a/libweston/renderer-g2d/g2d-renderer.c b/libweston/renderer-g2d/g2d-renderer.c | ||
21 | index f59fc4ee..36a458fc 100644 | ||
22 | --- a/libweston/renderer-g2d/g2d-renderer.c | ||
23 | +++ b/libweston/renderer-g2d/g2d-renderer.c | ||
24 | @@ -41,6 +41,7 @@ | ||
25 | #include <drm_fourcc.h> | ||
26 | #include <poll.h> | ||
27 | #include <errno.h> | ||
28 | +#include <sys/stat.h> /* stat() */ | ||
29 | |||
30 | #include <libweston/libweston.h> | ||
31 | #include "g2d-renderer.h" | ||
32 | -- | ||
33 | 2.37.3 | ||
34 | |||
diff --git a/recipes-graphics/wayland/weston_10.0.0.imx.bb b/recipes-graphics/wayland/weston_10.0.0.imx.bb index 8fce4472..a9f6ec13 100644 --- a/recipes-graphics/wayland/weston_10.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_10.0.0.imx.bb | |||
@@ -160,7 +160,9 @@ DEFAULT_PREFERENCE = "-1" | |||
160 | 160 | ||
161 | SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" | 161 | SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" |
162 | SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " | 162 | SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " |
163 | SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch" | 163 | SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch \ |
164 | file://0001-g2d-renderer.c-Include-sys-stat.h.patch \ | ||
165 | " | ||
164 | SRCBRANCH = "weston-imx-10.0" | 166 | SRCBRANCH = "weston-imx-10.0" |
165 | SRCREV = "c8c6e3106b03441db1037afa995f95fcb2f9f17d" | 167 | SRCREV = "c8c6e3106b03441db1037afa995f95fcb2f9f17d" |
166 | 168 | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch new file mode 100644 index 00000000..19057147 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 071fd005ad6572767d7441c97549b1c904719944 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 12 Sep 2022 20:29:25 -0700 | ||
4 | Subject: [PATCH] gstallocatorphymem.c: Typecast result of gst_phymem_get_phy | ||
5 | to guintptr | ||
6 | |||
7 | This fixes a warning/error found with clang-15 | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | gst-libs/gst/allocators/gstallocatorphymem.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | --- a/gst-libs/gst/allocators/gstallocatorphymem.c | ||
16 | +++ b/gst-libs/gst/allocators/gstallocatorphymem.c | ||
17 | @@ -225,7 +225,7 @@ static guintptr | ||
18 | gst_allocator_phymem_get_phys_addr (GstPhysMemoryAllocator * allocator, | ||
19 | GstMemory * mem) | ||
20 | { | ||
21 | - return gst_phymem_get_phy (mem); | ||
22 | + return (guintptr)gst_phymem_get_phy (mem); | ||
23 | } | ||
24 | |||
25 | static void | ||
26 | --- a/gst-libs/gst/gl/gstglphymemory.c | ||
27 | +++ b/gst-libs/gst/gl/gstglphymemory.c | ||
28 | @@ -337,7 +337,7 @@ gst_gl_physical_memory_setup_buffer (Gst | ||
29 | GST_VIDEO_INFO_HEIGHT (info), | ||
30 | viv_fmt, | ||
31 | memblk->vaddr, | ||
32 | - memblk->paddr, | ||
33 | + (guint)memblk->paddr, | ||
34 | FALSE | ||
35 | }; | ||
36 | |||
37 | --- a/gst/subparse/gstssaparse.c | ||
38 | +++ b/gst/subparse/gstssaparse.c | ||
39 | @@ -24,7 +24,9 @@ | ||
40 | #include "config.h" | ||
41 | #endif | ||
42 | |||
43 | +#include <ctype.h> /* isspace() */ | ||
44 | #include <stdlib.h> /* atoi() */ | ||
45 | +#include <stdio.h> /* sscanf() */ | ||
46 | #include <string.h> | ||
47 | |||
48 | #include "gstssaparse.h" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb index 3fce3a58..ba1b9787 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-ba | |||
17 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ | 17 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ |
18 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ | 18 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ |
19 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ | 19 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
20 | file://0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch \ | ||
20 | " | 21 | " |
21 | SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204" | 22 | SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204" |
22 | 23 | ||