diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-05-11 17:40:57 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-05-11 17:40:57 -0300 |
commit | 478aaa391ef6501b0785d6521d5237be5f0c216a (patch) | |
tree | 37f629543d6c24b8bd56f145db5f5927921778db | |
parent | 85348012ebdfb4201be29402bf29fe38c1290a18 (diff) | |
parent | 5c9e98440a5b84711f0cc5ae340e0ab1de8de123 (diff) | |
download | meta-freescale-478aaa391ef6501b0785d6521d5237be5f0c216a.tar.gz |
Merge pull request #1078 from thochstein/graphics
Graphics NXP 5.15.5-1.0.0
-rw-r--r-- | recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb | 35 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-dpu-g2d_2.0.0.bb | 27 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb | 25 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb | 32 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb | 31 | ||||
-rw-r--r-- | recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb | 33 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | 4 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch64.bb | 6 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch32.bb (renamed from recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch32.bb) | 4 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch64.bb | 6 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.0.bb (renamed from recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb) | 6 |
11 files changed, 105 insertions, 104 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb deleted file mode 100644 index c340505e..00000000 --- a/recipes-graphics/imx-g2d/imx-dpu-g2d_1.9.4.bb +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2021 NXP | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU" | ||
6 | LICENSE = "Proprietary" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" | ||
8 | PROVIDES += "virtual/libg2d" | ||
9 | |||
10 | SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" | ||
11 | SRC_URI[md5sum] = "0b7fc529b3af3ecc3087a99cca0c627d" | ||
12 | SRC_URI[sha256sum] = "42d470373fd72b2e2aa8d8a226e133c61b0a88e4e5bddbfec9509f7d2764f206" | ||
13 | |||
14 | inherit fsl-eula-unpack | ||
15 | |||
16 | do_install () { | ||
17 | install -d ${D}${libdir} | ||
18 | install -d ${D}${includedir} | ||
19 | cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
20 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
21 | cp -r ${S}/gpu-demos/opt ${D} | ||
22 | } | ||
23 | |||
24 | FILES:${PN} = "${libdir}/libg2d* /opt" | ||
25 | FILES:${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}" | ||
26 | INSANE_SKIP:${PN} += "ldflags" | ||
27 | |||
28 | RDEPENDS:${PN} = "libgal-imx libdrm libopencl-imx" | ||
29 | |||
30 | # This is required to provide support for VPU Amphion HEVC tile format | ||
31 | # From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99): | ||
32 | # VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx. | ||
33 | RDEPENDS:${PN} += "libopencl-imx" | ||
34 | |||
35 | COMPATIBLE_MACHINE = "(imxdpu)" | ||
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.0.0.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.0.0.bb new file mode 100644 index 00000000..c8e4169d --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.0.0.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2022 NXP | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "G2D library using i.MX DPU" | ||
6 | LICENSE = "Proprietary" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829" | ||
8 | |||
9 | DEPENDS = "libgal-imx libdrm" | ||
10 | PROVIDES += "virtual/libg2d" | ||
11 | |||
12 | SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" | ||
13 | SRC_URI[md5sum] = "96bc124401896dec1272a86cb2baef54" | ||
14 | SRC_URI[sha256sum] = "8e636b65b08cba6b4c2130c8dbff81ee1af42ef818c013aede81ab7e321899a4" | ||
15 | |||
16 | inherit fsl-eula-unpack | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}${libdir} | ||
20 | install -d ${D}${includedir} | ||
21 | cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
22 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
23 | } | ||
24 | |||
25 | INSANE_SKIP:${PN} += "ldflags" | ||
26 | |||
27 | COMPATIBLE_MACHINE = "(imxdpu)" | ||
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb deleted file mode 100644 index 984c10fc..00000000 --- a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "i.MX G2D Samples" | ||
2 | DESCRIPTION = "Set of sample applications for i.MX G2D" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91" | ||
5 | |||
6 | # This package is currently only for GPU-based G2D. Support for DPU-based G2d is coming. | ||
7 | DEPENDS = "imx-gpu-g2d" | ||
8 | |||
9 | GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https" | ||
10 | SRCBRANCH ?= "imx_1.0" | ||
11 | SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" | ||
12 | SRCREV = "daf64d010666ef2458566573c074e238993f228c" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | do_configure[noexec] = "1" | ||
17 | |||
18 | do_install() { | ||
19 | oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix} | ||
20 | } | ||
21 | |||
22 | FILES:${PN} += "/opt" | ||
23 | |||
24 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
25 | |||
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb new file mode 100644 index 00000000..9832aac2 --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "i.MX G2D Samples" | ||
2 | DESCRIPTION = "Set of sample applications for i.MX G2D" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91" | ||
5 | |||
6 | DEPENDS = "virtual/libg2d" | ||
7 | |||
8 | GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https" | ||
9 | SRCBRANCH ?= "imx_2.0" | ||
10 | SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" | ||
11 | SRCREV = "267af142881d350218c2c2cead8f304a28bbee07" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit pkgconfig | ||
16 | |||
17 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}" | ||
18 | |||
19 | PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols" | ||
20 | |||
21 | EXTRA_OEMAKE += " \ | ||
22 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ | ||
23 | ${PACKAGECONFIG_CONFARGS} \ | ||
24 | " | ||
25 | |||
26 | do_install() { | ||
27 | oe_runmake install DESTDIR=${D} | ||
28 | } | ||
29 | |||
30 | FILES:${PN} += "/opt" | ||
31 | |||
32 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb deleted file mode 100644 index 8eaa0bb3..00000000 --- a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p2.4.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2021 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "G2D library using i.MX GPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f" | ||
9 | |||
10 | DEPENDS = "libgal-imx" | ||
11 | PROVIDES = "virtual/libg2d" | ||
12 | |||
13 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
14 | |||
15 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
16 | SRC_URI[aarch64.md5sum] = "9d64a9c4a870419607d9e47e832eb997" | ||
17 | SRC_URI[aarch64.sha256sum] = "6065f545568e6cdc138f2d6e7cdcb525e477ce1d775c0ceabe2beb2eacf4eb5b" | ||
18 | SRC_URI[arm.md5sum] = "4d6cb47f09f268533cc6a9a90cc87555" | ||
19 | SRC_URI[arm.sha256sum] = "b298a38a16400e655ea46ab25b6261e602687e9970dd755594db343064a9ae53" | ||
20 | |||
21 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
22 | |||
23 | inherit fsl-eula-unpack | ||
24 | |||
25 | do_install () { | ||
26 | cp -r -d --no-preserve=ownership ${S}/g2d/* ${D} | ||
27 | } | ||
28 | |||
29 | INSANE_SKIP:${PN} = "ldflags" | ||
30 | |||
31 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb new file mode 100644 index 00000000..1f3c2e60 --- /dev/null +++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.0.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2022 NXP | ||
3 | # Copyright 2018 (C) O.S. Systems Software LTDA. | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | |||
6 | DESCRIPTION = "G2D library using i.MX GPU" | ||
7 | LICENSE = "Proprietary" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829" | ||
9 | DEPENDS = "libgal-imx" | ||
10 | PROVIDES = "virtual/libg2d" | ||
11 | |||
12 | FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}" | ||
13 | |||
14 | SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true" | ||
15 | SRC_URI[aarch64.md5sum] = "b3b3c285796cd5d47841b73c4735e6bd" | ||
16 | SRC_URI[aarch64.sha256sum] = "f2d592d1389be0c16f8dbe6374d480d674c2e31f4195916dbd6baf71473a0e60" | ||
17 | SRC_URI[arm.md5sum] = "82f6a394505bc9d348a35f26cd02bd6a" | ||
18 | SRC_URI[arm.sha256sum] = "96f0213009087de0842740401a67a19d70d5a7ae928843c9c9bee3f8f177b2a0" | ||
19 | |||
20 | S = "${WORKDIR}/${FSLBIN_NAME}" | ||
21 | |||
22 | inherit fsl-eula-unpack | ||
23 | |||
24 | do_install () { | ||
25 | install -d ${D}${libdir} | ||
26 | install -d ${D}${includedir} | ||
27 | cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir} | ||
28 | cp -Pr ${S}/g2d/usr/include/* ${D}${includedir} | ||
29 | } | ||
30 | |||
31 | INSANE_SKIP:${PN} = "ldflags" | ||
32 | |||
33 | COMPATIBLE_MACHINE = "(imxgpu2d)" | ||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc index 7816ec40..8d014259 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc | |||
@@ -6,7 +6,7 @@ | |||
6 | DESCRIPTION = "GPU driver and apps for i.MX" | 6 | DESCRIPTION = "GPU driver and apps for i.MX" |
7 | SECTION = "libs" | 7 | SECTION = "libs" |
8 | LICENSE = "Proprietary" | 8 | LICENSE = "Proprietary" |
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829" |
10 | 10 | ||
11 | DEPENDS += " \ | 11 | DEPENDS += " \ |
12 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | 12 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ |
@@ -155,7 +155,7 @@ IMX_SOC:mx8mn-nxp-bsp = "mx8mn" | |||
155 | IMX_SOC:mx8ulp-nxp-bsp = "mx8ulp" | 155 | IMX_SOC:mx8ulp-nxp-bsp = "mx8ulp" |
156 | 156 | ||
157 | LIBVULKAN_VERSION_MAJOR = "1" | 157 | LIBVULKAN_VERSION_MAJOR = "1" |
158 | LIBVULKAN_VERSION = "${LIBVULKAN_VERSION_MAJOR}.1.6" | 158 | LIBVULKAN_VERSION = "${LIBVULKAN_VERSION_MAJOR}.2.1" |
159 | 159 | ||
160 | do_install () { | 160 | do_install () { |
161 | install -d ${D}${libdir} | 161 | install -d ${D}${libdir} |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch64.bb deleted file mode 100644 index 7fc1bc4e..00000000 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch64.bb +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | require imx-gpu-viv-6.inc | ||
2 | |||
3 | SRC_URI[md5sum] = "d53371c1a9a504ff15f747e725164dcb" | ||
4 | SRC_URI[sha256sum] = "6106133afed40327b65d3eec0c197d214ff8f28f8ce3cad94653be4bffb9f9d4" | ||
5 | |||
6 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" | ||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch32.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch32.bb index ea3b0bde..d6cae8b6 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p2.4-aarch32.bb +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch32.bb | |||
@@ -4,7 +4,7 @@ | |||
4 | 4 | ||
5 | require imx-gpu-viv-6.inc | 5 | require imx-gpu-viv-6.inc |
6 | 6 | ||
7 | SRC_URI[md5sum] = "d577c4e34df73855ebf1c3b3be206f40" | 7 | SRC_URI[md5sum] = "9abc4e59919b68f81094c194edb525a2" |
8 | SRC_URI[sha256sum] = "a0266612e8c9ca64b417047274941c867de1058db6709170d0bb5c8b8a38eab1" | 8 | SRC_URI[sha256sum] = "5f56e4690287fd4e8480d2c43101ef30383c95d155a3f06beadecad309e684a3" |
9 | 9 | ||
10 | COMPATIBLE_MACHINE = "(mx6q-nxp-bsp|mx6dl-nxp-bsp|mx6sx-nxp-bsp|mx6sl-nxp-bsp|mx7ulp-nxp-bsp)" | 10 | COMPATIBLE_MACHINE = "(mx6q-nxp-bsp|mx6dl-nxp-bsp|mx6sx-nxp-bsp|mx6sl-nxp-bsp|mx7ulp-nxp-bsp)" |
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch64.bb new file mode 100644 index 00000000..81ca2526 --- /dev/null +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.0-aarch64.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require imx-gpu-viv-6.inc | ||
2 | |||
3 | SRC_URI[md5sum] = "20cecb3e5440f63bb6612c740ccfe43a" | ||
4 | SRC_URI[sha256sum] = "283f2f51cadf5138bd47269a73425a51f69453556fb80f18521da04317e547a8" | ||
5 | |||
6 | COMPATIBLE_MACHINE = "(mx8-nxp-bsp)" | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.0.bb index 6c759c3b..12de35be 100644 --- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb +++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p4.0.bb | |||
@@ -7,14 +7,14 @@ allowing flexibility to use a newer graphics release with an older kernel." | |||
7 | LICENSE = "GPL-2.0-only" | 7 | LICENSE = "GPL-2.0-only" |
8 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" | 8 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
9 | 9 | ||
10 | SRCBRANCH = "lf-5.10.y" | 10 | SRCBRANCH = "lf-5.15.y" |
11 | LOCALVERSION = "-5.10.72-2.2.0" | 11 | LOCALVERSION = "-5.15.5-1.0.0" |
12 | KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=master" | 12 | KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=master" |
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \ | 14 | ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \ |
15 | file://Add-makefile.patch \ | 15 | file://Add-makefile.patch \ |
16 | " | 16 | " |
17 | SRCREV = "8e035d8196aacc7c1926d3d278df99255baa3c6d" | 17 | SRCREV = "e47e5ff6895a7aa2f75dcb2e2c7257e25cf77901" |
18 | 18 | ||
19 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
20 | 20 | ||