diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-07-10 17:45:10 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-13 14:00:59 -0300 |
commit | 5558502c956dec76b81c03a30a2833ac48f9f08d (patch) | |
tree | e94fb7d45b8688eb49fc5747dafbb8d3e2c92dea | |
parent | 0e62e2e1fe38aff6a27921fd382e6dfd346654d5 (diff) | |
download | meta-freescale-5558502c956dec76b81c03a30a2833ac48f9f08d.tar.gz |
u-boot-ls1: update to revision v2015.01-630-g6ba8eed
Changes:
1. Rebased on git://git.denx.de/u-boot.git v2015.01-487-gab92da9
2. Applied another 143 FSL/backported patches (git log ab92da9..)
3. add DEPENDS on dtc-native as u-boot brings in device tree files
4. use u-boot-with-spl-pbl.bin for nand
5. replace with u-boot-dtb.bin when swapping the image endianness
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb (renamed from meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb) | 13 |
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb index ad1dd4b9..716105f4 100644 --- a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb +++ b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require recipes-bsp/u-boot/u-boot.inc | 1 | require recipes-bsp/u-boot/u-boot.inc |
2 | 2 | ||
3 | DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards" | 3 | DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ Layerscape1 boards" |
4 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" | 4 | LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" |
5 | LIC_FILES_CHKSUM = " \ | 5 | LIC_FILES_CHKSUM = " \ |
6 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 6 | file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
@@ -10,17 +10,17 @@ LIC_FILES_CHKSUM = " \ | |||
10 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ | 10 | file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ |
11 | " | 11 | " |
12 | 12 | ||
13 | SRCBRANCH = "sdk-v1.7.x" | 13 | SRCBRANCH = "master" |
14 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" | 14 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" |
15 | SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" | 15 | SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad" |
16 | 16 | ||
17 | LOCALVERSION ?= "-${SRCBRANCH}" | 17 | LOCALVERSION ?= "+ls1" |
18 | 18 | ||
19 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
20 | 20 | ||
21 | inherit fsl-u-boot-localversion | 21 | inherit fsl-u-boot-localversion |
22 | 22 | ||
23 | DEPENDS += "change-file-endianess-native" | 23 | DEPENDS += "change-file-endianess-native dtc-native" |
24 | PROVIDES += "u-boot" | 24 | PROVIDES += "u-boot" |
25 | 25 | ||
26 | do_compile_append () { | 26 | do_compile_append () { |
@@ -28,9 +28,10 @@ do_compile_append () { | |||
28 | then | 28 | then |
29 | for config in ${UBOOT_MACHINE}; do | 29 | for config in ${UBOOT_MACHINE}; do |
30 | case "${config}" in | 30 | case "${config}" in |
31 | *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot.bin ${S}/${config}/u-boot.swap.bin 8 | 31 | *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8 |
32 | mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};; | 32 | mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};; |
33 | *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;; | 33 | *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;; |
34 | *nand*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;; | ||
34 | esac | 35 | esac |
35 | done | 36 | done |
36 | fi | 37 | fi |