summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-01 23:53:46 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-05-12 14:42:20 +0800
commit9d382632fcb6cff2445625a3cba0a52413546a8f (patch)
treea37a06da2209981cb15347edd179bd035546addd
parentd941ab6d0a6d7862d477c53acca282efaec49d2f (diff)
downloadmeta-freescale-9d382632fcb6cff2445625a3cba0a52413546a8f.tar.gz
ceetm: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. ceetm Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb
index 266261eb..beaed31e 100644
--- a/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb
+++ b/meta-fsl-ppc/recipes-kernel/ceetm/ceetm_git.bb
@@ -14,6 +14,11 @@ S = "${WORKDIR}/git"
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" 14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}" 15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16 16
17do_configure[depends] += "virtual/kernel:do_shared_workdir"
18do_configure_prepend () {
19 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/ceetm_module/Makefile
20}
21
17do_install(){ 22do_install(){
18 mkdir -p ${D}/usr/driver/ceetm 23 mkdir -p ${D}/usr/driver/ceetm
19 mkdir -p ${D}/${libdir}/tc 24 mkdir -p ${D}/${libdir}/tc