diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-09-05 08:32:15 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-09-05 08:32:15 -0300 |
commit | a59c554cfeeeadfd8f0da053a59719207c73a636 (patch) | |
tree | e5452916c723f2a18facc448c5dc5b7a33f0fe5c | |
parent | 84b9ae5d0859cb6920056a1f9295917bad83383a (diff) | |
parent | b5bd73c5f845ee14c4baa0f5235381b88dbcc4f5 (diff) | |
download | meta-freescale-a59c554cfeeeadfd8f0da053a59719207c73a636.tar.gz |
Merge pull request #1194 from YoeDistro/yoe/mut
imx-atf: Use clang when using toolchain-clang defaults
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.6.bb | 3 | ||||
-rw-r--r-- | recipes-graphics/cairo/cairo_%.bbappend | 6 | ||||
-rw-r--r-- | recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb | 3 |
3 files changed, 12 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb index 3f627150..d6e02a71 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.6.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb | |||
@@ -40,6 +40,9 @@ LD[unexport] = "1" | |||
40 | INHIBIT_DEFAULT_DEPS = "1" | 40 | INHIBIT_DEFAULT_DEPS = "1" |
41 | DEPENDS = "virtual/${HOST_PREFIX}gcc" | 41 | DEPENDS = "virtual/${HOST_PREFIX}gcc" |
42 | 42 | ||
43 | # Bring in clang compiler if using clang as default | ||
44 | DEPENDS:append:toolchain-clang = " clang-cross-${TARGET_ARCH}" | ||
45 | |||
43 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" | 46 | BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" |
44 | 47 | ||
45 | # CC and LD introduce arguments which conflict with those otherwise provided by | 48 | # CC and LD introduce arguments which conflict with those otherwise provided by |
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend index 2c73c7f3..245adb59 100644 --- a/recipes-graphics/cairo/cairo_%.bbappend +++ b/recipes-graphics/cairo/cairo_%.bbappend | |||
@@ -1,2 +1,8 @@ | |||
1 | PACKAGECONFIG:append:imxgpu3d = " egl glesv2" | 1 | PACKAGECONFIG:append:imxgpu3d = " egl glesv2" |
2 | PACKAGECONFIG:remove:imxgpu3d = "opengl" | 2 | PACKAGECONFIG:remove:imxgpu3d = "opengl" |
3 | |||
4 | # links with imx-gpu libs which are pre-built for glibc | ||
5 | # gcompat will address it during runtime | ||
6 | LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined" | ||
7 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
8 | |||
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb index de527cda..bd584dbe 100644 --- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb +++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.3.p4.2-aarch64.bb | |||
@@ -1,5 +1,8 @@ | |||
1 | require imx-gpu-viv-6.inc | 1 | require imx-gpu-viv-6.inc |
2 | 2 | ||
3 | DEPENDS:append:libc-musl = " gcompat" | ||
4 | INSANE_SKIP:append:libc-musl = " file-rdeps" | ||
5 | |||
3 | SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" | 6 | SRC_URI[md5sum] = "22de8a5f59a56a7ef499f590d1659b6f" |
4 | SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" | 7 | SRC_URI[sha256sum] = "52921c0b59529f1598084e991eda1863100754f28a7744ba958158dff8074b3b" |
5 | 8 | ||