diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2022-08-24 13:27:59 +0200 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2022-08-24 13:51:30 +0200 |
commit | bac8c6af8471addb7add0d1b1ddfbbbd36bed16e (patch) | |
tree | 07b5484bc5b745d4002af05468a6d452fc10c8dd | |
parent | 2902c1c5a26b9ac2c7a1957698d92ceea2c5b0df (diff) | |
download | meta-freescale-bac8c6af8471addb7add0d1b1ddfbbbd36bed16e.tar.gz |
imx-atf: fix build error with binutils 2.39
This disables the warning about a LOAD segment in the produced elf file
which has RWX permissions set. As the build is set to error out on any
warning the build fails without this patch.
| LD ...imx-atf/2.6+gitAUTOINC+c6a19b1a35-r0/git/build/imx8mm/release/bl31/bl31.elf
| aarch64-tdx-linux-ld: warning: ...git/build/imx8mm/release/bl31/bl31.elf has a LOAD segment with RWX permissions
| make: *** [Makefile:1254: ...git/build/imx8mm/release/bl31/bl31.elf] Error 1
| ERROR: oe_runmake failed
Bug report for atf: https://developer.trustedfirmware.org/T996
Reported-by: Peter Bergin <peter@berginkonsult.se>
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.6.bb | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb index b0426f0b..1df61cab 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.6.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb | |||
@@ -29,7 +29,9 @@ EXTRA_OEMAKE += " \ | |||
29 | 29 | ||
30 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application | 30 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application |
31 | CFLAGS[unexport] = "1" | 31 | CFLAGS[unexport] = "1" |
32 | LDFLAGS[unexport] = "1" | 32 | # Needed for binutils >= 2.39 to prevent build failure. |
33 | # imx-atf links with ld, thus no '-Wl,' prefix | ||
34 | LDFLAGS = "--no-warn-rwx-segments" | ||
33 | AS[unexport] = "1" | 35 | AS[unexport] = "1" |
34 | LD[unexport] = "1" | 36 | LD[unexport] = "1" |
35 | 37 | ||
@@ -56,7 +58,6 @@ EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}' | |||
56 | do_configure[noexec] = "1" | 58 | do_configure[noexec] = "1" |
57 | 59 | ||
58 | do_compile() { | 60 | do_compile() { |
59 | # Clear LDFLAGS to avoid the option -Wl recognize issue | ||
60 | oe_runmake bl31 | 61 | oe_runmake bl31 |
61 | if ${BUILD_OPTEE}; then | 62 | if ${BUILD_OPTEE}; then |
62 | oe_runmake clean BUILD_BASE=build-optee | 63 | oe_runmake clean BUILD_BASE=build-optee |