diff options
author | Joris Offouga <offougajoris@gmail.com> | 2018-10-15 17:03:36 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-26 11:47:36 -0300 |
commit | bb4dcaa73c446fe77af8cf7782dafe9ccd7b58be (patch) | |
tree | 259c32830d9f83cb396d98c3ab7cc2bc801528c8 | |
parent | 1925b1cce5efb6dce8bea68177b09a27a66acc83 (diff) | |
download | meta-freescale-bb4dcaa73c446fe77af8cf7782dafe9ccd7b58be.tar.gz |
u-boot-qoriq: Add recipe fw-utils
Initial support for fw utils for qoriq
Signed-off-by: Joris Offouga <offougajoris@gmail.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2018.03.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2018.03.bb b/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2018.03.bb new file mode 100644 index 00000000..ae47cb0d --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-qoriq-fw-utils_2018.03.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | require u-boot-qoriq-common_${PV}.inc | ||
2 | |||
3 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" | ||
4 | DEPENDS = "mtd-utils" | ||
5 | |||
6 | INSANE_SKIP_${PN} = "already-stripped" | ||
7 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1' | ||
8 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' | ||
9 | |||
10 | inherit uboot-config | ||
11 | |||
12 | do_compile () { | ||
13 | oe_runmake ${UBOOT_MACHINE} | ||
14 | oe_runmake envtools | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | install -d ${D}${base_sbindir} | ||
19 | install -d ${D}${sysconfdir} | ||
20 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv | ||
21 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv | ||
22 | |||
23 | if [ -e ${WORKDIR}/fw_env.config ]; then | ||
24 | install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
25 | else | ||
26 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config | ||
27 | fi | ||
28 | } | ||
29 | |||
30 | do_install_class-cross () { | ||
31 | install -d ${D}${bindir_cross} | ||
32 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv | ||
33 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv | ||
34 | } | ||
35 | |||
36 | SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" | ||
37 | uboot_fw_utils_cross() { | ||
38 | sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} | ||
39 | } | ||
40 | |||
41 | PROVIDES += "u-boot-fw-utils" | ||
42 | RPROVIDES_${PN} += "u-boot-fw-utils" | ||
43 | |||
44 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
45 | BBCLASSEXTEND = "cross" | ||