diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-08-24 17:04:48 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-08-26 15:05:40 -0500 |
commit | ed60a7915dfb4c2da89007c1670ef1da8618a063 (patch) | |
tree | 6eb1fbde7acd062998be2b6a0ec765eb45eca6f2 | |
parent | b0e0b700fb6736eb77d880952d9e92c3014b1445 (diff) | |
download | meta-freescale-ed60a7915dfb4c2da89007c1670ef1da8618a063.tar.gz |
mesa-demos: Update for latest
Drop OpenVG packageconfig and patch as OpenVG support is dropped from
mesa-demos.
For i.MX GPU:
- x11 is not required
- GLX is not supported
- GLU is required
- GLUT is not required for x11
Since x11 is not required but GLU is, restore the PACKAGECONFIG for glu,
which was recently tied to x11.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch | 84 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-demos_%.bbappend | 15 |
2 files changed, 7 insertions, 92 deletions
diff --git a/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch b/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch deleted file mode 100644 index 19bcca98..00000000 --- a/recipes-graphics/mesa/mesa-demos/Add-OpenVG-demos-to-support-wayland.patch +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | From 8aba54422d9a77383c150f9f70240b18b6e1918e Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
3 | Date: Thu, 9 Apr 2015 15:47:21 -0500 | ||
4 | Subject: [PATCH] Add OpenVG demos to support wayland. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
9 | --- | ||
10 | src/egl/Makefile.am | 6 +++--- | ||
11 | src/egl/openvg/Makefile.am | 33 +++++++++++++++++++++++++++++---- | ||
12 | 2 files changed, 32 insertions(+), 7 deletions(-) | ||
13 | |||
14 | Index: mesa-demos-8.2.0/src/egl/Makefile.am | ||
15 | =================================================================== | ||
16 | --- mesa-demos-8.2.0.orig/src/egl/Makefile.am 2016-05-09 11:45:51.479100180 -0500 | ||
17 | +++ mesa-demos-8.2.0/src/egl/Makefile.am 2016-05-09 11:45:51.475100160 -0500 | ||
18 | @@ -26,10 +26,10 @@ | ||
19 | eglut \ | ||
20 | opengles1 \ | ||
21 | opengles2 \ | ||
22 | - oes_vg | ||
23 | + oes_vg \ | ||
24 | + openvg | ||
25 | |||
26 | if HAVE_GLU | ||
27 | SUBDIRS += \ | ||
28 | - opengl \ | ||
29 | - openvg | ||
30 | + opengl | ||
31 | endif | ||
32 | Index: mesa-demos-8.2.0/src/egl/openvg/Makefile.am | ||
33 | =================================================================== | ||
34 | --- mesa-demos-8.2.0.orig/src/egl/openvg/Makefile.am 2016-05-09 11:45:51.479100180 -0500 | ||
35 | +++ mesa-demos-8.2.0/src/egl/openvg/Makefile.am 2016-05-09 12:39:30.000000000 -0500 | ||
36 | @@ -47,13 +47,26 @@ | ||
37 | endif | ||
38 | endif | ||
39 | |||
40 | +if HAVE_WAYLAND | ||
41 | +EGL_WL_DEMOS = \ | ||
42 | + lion_wayland \ | ||
43 | + sp_wayland | ||
44 | + | ||
45 | +if HAVE_FREETYPE2 | ||
46 | +EGL_WL_DEMOS += \ | ||
47 | + vgtext_wayland | ||
48 | +endif | ||
49 | +endif | ||
50 | + | ||
51 | if HAVE_EGL | ||
52 | if HAVE_VG | ||
53 | bin_PROGRAMS = \ | ||
54 | - $(EGL_X11_DEMOS) | ||
55 | + $(EGL_X11_DEMOS) \ | ||
56 | + $(EGL_WL_DEMOS) | ||
57 | endif | ||
58 | endif | ||
59 | |||
60 | +if HAVE_X11 | ||
61 | lion_x11_SOURCES = lion.c lion-render.c lion-render.h | ||
62 | sp_x11_SOURCES = sp.c | ||
63 | |||
64 | @@ -63,6 +76,20 @@ | ||
65 | text_SOURCES = text.c | ||
66 | text_CFLAGS = $(AM_CFLAGS) @FREETYPE2_CFLAGS@ | ||
67 | text_LDADD = @FREETYPE2_LIBS@ ../eglut/libeglut_x11.la | ||
68 | +endif | ||
69 | + | ||
70 | +if HAVE_WAYLAND | ||
71 | +lion_wayland_SOURCES = lion.c lion-render.c lion-render.h | ||
72 | +lion_wayland_LDADD = ../eglut/libeglut_wayland.la | ||
73 | + | ||
74 | +sp_wayland_SOURCES = sp.c | ||
75 | +sp_wayland_LDADD = ../eglut/libeglut_wayland.la | ||
76 | + | ||
77 | +vgtext_wayland_SOURCES = text.c | ||
78 | +vgtext_wayland_CFLAGS = $(AM_CFLAGS) @FREETYPE2_CFLAGS@ | ||
79 | +vgtext_wayland_LDADD = @FREETYPE2_LIBS@ ../eglut/libeglut_wayland.la | ||
80 | + | ||
81 | +endif | ||
82 | |||
83 | SUBDIRS = \ | ||
84 | trivial | ||
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend index 10db1f9e..0f0528dd 100644 --- a/recipes-graphics/mesa/mesa-demos_%.bbappend +++ b/recipes-graphics/mesa/mesa-demos_%.bbappend | |||
@@ -2,8 +2,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | |||
2 | 2 | ||
3 | SRC_URI:append:imxgpu = " \ | 3 | SRC_URI:append:imxgpu = " \ |
4 | file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ | 4 | file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ |
5 | file://fix-clear-build-break.patch \ | 5 | file://fix-clear-build-break.patch" |
6 | file://Add-OpenVG-demos-to-support-wayland.patch" | 6 | |
7 | REQUIRED_DISTRO_FEATURES:remove:imxgpu = "x11" | ||
7 | 8 | ||
8 | PACKAGECONFIG:remove = " \ | 9 | PACKAGECONFIG:remove = " \ |
9 | ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \ | 10 | ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \ |
@@ -12,13 +13,11 @@ PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" | |||
12 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu2d = "gles1 gles2" | 13 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu2d = "gles1 gles2" |
13 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu3d = "" | 14 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu3d = "" |
14 | PACKAGECONFIG_REMOVE_IF_GPU = "" | 15 | PACKAGECONFIG_REMOVE_IF_GPU = "" |
15 | PACKAGECONFIG_REMOVE_IF_GPU:imxgpu = " \ | 16 | PACKAGECONFIG_REMOVE_IF_GPU:imxgpu = "glx x11" |
16 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)}" | ||
17 | 17 | ||
18 | PACKAGECONFIG:append = " \ | 18 | PACKAGECONFIG:append = " \ |
19 | ${PACKAGECONFIG_APPEND_IF_GPU}" | 19 | ${PACKAGECONFIG_APPEND_IF_GPU}" |
20 | PACKAGECONFIG_APPEND_IF_GPU = "" | 20 | PACKAGECONFIG_APPEND_IF_GPU = "" |
21 | PACKAGECONFIG_APPEND_IF_GPU:imxgpu = " \ | 21 | PACKAGECONFIG_APPEND_IF_GPU:imxgpu = "glu" |
22 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \ | 22 | |
23 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glut', '', d)}" | 23 | PACKAGECONFIG[glu] = ",,libglu" |
24 | " | ||