diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-17 10:01:30 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-19 14:06:35 -0700 |
commit | fa4112e43fc4edc4a8521eddd459606328be647e (patch) | |
tree | 5fa13cf5b94cae0ecd522fb561017d43468f4ac8 | |
parent | 61718793a4c04c768ecc829372b9d4de3c6c463b (diff) | |
download | meta-freescale-fa4112e43fc4edc4a8521eddd459606328be647e.tar.gz |
cairo,xwayland: Fix compiling with musl with vivante gpu driver libs
This ensures that the symbols from the prebuilt libs are not flagged
during build, we are betting on gcompat to provide the missing glibc
API stubs at runtime.
Depend on gcompat on musl needed for imxgpu machines its needed
since graphics driver is precompiled for glibc.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-graphics/cairo/cairo_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/xwayland/xwayland_%.bbappend | 7 |
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend index 245adb59..c61e9a58 100644 --- a/recipes-graphics/cairo/cairo_%.bbappend +++ b/recipes-graphics/cairo/cairo_%.bbappend | |||
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl" | |||
3 | 3 | ||
4 | # links with imx-gpu libs which are pre-built for glibc | 4 | # links with imx-gpu libs which are pre-built for glibc |
5 | # gcompat will address it during runtime | 5 | # gcompat will address it during runtime |
6 | LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined" | ||
7 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | 6 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" |
8 | 7 | ||
8 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend index 69063121..f2141f4f 100644 --- a/recipes-graphics/xwayland/xwayland_%.bbappend +++ b/recipes-graphics/xwayland/xwayland_%.bbappend | |||
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = "" | |||
10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" | 10 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" |
11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" | 11 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" |
12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" | 12 | OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" |
13 | |||
14 | |||
15 | # links with imx-gpu libs which are pre-built for glibc | ||
16 | # gcompat will address it during runtime | ||
17 | LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" | ||
18 | |||
19 | RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat" | ||