diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-07-10 17:45:13 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-13 14:00:59 -0300 |
commit | 0c7a93425e0f76c3e2c1e89cb5f3c6f5c52af0be (patch) | |
tree | 91d303002336038b81d27cf5c72623c14f50076f | |
parent | c54ba27c9eae4743e6ef2f6e95438007a6f2ef2a (diff) | |
download | meta-freescale-0c7a93425e0f76c3e2c1e89cb5f3c6f5c52af0be.tar.gz |
qemu-fsl: upgrade from v1.7 to v2.2.0
Update the supported QEMU version from v1.7 to v2.2.0 and include the
Freescale patches on top of this.
Baseline: http://git.qemu.org/?p=qemu.git;a=tag;h=refs/tags/v2.2.0
Freescale patches:
00ac004 QEMU: PPC: Support for VFIO_IOMMU_DUMMY.
58d1cc4 QEMU: PPC: Identity mapped memory support for qemu.
07d4f5f Qemu: PPC: e500: Move CCSR and MMIO space to upper end of address space
a7aee41 QEMU: PPC: e500: Move CCSR definition to params
fbcc0ca vfio-pci: add direct pci device assignment for fsl powerpc
536df03 Update Linux Headers from 3.18
ee367e4 QEMU:Add support for e5500 core revision v102.1 present on T1024 SOC.
b0c2f44 hw/arm/virt: Use memory_region_allocate_system_memory to allocate memory
b2f233e PPC: add e6500 cpu class
694c39a QEMU: PPC: set default cpu type to be 'host'
1572872 QEMU: PPC: specify PVRs for all e500 cores
Also fix indent.
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | meta-fsl-arm/recipes-devtools/qemu/qemu-fsl_git.bb | 34 |
1 files changed, 15 insertions, 19 deletions
diff --git a/meta-fsl-arm/recipes-devtools/qemu/qemu-fsl_git.bb b/meta-fsl-arm/recipes-devtools/qemu/qemu-fsl_git.bb index ca36c3df..94fb9b19 100644 --- a/meta-fsl-arm/recipes-devtools/qemu/qemu-fsl_git.bb +++ b/meta-fsl-arm/recipes-devtools/qemu/qemu-fsl_git.bb | |||
@@ -3,20 +3,17 @@ require recipes-devtools/qemu/qemu.inc | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ |
4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | 4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" |
5 | 5 | ||
6 | # This means QEMU v1.7 with FSL specific patches applied | 6 | # This means QEMU v2.2.0 with FSL specific patches applied |
7 | PV = "1.7+${SRCPV}" | 7 | PV = "2.2.0+${SRCPV}" |
8 | 8 | ||
9 | # NOTE: these options are note available in qemu 1.7, but qemu.inc assumes | 9 | # NOTE: this recipe requires poky's qemu.inc which assumes version 2.3 |
10 | # version 2.0+ where they are available. For now we unset them, but we should | 10 | # where glx enable config option changed to --enable-opengl. For now we |
11 | # remove the following lines when upgrading to qemu 2.0+: | 11 | # restore it, but we should remove the following lines when upgrading |
12 | PACKAGECONFIG[quorum] = "" | 12 | # to qemu 2.3: |
13 | PACKAGECONFIG[lzo] = "" | 13 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa" |
14 | PACKAGECONFIG[numa] = "" | ||
15 | PACKAGECONFIG[gtk+] = "" | ||
16 | 14 | ||
17 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.7.x \ | 15 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master" |
18 | " | 16 | SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a" |
19 | SRCREV = "6ac4597c059d35e2737b234747243e56d340f4db" | ||
20 | 17 | ||
21 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
22 | 19 | ||
@@ -26,23 +23,22 @@ inherit pkgconfig | |||
26 | 23 | ||
27 | # Append build host pkg-config paths for native target since the host may provide sdl | 24 | # Append build host pkg-config paths for native target since the host may provide sdl |
28 | do_configure_prepend() { | 25 | do_configure_prepend() { |
29 | export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config | 26 | export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config |
30 | } | 27 | } |
31 | 28 | ||
32 | do_configure_append () { | 29 | do_configure_append () { |
33 | if ! grep 'CONFIG_FDT=y' config-host.mak; then | 30 | if ! grep 'CONFIG_FDT=y' config-host.mak; then |
34 | echo "CONFIG_RDMA=y" >> config_host_mak | 31 | echo "CONFIG_RDMA=y" >> config_host_mak |
35 | fi | 32 | fi |
36 | } | 33 | } |
37 | 34 | ||
38 | # gets around qemu.inc trying to install powerpc_rom.bin | 35 | # gets around qemu.inc trying to install powerpc_rom.bin |
39 | do_install_prepend() { | 36 | do_install_prepend() { |
40 | touch ${WORKDIR}/powerpc_rom.bin | 37 | touch ${WORKDIR}/powerpc_rom.bin |
41 | } | 38 | } |
42 | 39 | ||
43 | do_install_append() { | 40 | do_install_append() { |
44 | rm ${WORKDIR}/powerpc_rom.bin | 41 | rm ${WORKDIR}/powerpc_rom.bin |
45 | |||
46 | # Prevent QA warnings about installed ${localstatedir}/run | 42 | # Prevent QA warnings about installed ${localstatedir}/run |
47 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi | 43 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi |
48 | } | 44 | } |