diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-04-01 14:42:05 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-04-11 09:00:13 -0300 |
commit | 0ea64936af24159b1c78993e3444e67ae15cc6d1 (patch) | |
tree | eac507c6b91f61f1f255779e6be87585e693f0bb | |
parent | 14e1ea04d72a6f0df3538db33f5c6d8fef7f5ab2 (diff) | |
download | meta-freescale-0ea64936af24159b1c78993e3444e67ae15cc6d1.tar.gz |
linux-qoriq/4.14:update to 7e52442
*update to lsdk 1903 tag
include the following changes:
7e52442 - vfio/fsl-mc: Reset container on last reference release
66346b1 - Revert "net: phy: aquantia: add pause frame support"
5a51f09 - Merge branch 'linux-4.14-nxp' into linux-4.14 on Mar 21, 2019
0412772 - PCI: controller: dwc: Do not let PCIE_DW_PLAT_HOST default to yes
55f1e5e - i2c: imx: defer probing on dma channel request
c42701e - i2c: imx: fix dma_request_chan error handling
e16c8a1 - i2c: imx: improve the error handling in i2c_imx_dma_request()
434a13d - i2c: imx: notify about real errors on dma i2c_imx_dma_request
ba46a4b - powerpc/dts/fsl: add crypto node alias for B4
1c0ec67 - arm64: dts: ls1043a: add crypto node alias also for qds
eb96cdd - soc: fsl: dpio: Increase timeout for QBMan Management Commands
a695286 - soc: fsl: qbman: avoid race in clearing QMan interrupt
07977ec - drivers: soc: fsl: fix problem of compiling qixis driver
0529a6d - PCI: endpoint: Correcting nonstandard NXP copyright
70827e4 - Merge branch 'linux-4.14-nxp' into linux-4.14 on Mar 20, 2019
2a71b28 - crypto: caam - fix building job ring as module
b87ba6a - soc/fsl/bqman: page align iommu mapping sizes
d2e2129 - sdk: dts: remove dma-coherent from sdk dts for QE
788e297 - net: phy: aquantia: add pause frame support
fcc8208 - dpaa2-eth: Update pause frames settings on link up
4c86a9c - dpaa2-eth: fix race condition with bql frame accounting
e0d959e - dpaa2-eth: configure the cache stashing amount on a queue
bafb6b5 - staging: fsl-dpaa2/mac: Fix bug in pause frame advertising
0ed08fd - staging: fsl-dpaa2/mac: add pause frames support for managed phys
adcaa66 - of/device: Set bus DMA mask as appropriate
7f97665 - iommu/dma: Respect bus DMA limit for IOVAs
*refresh patches
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
4 files changed, 28 insertions, 52 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch deleted file mode 100644 index b4c4aed8..00000000 --- a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From 5066b8f46b0f2348881923491b93825ac04d13d2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Sat, 29 Sep 2018 14:12:34 +0800 | ||
4 | Subject: [PATCH] Makefile: fix gcc-8 build error | ||
5 | |||
6 | Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com> | ||
7 | --- | ||
8 | Makefile | 1 + | ||
9 | 1 file changed, 1 insertion(+) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index 53d57ac..b7c5fd4 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -395,6 +395,7 @@ LINUXINCLUDE += $(filter-out $(LINUXINCLUDE),$(USERINCLUDE)) | ||
16 | KBUILD_AFLAGS := -D__ASSEMBLY__ | ||
17 | KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \ | ||
18 | -fno-strict-aliasing -fno-common \ | ||
19 | + -Wno-packed-not-aligned -Wno-tautological-compare \ | ||
20 | -Werror-implicit-function-declaration \ | ||
21 | -Wno-format-security \ | ||
22 | -std=gnu89 | ||
23 | -- | ||
24 | 1.8.3.1 | ||
25 | |||
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch new file mode 100644 index 00000000..b01545f8 --- /dev/null +++ b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From e2283cc7582ba82f346b05fdb38f0057e54de7fa Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Tue, 12 Mar 2019 03:52:03 +0100 | ||
4 | Subject: [PATCH] Makfefile: add cflags | ||
5 | |||
6 | Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com> | ||
7 | --- | ||
8 | Makefile | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index 967692b..ae395cd 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -417,7 +417,7 @@ LINUXINCLUDE := \ | ||
16 | KBUILD_AFLAGS := -D__ASSEMBLY__ | ||
17 | KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \ | ||
18 | -fno-strict-aliasing -fno-common -fshort-wchar \ | ||
19 | - -Werror-implicit-function-declaration \ | ||
20 | + -Werror-implicit-function-declaration -Wno-misleading-indentation -Wno-tautological-compare \ | ||
21 | -Wno-format-security \ | ||
22 | -std=gnu89 | ||
23 | KBUILD_CPPFLAGS := -D__KERNEL__ | ||
24 | -- | ||
25 | 2.7.4 | ||
26 | |||
diff --git a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch deleted file mode 100644 index 3cd25014..00000000 --- a/recipes-kernel/linux/linux-qoriq/0001-fix-gcc8-build-error.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | From 844ce11967bca7b7f68c6cb459e02c9a10f32574 Mon Sep 17 00:00:00 2001 | ||
2 | From: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com> | ||
3 | Date: Tue, 3 Jul 2018 15:06:29 +0800 | ||
4 | Subject: [PATCH] fix gcc8 build error | ||
5 | |||
6 | --- | ||
7 | Makefile | 2 ++ | ||
8 | 1 file changed, 2 insertions(+) | ||
9 | |||
10 | diff --git a/Makefile b/Makefile | ||
11 | index d6db01a..85d9d6c 100644 | ||
12 | --- a/Makefile | ||
13 | +++ b/Makefile | ||
14 | @@ -422,6 +422,8 @@ LINUXINCLUDE := \ | ||
15 | KBUILD_AFLAGS := -D__ASSEMBLY__ | ||
16 | KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \ | ||
17 | -fno-strict-aliasing -fno-common -fshort-wchar \ | ||
18 | + -Wno-packed-not-aligned \ | ||
19 | + -Wno-tautological-compare \ | ||
20 | -Werror-implicit-function-declaration \ | ||
21 | -Wno-format-security \ | ||
22 | -std=gnu89 | ||
23 | -- | ||
24 | 1.8.3.1 | ||
25 | |||
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb index cb06ae43..9f4bcf04 100644 --- a/recipes-kernel/linux/linux-qoriq_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq_4.14.bb | |||
@@ -7,9 +7,9 @@ LICENSE = "GPLv2" | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" |
8 | 8 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
10 | file://0001-fix-gcc8-build-error.patch \ | 10 | file://0001-Makfefile-add-cflags.patch \ |
11 | " | 11 | " |
12 | SRCREV = "7e0006ca696756b867abbeb7a4ed97ffe9caf725" | 12 | SRCREV = "7e52442b136c439c142c4859a70ce92208c481a9" |
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||