diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-07-05 12:13:29 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-07-12 17:18:34 -0300 |
commit | 1bef7398e0de36d6268860c43d02f6ed5adfd15d (patch) | |
tree | ecff76e46c201d30789c1c60ed8e3f2090cddff8 | |
parent | d9d4c44812dfbb8808ba3759e4ad21e76efb8c30 (diff) | |
download | meta-freescale-1bef7398e0de36d6268860c43d02f6ed5adfd15d.tar.gz |
linux-qoriq/4.19: update to 1a4cab2
*update to lsdk 1906 tag
include the following changes:
1a4cab2 - tcp: enforce tcp_min_snd_mss in tcp_mtu_probing()
b20446e - tcp: add tcp_min_snd_mss sysctl
96340e0 - tcp: tcp_fragment() should apply sane memory limits
6aa0603 - tcp: limit payload size of sacked skbs
58cd089 - Revert "crypto: caam - fix concurrency issue in givencrypt descriptor"
2cf3e79 - ahci_qoriq: bug fix for ecc_addr
43aec2b - arm64: dts: ls1028a: add gpu node
8d67002 - sdk_qbman: Avoid variable length array in USDPAA
63a7aba - net: dev: introduce support for sch BYPASS for lockless qdisc
e1924fc - net: sched: add empty status flag for NOLOCK qdisc
31639b0 - dpaa2-eth: add irq for the dpmac connect/disconnect event
ad0e508 - dpaa2-eth: Fix incorrect version check
1816b9c - dpaa2-eth: Fix FQ-based enqueue
97894b93 - crypto: caam - fix pkcs1pad(rsa-caam, sha256) failure because of invalid input
1bee6b6 - crypto: caam - fix concurrency issue in givencrypt descriptor
582dfcb - arm64: dts: ls1028a: Add temperature sensor node
9be8742 - staging: fsl-dpaa2: Remove duplicate config options
6e189a2 - arm64: dts: ls1028a: Fix CPU idle fail.
fe14f5f - spi: nxp-fspi: add "get_name" function
6aa2bb8 - dmaengine: fsl-edma: support little endian for edma driver
2505bc2 - arm64: dts: fsl: ls1028a: Add qDMA node
1a1da4d - arm64: dts: lx2160a: update interrupt property for Aquantia phy
052f93b - can: flexcan: Handle bit timings overflow
4687a6d - can: flexcan: enable flexcan for all architectures
ab64674 - can: flexcan: modify the interrupt register handling
ce7a15d - net: can: flexcan: can FD Format (FDF) changes
*refresh patches.
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
-rw-r--r-- | recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.19.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch index b01545f8..4e76c105 100644 --- a/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch +++ b/recipes-kernel/linux/linux-qoriq/0001-Makfefile-add-cflags.patch | |||
@@ -17,7 +17,7 @@ index 967692b..ae395cd 100644 | |||
17 | KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \ | 17 | KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \ |
18 | -fno-strict-aliasing -fno-common -fshort-wchar \ | 18 | -fno-strict-aliasing -fno-common -fshort-wchar \ |
19 | - -Werror-implicit-function-declaration \ | 19 | - -Werror-implicit-function-declaration \ |
20 | + -Werror-implicit-function-declaration -Wno-misleading-indentation -Wno-tautological-compare \ | 20 | + -Werror-implicit-function-declaration -Wno-address-of-packed-member \ |
21 | -Wno-format-security \ | 21 | -Wno-format-security \ |
22 | -std=gnu89 | 22 | -std=gnu89 |
23 | KBUILD_CPPFLAGS := -D__KERNEL__ | 23 | KBUILD_CPPFLAGS := -D__KERNEL__ |
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb index 13667ea5..bfea4bdf 100644 --- a/recipes-kernel/linux/linux-qoriq_4.19.bb +++ b/recipes-kernel/linux/linux-qoriq_4.19.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | |||
8 | 8 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
10 | " | 10 | " |
11 | SRCREV = "c0c2141106240d61e7b9d7c80284711d54f6ae91" | 11 | SRCREV = "1a4cab2c597de7ac87c6ab4ce2a42e5e5adb3c0b" |
12 | 12 | ||
13 | SRC_URI += " file://0001-Makfefile-add-cflags.patch \ | 13 | SRC_URI += " file://0001-Makfefile-add-cflags.patch \ |
14 | " | 14 | " |