diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2021-07-09 16:43:10 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-07-09 16:43:10 -0300 |
commit | 201b15ab63081938c6fd836798482a15cf1aeeb7 (patch) | |
tree | 4dbb21b1b3733142e123536071a515c62ebb5e8a | |
parent | 25f3bbf74029fc98a2a56c8b83653f628ae63bdc (diff) | |
parent | c72cb38b891cb916d3d71d86bfd0787ba947de2c (diff) | |
download | meta-freescale-201b15ab63081938c6fd836798482a15cf1aeeb7.tar.gz |
Merge pull request #825 from thochstein/u-boot
U-boot issues
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2021.04.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-mfgtool.inc | 4 |
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb index 40772e2b..6a279a12 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb | |||
@@ -8,7 +8,7 @@ require u-boot-imx-common_${PV}.inc | |||
8 | PROVIDES += "u-boot" | 8 | PROVIDES += "u-boot" |
9 | 9 | ||
10 | do_deploy_append_mx8m() { | 10 | do_deploy_append_mx8m() { |
11 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | 11 | # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary |
12 | if [ -n "${UBOOT_CONFIG}" ] | 12 | if [ -n "${UBOOT_CONFIG}" ] |
13 | then | 13 | then |
14 | for config in ${UBOOT_MACHINE}; do | 14 | for config in ${UBOOT_MACHINE}; do |
@@ -19,7 +19,7 @@ do_deploy_append_mx8m() { | |||
19 | then | 19 | then |
20 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | 20 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} |
21 | install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 21 | install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
22 | install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} | 22 | install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type} |
23 | fi | 23 | fi |
24 | done | 24 | done |
25 | unset j | 25 | unset j |
diff --git a/recipes-bsp/u-boot/u-boot-mfgtool.inc b/recipes-bsp/u-boot/u-boot-mfgtool.inc index 91526ad7..92d055bf 100644 --- a/recipes-bsp/u-boot/u-boot-mfgtool.inc +++ b/recipes-bsp/u-boot/u-boot-mfgtool.inc | |||
@@ -17,5 +17,5 @@ UBOOT_CONFIG = "mfgtool" | |||
17 | # Add 'mfgtool' suffix | 17 | # Add 'mfgtool' suffix |
18 | UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}" | 18 | UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}" |
19 | UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}" | 19 | UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}" |
20 | SPL_IMAGE = "${SPL_BINARY}-${MACHINE}-mfgtool-${PV}-${PR}" | 20 | SPL_IMAGE = "${SPL_BINARYNAME}-${MACHINE}-mfgtool-${PV}-${PR}" |
21 | SPL_SYMLINK = "${SPL_BINARY}-mfgtool-${MACHINE}" | 21 | SPL_SYMLINK = "${SPL_BINARYNAME}-mfgtool-${MACHINE}" |