diff options
author | Gary Bisson <gary.bisson@boundarydevices.com> | 2018-07-11 11:21:54 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-11 14:18:00 -0300 |
commit | 291060cd3b0dc49aeb9a745f898f690949f24cc2 (patch) | |
tree | 6deb993a2f17e6b966d2a003a3f278ebb581bf32 | |
parent | c326240080b83cb8ff601737969a6bf9e82fa1d8 (diff) | |
download | meta-freescale-291060cd3b0dc49aeb9a745f898f690949f24cc2.tar.gz |
imx-gpu-apitrace: add i.MX8MQ support
This is pretty much a copy of the recipe from meta-fsl-bsp-release.
The particularity of the i.MX8MQ is that it doesn't include a GPU2D and
therefore depending on virtual/libg2d isn't possible.
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
-rw-r--r-- | recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb | 27 |
1 files changed, 20 insertions, 7 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb index 79ef6579..80084150 100644 --- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb +++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_7.1.0.bb | |||
@@ -2,7 +2,7 @@ | |||
2 | SUMMARY = "Samples for OpenGL ES" | 2 | SUMMARY = "Samples for OpenGL ES" |
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50" |
5 | DEPENDS = "virtual/libg2d imx-gpu-viv zlib libpng procps" | 5 | DEPENDS = "imx-gpu-viv zlib libpng procps" |
6 | 6 | ||
7 | SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_7.1" | 7 | SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_7.1" |
8 | SRCREV = "9281b2c2f2766caf3529df347289128470318537" | 8 | SRCREV = "9281b2c2f2766caf3529df347289128470318537" |
@@ -11,14 +11,27 @@ S = "${WORKDIR}/git" | |||
11 | 11 | ||
12 | inherit cmake lib_package pkgconfig perlnative pythonnative | 12 | inherit cmake lib_package pkgconfig perlnative pythonnative |
13 | 13 | ||
14 | EXTRA_OECMAKE += "-DENABLE_VIVANTE=ON -DENABLE_MULTIARCH=OFF" | 14 | PACKAGECONFIG ??= "" |
15 | EXTRA_OECMAKE += \ | 15 | PACKAGECONFIG_append = \ |
16 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '-DDISABLE_X11=ON', \ | 16 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ |
17 | bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 17 | bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', \ |
18 | '-DDISABLE_X11=ON', d), d)}" | 18 | '', d), d)}" |
19 | PACKAGECONFIG_append_imxgpu2d = " vivante" | ||
20 | # For 8M, which has 3D but no 2D, eglretrace is not available | ||
21 | # on Wayland except through X11 and waffle. | ||
22 | PACKAGECONFIG_IMXGPU3D = \ | ||
23 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', ' waffle x11 x11-egl', '', d)}" | ||
24 | PACKAGECONFIG_IMXGPU3D_imxgpu2d = "" | ||
25 | PACKAGECONFIG_append_imxgpu3d = "${PACKAGECONFIG_IMXGPU3D}" | ||
26 | |||
27 | PACKAGECONFIG[multiarch] = "-DENABLE_MULTIARCH=ON,-DENABLE_MULTIARCH=OFF" | ||
28 | PACKAGECONFIG[waffle] = "-DENABLE_WAFFLE=ON,-DENABLE_WAFFLE=OFF,waffle" | ||
29 | PACKAGECONFIG[x11] = "-DDISABLE_X11=OFF,-DDISABLE_X11=ON" | ||
30 | PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=ON,-Dwaffle_has_x11_egl=OFF" | ||
31 | PACKAGECONFIG[vivante] = "-DENABLE_VIVANTE=ON,-DENABLE_VIVANTE=OFF,virtual/libg2d" | ||
19 | 32 | ||
20 | FILES_${PN} = "${bindir} ${libdir}" | 33 | FILES_${PN} = "${bindir} ${libdir}" |
21 | FILES_${PN}-dbg += "${libdir}/*/*/.debug" | 34 | FILES_${PN}-dbg += "${libdir}/*/*/.debug" |
22 | 35 | ||
23 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 36 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
24 | COMPATIBLE_MACHINE = "(mx6q|mx6dl|mx6sx|mx6sl|mx7ulp)" | 37 | COMPATIBLE_MACHINE = "(mx6q|mx6dl|mx6sx|mx6sl|mx7ulp|mx8mq)" |