diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-09-09 16:30:50 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2021-09-09 16:30:50 -0500 |
commit | 2a0c49b7f23545a267ea70762aec08f0231a19d9 (patch) | |
tree | b65d09f4e926378eaad69c817100548f8f6d36a8 | |
parent | 7e7e5408abaec6ea2e967dab2ef2c8e865712bc4 (diff) | |
download | meta-freescale-2a0c49b7f23545a267ea70762aec08f0231a19d9.tar.gz |
qcacld: Drop BSP support
NXP has dropped support for qcacld, plus the code is not compatible
with 5.10, so drop BSP support.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | recipes-bsp/firmware-qca/firmware-qca.inc | 15 | ||||
-rw-r--r-- | recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb | 27 | ||||
-rw-r--r-- | recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb | 27 | ||||
-rw-r--r-- | recipes-bsp/firmware-qca/qca-tools_3.0.2.bb | 20 | ||||
-rw-r--r-- | recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb | 13 | ||||
-rw-r--r-- | recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb | 12 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb | 14 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb | 17 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc | 23 |
9 files changed, 0 insertions, 168 deletions
diff --git a/recipes-bsp/firmware-qca/firmware-qca.inc b/recipes-bsp/firmware-qca/firmware-qca.inc deleted file mode 100644 index f33f4eb9..00000000 --- a/recipes-bsp/firmware-qca/firmware-qca.inc +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | # Copyright (C) 2018-2020 NXP | ||
2 | |||
3 | SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "Proprietary" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d \ | ||
7 | file://QUALCOMM_ATHEROS_LICENSE_AGREEMENT.pdf;md5=e629669cf17f6a2a6872e067582986e3 \ | ||
8 | " | ||
9 | |||
10 | SRC_URI = " ${FSL_MIRROR}/firmware-qca-${PV}.bin;fsl-eula=true" | ||
11 | SRC_URI[md5sum] = "75b1b2a8dea8f81609ccfc072d42fa86" | ||
12 | SRC_URI[sha256sum] = "6ad56ac1df841e252ac6db0a8966082715a3cb6dc7189426bade13333a16fd9d" | ||
13 | S = "${WORKDIR}/firmware-qca-${PV}" | ||
14 | |||
15 | inherit fsl-eula-unpack | ||
diff --git a/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb b/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb deleted file mode 100644 index a625a9d5..00000000 --- a/recipes-bsp/firmware-qca/firmware-qca6174_3.0.2.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | # Copyright (C) 2019-2020 NXP | ||
2 | |||
3 | require firmware-qca.inc | ||
4 | |||
5 | SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware" | ||
6 | DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth firmware for modules such as QCA6174A" | ||
7 | SECTION = "base" | ||
8 | LICENSE = "Proprietary" | ||
9 | |||
10 | inherit allarch | ||
11 | |||
12 | do_install () { | ||
13 | # Install firmware.conf for QCA modules | ||
14 | install -d ${D}${sysconfdir}/bluetooth | ||
15 | install -m 644 ${S}/1CQ_QCA6174A_LEA_2.0/etc/bluetooth/firmware.conf ${D}${sysconfdir}/bluetooth | ||
16 | |||
17 | # Install firmware files | ||
18 | install -d ${D}${base_libdir} | ||
19 | cp -r ${S}/1CQ_QCA6174A_LEA_2.0/lib/firmware ${D}${base_libdir} | ||
20 | } | ||
21 | |||
22 | FILES:${PN} = " \ | ||
23 | ${sysconfdir}/bluetooth/firmware.conf \ | ||
24 | ${base_libdir}/firmware/qca6174 \ | ||
25 | ${base_libdir}/firmware/wlan \ | ||
26 | ${base_libdir}/firmware/* \ | ||
27 | " | ||
diff --git a/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb b/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb deleted file mode 100644 index d6bf5caf..00000000 --- a/recipes-bsp/firmware-qca/firmware-qca9377_3.0.2.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | # Copyright (C) 2018-2020 NXP | ||
2 | |||
3 | require firmware-qca.inc | ||
4 | |||
5 | SUMMARY = "Qualcomm Wi-Fi and Bluetooth firmware" | ||
6 | DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth firmware for modules such as QCA9377-3" | ||
7 | SECTION = "base" | ||
8 | LICENSE = "Proprietary" | ||
9 | |||
10 | inherit allarch | ||
11 | |||
12 | do_install () { | ||
13 | # Install firmware.conf for QCA modules | ||
14 | install -d ${D}${sysconfdir}/bluetooth | ||
15 | install -m 644 ${S}/1PJ_QCA9377-3_LEA_3.0/etc/bluetooth/firmware.conf ${D}${sysconfdir}/bluetooth | ||
16 | |||
17 | # Install firmware files | ||
18 | install -d ${D}${base_libdir} | ||
19 | cp -r ${S}/1PJ_QCA9377-3_LEA_3.0/lib/firmware ${D}${base_libdir} | ||
20 | } | ||
21 | |||
22 | FILES:${PN} = " \ | ||
23 | ${sysconfdir}/bluetooth/firmware.conf \ | ||
24 | ${base_libdir}/firmware/qca \ | ||
25 | ${base_libdir}/firmware/qca9377 \ | ||
26 | ${base_libdir}/firmware/wlan \ | ||
27 | " | ||
diff --git a/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb b/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb deleted file mode 100644 index fd0c2e74..00000000 --- a/recipes-bsp/firmware-qca/qca-tools_3.0.2.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | # Copyright (C) 2018-2020 NXP | ||
2 | |||
3 | require firmware-qca.inc | ||
4 | |||
5 | SUMMARY = "Qualcomm Wi-Fi and Bluetooth tools" | ||
6 | DESCRIPTION = "Qualcomm Wi-Fi and Bluetooth tools for modules such as QCA6174A and QCA9377" | ||
7 | LICENSE = "Proprietary" | ||
8 | |||
9 | DEPENDS = "libnl zlib" | ||
10 | |||
11 | FCC_TOOLS_FOLDER ?= "qca9377_qca6174_arm32" | ||
12 | FCC_TOOLS_FOLDER:aarch64 = "qca9377_qca6174_arm64" | ||
13 | |||
14 | do_install() { | ||
15 | install -d ${D}${sbindir}/fcc_tools | ||
16 | cp -r ${S}/fcc_tools/${FCC_TOOLS_FOLDER} ${D}${sbindir}/fcc_tools | ||
17 | } | ||
18 | |||
19 | COMPATIBLE_HOST = '(aarch64|arm).*-linux' | ||
20 | COMPATIBLE_HOST:libc-musl = 'null' | ||
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb deleted file mode 100644 index 201f7d21..00000000 --- a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | # Copyright 2019 NXP | ||
2 | |||
3 | SUMMARY = "Qualcomm Wi-Fi support" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | RDEPENDS:${PN} = " \ | ||
8 | kernel-module-qca6174 \ | ||
9 | firmware-qca6174 \ | ||
10 | " | ||
11 | |||
12 | COMPATIBLE_HOST = '(aarch64|arm).*-linux' | ||
13 | COMPATIBLE_HOST:libc-musl = 'null' | ||
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb deleted file mode 100644 index 2e3e9ced..00000000 --- a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | # Copyright 2019 NXP | ||
2 | |||
3 | SUMMARY = "Qualcomm Wi-Fi support" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | RDEPENDS:${PN} = " \ | ||
8 | kernel-module-qca9377 \ | ||
9 | firmware-qca9377 \ | ||
10 | " | ||
11 | COMPATIBLE_HOST = '(aarch64|arm).*-linux' | ||
12 | COMPATIBLE_HOST:libc-musl = 'null' | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb deleted file mode 100644 index 40eadef3..00000000 --- a/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | require kernel-module-qcacld-lea.inc | ||
2 | |||
3 | SUMMARY = "Qualcomm WiFi driver for QCA module 6174" | ||
4 | |||
5 | EXTRA_OEMAKE += " \ | ||
6 | CONFIG_ROME_IF=pci \ | ||
7 | CONFIG_WLAN_FEATURE_11W=y \ | ||
8 | CONFIG_WLAN_FEATURE_FILS=y \ | ||
9 | CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \ | ||
10 | MODNAME=qca6174 \ | ||
11 | CONFIG_WLAN_FEATURE_DSRC=y \ | ||
12 | " | ||
13 | |||
14 | RDEPENDS:${PN} += "firmware-qca6174" | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb deleted file mode 100644 index 92bc01fc..00000000 --- a/recipes-kernel/kernel-modules/kernel-module-qca9377_3.1.bb +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | require kernel-module-qcacld-lea.inc | ||
2 | |||
3 | SUMMARY = "Qualcomm WiFi driver for QCA module 9377" | ||
4 | |||
5 | EXTRA_OEMAKE += " \ | ||
6 | CONFIG_CLD_HL_SDIO_CORE=y \ | ||
7 | CONFIG_FEATURE_COEX_PTA_CONFIG_ENABLE=y \ | ||
8 | CONFIG_PER_VDEV_TX_DESC_POOL=1 \ | ||
9 | CONFIG_QCA_LL_TX_FLOW_CT=1 \ | ||
10 | CONFIG_QCA_SUPPORT_TXRX_DRIVER_TCP_DEL_ACK=y \ | ||
11 | CONFIG_WLAN_FEATURE_FILS=y \ | ||
12 | CONFIG_WLAN_WAPI_MODE_11AC_DISABLE=y \ | ||
13 | MODNAME=qca9377 \ | ||
14 | SAP_AUTH_OFFLOAD=1 \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS:${PN} += "firmware-qca9377" | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc deleted file mode 100644 index a7b8a4e6..00000000 --- a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Qualcomm WiFi driver for QCA module 9377 and 6174" | ||
2 | LICENSE = "BSD & GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=ec8d62116b13db773825ebf7cf91be1d;" | ||
4 | |||
5 | QCACLD_SRC ?= "git://source.codeaurora.org/external/imx/qcacld-2.0-imx.git;protocol=https" | ||
6 | SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_3.0_KRL5.4" | ||
7 | SRCREV = "7dc91e5977f31d60741c55682564788c0f930163" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | inherit module | ||
12 | |||
13 | EXTRA_OEMAKE += " \ | ||
14 | CONFIG_CFG80211_INTERNAL_REGDB=y \ | ||
15 | CONFIG_HDD_WLAN_WAIT_TIME=10000 \ | ||
16 | CONFIG_LINUX_QCMBR=y \ | ||
17 | CONFIG_NON_QC_PLATFORM=y \ | ||
18 | CONFIG_PMF_SUPPORT=y \ | ||
19 | TARGET_BUILD_VARIANT=user \ | ||
20 | " | ||
21 | |||
22 | COMPATIBLE_MACHINE = "(imx)" | ||
23 | COMPATIBLE_HOST:libc-musl = 'null' | ||