diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2017-01-16 13:52:25 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-23 16:55:31 -0200 |
commit | 599f72c34c826142ed56c41261163f795dcdfa18 (patch) | |
tree | 0692bbc0fa837218873c2035de6b6746d4ce9c81 | |
parent | a9184abc1842cbecadd754c2d6bc8e32d7cdf5f1 (diff) | |
download | meta-freescale-599f72c34c826142ed56c41261163f795dcdfa18.tar.gz |
weston: Undo recent command-line change for renderer selection
To restore command-line compatibility, reverting back to
integer-based renderer selection syntax:
weston [--use-gl=0|1] [--use-g2d=0|1]
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
4 files changed, 116 insertions, 146 deletions
diff --git a/recipes-graphics/wayland/weston/0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch b/recipes-graphics/wayland/weston/0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch index 9a80d9ed..cfe8f605 100644 --- a/recipes-graphics/wayland/weston/0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch +++ b/recipes-graphics/wayland/weston/0002-MGS-1111-Add-GPU-VIV-suport-for-wayland-and-weston-1.patch | |||
@@ -15,10 +15,10 @@ Signed-off-by: Prabhu <prabhu.sundararaj@freescale.com> | |||
15 | create mode 100644 src/gal2d-renderer.c | 15 | create mode 100644 src/gal2d-renderer.c |
16 | create mode 100644 src/gal2d-renderer.h | 16 | create mode 100644 src/gal2d-renderer.h |
17 | 17 | ||
18 | Index: weston-1.11.0/Makefile.am | 18 | Index: weston-1.11.1/Makefile.am |
19 | =================================================================== | 19 | =================================================================== |
20 | --- weston-1.11.0.orig/Makefile.am 2016-05-19 16:36:04.000000000 -0500 | 20 | --- weston-1.11.1.orig/Makefile.am 2016-09-20 19:35:22.000000000 -0500 |
21 | +++ weston-1.11.0/Makefile.am 2016-09-20 15:28:46.634190725 -0500 | 21 | +++ weston-1.11.1/Makefile.am 2017-01-14 08:35:10.000000000 -0600 |
22 | @@ -247,6 +247,18 @@ | 22 | @@ -247,6 +247,18 @@ |
23 | src/vertex-clipping.h \ | 23 | src/vertex-clipping.h \ |
24 | shared/helpers.h | 24 | shared/helpers.h |
@@ -38,10 +38,10 @@ Index: weston-1.11.0/Makefile.am | |||
38 | 38 | ||
39 | if ENABLE_X11_COMPOSITOR | 39 | if ENABLE_X11_COMPOSITOR |
40 | module_LTLIBRARIES += x11-backend.la | 40 | module_LTLIBRARIES += x11-backend.la |
41 | Index: weston-1.11.0/src/compositor-fbdev.c | 41 | Index: weston-1.11.1/src/compositor-fbdev.c |
42 | =================================================================== | 42 | =================================================================== |
43 | --- weston-1.11.0.orig/src/compositor-fbdev.c 2016-05-19 16:36:04.000000000 -0500 | 43 | --- weston-1.11.1.orig/src/compositor-fbdev.c 2016-09-20 19:35:22.000000000 -0500 |
44 | +++ weston-1.11.0/src/compositor-fbdev.c 2016-09-20 17:05:27.000000000 -0500 | 44 | +++ weston-1.11.1/src/compositor-fbdev.c 2017-01-14 08:35:11.000000000 -0600 |
45 | @@ -50,6 +50,7 @@ | 45 | @@ -50,6 +50,7 @@ |
46 | #include "libinput-seat.h" | 46 | #include "libinput-seat.h" |
47 | #include "gl-renderer.h" | 47 | #include "gl-renderer.h" |
@@ -263,10 +263,10 @@ Index: weston-1.11.0/src/compositor-fbdev.c | |||
263 | config->output_transform = WL_OUTPUT_TRANSFORM_NORMAL; | 263 | config->output_transform = WL_OUTPUT_TRANSFORM_NORMAL; |
264 | } | 264 | } |
265 | 265 | ||
266 | Index: weston-1.11.0/src/gal2d-renderer.c | 266 | Index: weston-1.11.1/src/gal2d-renderer.c |
267 | =================================================================== | 267 | =================================================================== |
268 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 268 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
269 | +++ weston-1.11.0/src/gal2d-renderer.c 2016-09-20 16:58:24.000000000 -0500 | 269 | +++ weston-1.11.1/src/gal2d-renderer.c 2017-01-14 08:35:10.000000000 -0600 |
270 | @@ -0,0 +1,1342 @@ | 270 | @@ -0,0 +1,1342 @@ |
271 | +/* | 271 | +/* |
272 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. | 272 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. |
@@ -1610,10 +1610,10 @@ Index: weston-1.11.0/src/gal2d-renderer.c | |||
1610 | + .output_create = gal2d_renderer_output_create, | 1610 | + .output_create = gal2d_renderer_output_create, |
1611 | + .output_destroy = gal2d_renderer_output_destroy, | 1611 | + .output_destroy = gal2d_renderer_output_destroy, |
1612 | +}; | 1612 | +}; |
1613 | Index: weston-1.11.0/src/gal2d-renderer.h | 1613 | Index: weston-1.11.1/src/gal2d-renderer.h |
1614 | =================================================================== | 1614 | =================================================================== |
1615 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 1615 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
1616 | +++ weston-1.11.0/src/gal2d-renderer.h 2016-09-20 15:28:46.638190745 -0500 | 1616 | +++ weston-1.11.1/src/gal2d-renderer.h 2017-01-14 08:35:10.000000000 -0600 |
1617 | @@ -0,0 +1,50 @@ | 1617 | @@ -0,0 +1,50 @@ |
1618 | +/* | 1618 | +/* |
1619 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. | 1619 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. |
@@ -1665,10 +1665,10 @@ Index: weston-1.11.0/src/gal2d-renderer.h | |||
1665 | +}; | 1665 | +}; |
1666 | + | 1666 | + |
1667 | +#endif | 1667 | +#endif |
1668 | Index: weston-1.11.0/src/compositor-fbdev.h | 1668 | Index: weston-1.11.1/src/compositor-fbdev.h |
1669 | =================================================================== | 1669 | =================================================================== |
1670 | --- weston-1.11.0.orig/src/compositor-fbdev.h 2016-05-19 16:36:04.000000000 -0500 | 1670 | --- weston-1.11.1.orig/src/compositor-fbdev.h 2016-09-20 19:35:22.000000000 -0500 |
1671 | +++ weston-1.11.0/src/compositor-fbdev.h 2016-09-20 17:03:37.000000000 -0500 | 1671 | +++ weston-1.11.1/src/compositor-fbdev.h 2017-01-14 08:35:10.000000000 -0600 |
1672 | @@ -40,6 +40,7 @@ | 1672 | @@ -40,6 +40,7 @@ |
1673 | int tty; | 1673 | int tty; |
1674 | char *device; | 1674 | char *device; |
@@ -1677,59 +1677,32 @@ Index: weston-1.11.0/src/compositor-fbdev.h | |||
1677 | 1677 | ||
1678 | uint32_t output_transform; | 1678 | uint32_t output_transform; |
1679 | }; | 1679 | }; |
1680 | Index: weston-1.11.0/src/main.c | 1680 | Index: weston-1.11.1/src/main.c |
1681 | =================================================================== | 1681 | =================================================================== |
1682 | --- weston-1.11.0.orig/src/main.c 2016-05-19 16:36:04.000000000 -0500 | 1682 | --- weston-1.11.1.orig/src/main.c 2017-01-14 08:34:10.030218137 -0600 |
1683 | +++ weston-1.11.0/src/main.c 2016-09-20 17:29:12.000000000 -0500 | 1683 | +++ weston-1.11.1/src/main.c 2017-01-14 08:54:45.000000000 -0600 |
1684 | @@ -285,7 +285,13 @@ | 1684 | @@ -285,7 +285,13 @@ |
1685 | "Options for fbdev-backend.so:\n\n" | 1685 | "Options for fbdev-backend.so:\n\n" |
1686 | " --tty=TTY\t\tThe tty to use\n" | 1686 | " --tty=TTY\t\tThe tty to use\n" |
1687 | " --device=DEVICE\tThe framebuffer device to use\n" | 1687 | " --device=DEVICE\tThe framebuffer device to use\n" |
1688 | - " --use-gl\t\tUse the GL renderer\n\n"); | 1688 | - " --use-gl\t\tUse the GL renderer\n\n"); |
1689 | +#if defined ENABLE_EGL | 1689 | +#if defined ENABLE_EGL |
1690 | + " --no-use-gl\t\tDo not use the GL renderer\n" | 1690 | + " --use-gl=1\t\tUse the GL renderer (default is 1)\n" |
1691 | + " --use-gal2d\t\tUse the GAL2D renderer\n\n"); | 1691 | + " --use-gal2d=1\t\tUse the GAL2D renderer (default is 0)\n\n"); |
1692 | +#else | 1692 | +#else |
1693 | + " --use-gl\t\tUse the GL renderer\n" | 1693 | + " --use-gl=1\t\tUse the GL renderer (default is 0)\n" |
1694 | + " --no-use-gal2d\t\tDo not use the GAL2D renderer\n\n"); | 1694 | + " --use-gal2d=1\t\tUse the GAL2D renderer (default is 1)\n\n"); |
1695 | +#endif | 1695 | +#endif |
1696 | #endif | 1696 | #endif |
1697 | 1697 | ||
1698 | #if defined(BUILD_HEADLESS_COMPOSITOR) | 1698 | #if defined(BUILD_HEADLESS_COMPOSITOR) |
1699 | @@ -864,18 +870,35 @@ | 1699 | @@ -868,7 +874,8 @@ |
1700 | struct weston_config_section *section; | ||
1701 | char *s = NULL; | ||
1702 | int ret = 0; | ||
1703 | +#ifdef ENABLE_EGL | ||
1704 | + /* GL rendering is default, so user options are --no-use-gl and --use-gal2d */ | ||
1705 | + int no_use_gl = 0; | ||
1706 | +#else | ||
1707 | + /* GAL2D rendering is default, so user options are --use-gl and --no-use-gal2d */ | ||
1708 | + int no_use_gal2d = 0; | ||
1709 | +#endif | ||
1710 | |||
1711 | const struct weston_option fbdev_options[] = { | 1700 | const struct weston_option fbdev_options[] = { |
1712 | { WESTON_OPTION_INTEGER, "tty", 0, &config.tty }, | 1701 | { WESTON_OPTION_INTEGER, "tty", 0, &config.tty }, |
1713 | { WESTON_OPTION_STRING, "device", 0, &config.device }, | 1702 | { WESTON_OPTION_STRING, "device", 0, &config.device }, |
1714 | +#ifdef ENABLE_EGL | 1703 | - { WESTON_OPTION_BOOLEAN, "use-gl", 0, &config.use_gl }, |
1715 | + { WESTON_OPTION_BOOLEAN, "no-use-gl", 0, &no_use_gl }, | 1704 | + { WESTON_OPTION_INTEGER, "use-gl", 0, &config.use_gl }, |
1716 | + { WESTON_OPTION_BOOLEAN, "use-gal2d", 0, &config.use_gal2d }, | 1705 | + { WESTON_OPTION_INTEGER, "use-gal2d", 0, &config.use_gal2d }, |
1717 | +#else | ||
1718 | { WESTON_OPTION_BOOLEAN, "use-gl", 0, &config.use_gl }, | ||
1719 | + { WESTON_OPTION_BOOLEAN, "no-use-gal2d", 0, &no_use_gal2d }, | ||
1720 | +#endif | ||
1721 | }; | 1706 | }; |
1722 | 1707 | ||
1723 | parse_options(fbdev_options, ARRAY_LENGTH(fbdev_options), argc, argv); | 1708 | parse_options(fbdev_options, ARRAY_LENGTH(fbdev_options), argc, argv); |
1724 | |||
1725 | if (!config.device) | ||
1726 | config.device = strdup("/dev/fb0"); | ||
1727 | - | ||
1728 | +#ifdef ENABLE_EGL | ||
1729 | + config.use_gl = !no_use_gl; | ||
1730 | +#else | ||
1731 | + config.use_gal2d = !no_use_gal2d; | ||
1732 | +#endif | ||
1733 | section = weston_config_get_section(wc, "output", "name", "fbdev"); | ||
1734 | weston_config_section_get_string(section, "transform", &s, "normal"); | ||
1735 | if (weston_parse_transform(s, &config.output_transform) < 0) | ||
diff --git a/recipes-graphics/wayland/weston/0009-MGS-1284-xwld-Re-implement-weston-2d-renderer-with-p.patch b/recipes-graphics/wayland/weston/0009-MGS-1284-xwld-Re-implement-weston-2d-renderer-with-p.patch index 0afbd4b6..f48785f1 100644 --- a/recipes-graphics/wayland/weston/0009-MGS-1284-xwld-Re-implement-weston-2d-renderer-with-p.patch +++ b/recipes-graphics/wayland/weston/0009-MGS-1284-xwld-Re-implement-weston-2d-renderer-with-p.patch | |||
@@ -25,10 +25,10 @@ Signed-off-by: Yong Gan <yong.gan@freescale.com> | |||
25 | delete mode 100644 src/gal2d-renderer.c | 25 | delete mode 100644 src/gal2d-renderer.c |
26 | delete mode 100644 src/gal2d-renderer.h | 26 | delete mode 100644 src/gal2d-renderer.h |
27 | 27 | ||
28 | Index: weston-1.11.0/Makefile.am | 28 | Index: weston-1.11.1/Makefile.am |
29 | =================================================================== | 29 | =================================================================== |
30 | --- weston-1.11.0.orig/Makefile.am 2016-10-06 14:26:20.254564856 -0500 | 30 | --- weston-1.11.1.orig/Makefile.am 2017-01-14 08:59:52.293865810 -0600 |
31 | +++ weston-1.11.0/Makefile.am 2016-10-06 14:28:47.000000000 -0500 | 31 | +++ weston-1.11.1/Makefile.am 2017-01-14 09:08:38.000000000 -0600 |
32 | @@ -247,16 +247,16 @@ | 32 | @@ -247,16 +247,16 @@ |
33 | src/vertex-clipping.h \ | 33 | src/vertex-clipping.h \ |
34 | shared/helpers.h | 34 | shared/helpers.h |
@@ -54,10 +54,10 @@ Index: weston-1.11.0/Makefile.am | |||
54 | src/vertex-clipping.c \ | 54 | src/vertex-clipping.c \ |
55 | src/vertex-clipping.h | 55 | src/vertex-clipping.h |
56 | 56 | ||
57 | Index: weston-1.11.0/src/compositor-fbdev.c | 57 | Index: weston-1.11.1/src/compositor-fbdev.c |
58 | =================================================================== | 58 | =================================================================== |
59 | --- weston-1.11.0.orig/src/compositor-fbdev.c 2016-10-06 14:26:20.418565670 -0500 | 59 | --- weston-1.11.1.orig/src/compositor-fbdev.c 2017-01-14 08:59:52.473866702 -0600 |
60 | +++ weston-1.11.0/src/compositor-fbdev.c 2016-10-06 14:28:47.000000000 -0500 | 60 | +++ weston-1.11.1/src/compositor-fbdev.c 2017-01-14 09:19:12.000000000 -0600 |
61 | @@ -50,7 +50,7 @@ | 61 | @@ -50,7 +50,7 @@ |
62 | #include "libinput-seat.h" | 62 | #include "libinput-seat.h" |
63 | #include "gl-renderer.h" | 63 | #include "gl-renderer.h" |
@@ -186,23 +186,25 @@ Index: weston-1.11.0/src/compositor-fbdev.c | |||
186 | if (fbdev_output_create(backend, 0, 0, param->device) < 0) | 186 | if (fbdev_output_create(backend, 0, 0, param->device) < 0) |
187 | goto out_launcher; | 187 | goto out_launcher; |
188 | 188 | ||
189 | @@ -924,10 +898,10 @@ | 189 | @@ -922,13 +896,8 @@ |
190 | * udev, rather than passing a device node in as a parameter. */ | ||
191 | config->tty = 0; /* default to current tty */ | ||
190 | config->device = "/dev/fb0"; /* default frame buffer */ | 192 | config->device = "/dev/fb0"; /* default frame buffer */ |
191 | #ifdef ENABLE_EGL | 193 | -#ifdef ENABLE_EGL |
192 | config->use_gl = 1; | 194 | - config->use_gl = 1; |
193 | - config->use_gal2d = 0; | 195 | - config->use_gal2d = 0; |
194 | + config->use_g2d = 0; | 196 | -#else |
195 | #else | ||
196 | config->use_gl = 0; | 197 | config->use_gl = 0; |
197 | - config->use_gal2d = 1; | 198 | - config->use_gal2d = 1; |
198 | + config->use_g2d = 1; | 199 | -#endif |
199 | #endif | 200 | + config->use_g2d = 0; |
200 | config->output_transform = WL_OUTPUT_TRANSFORM_NORMAL; | 201 | config->output_transform = WL_OUTPUT_TRANSFORM_NORMAL; |
201 | } | 202 | } |
202 | Index: weston-1.11.0/src/g2d-renderer.c | 203 | |
204 | Index: weston-1.11.1/src/g2d-renderer.c | ||
203 | =================================================================== | 205 | =================================================================== |
204 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 206 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
205 | +++ weston-1.11.0/src/g2d-renderer.c 2016-10-06 14:28:47.000000000 -0500 | 207 | +++ weston-1.11.1/src/g2d-renderer.c 2017-01-14 09:08:38.000000000 -0600 |
206 | @@ -0,0 +1,1175 @@ | 208 | @@ -0,0 +1,1175 @@ |
207 | +/* | 209 | +/* |
208 | + * Copyright (c) 2016 Freescale Semiconductor, Inc. | 210 | + * Copyright (c) 2016 Freescale Semiconductor, Inc. |
@@ -1379,10 +1381,10 @@ Index: weston-1.11.0/src/g2d-renderer.c | |||
1379 | + .output_create = g2d_renderer_output_create, | 1381 | + .output_create = g2d_renderer_output_create, |
1380 | + .output_destroy = g2d_renderer_output_destroy, | 1382 | + .output_destroy = g2d_renderer_output_destroy, |
1381 | +}; | 1383 | +}; |
1382 | Index: weston-1.11.0/src/g2d-renderer.h | 1384 | Index: weston-1.11.1/src/g2d-renderer.h |
1383 | =================================================================== | 1385 | =================================================================== |
1384 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | 1386 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 |
1385 | +++ weston-1.11.0/src/g2d-renderer.h 2016-10-06 14:28:47.000000000 -0500 | 1387 | +++ weston-1.11.1/src/g2d-renderer.h 2017-01-14 09:08:38.000000000 -0600 |
1386 | @@ -0,0 +1,48 @@ | 1388 | @@ -0,0 +1,48 @@ |
1387 | +/* | 1389 | +/* |
1388 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. | 1390 | + * Copyright (c) 2015 Freescale Semiconductor, Inc. |
@@ -1432,9 +1434,9 @@ Index: weston-1.11.0/src/g2d-renderer.h | |||
1432 | +}; | 1434 | +}; |
1433 | + | 1435 | + |
1434 | +#endif | 1436 | +#endif |
1435 | Index: weston-1.11.0/src/gal2d-renderer.c | 1437 | Index: weston-1.11.1/src/gal2d-renderer.c |
1436 | =================================================================== | 1438 | =================================================================== |
1437 | --- weston-1.11.0.orig/src/gal2d-renderer.c 2016-10-06 14:26:20.678566959 -0500 | 1439 | --- weston-1.11.1.orig/src/gal2d-renderer.c 2017-01-14 08:59:52.753868091 -0600 |
1438 | +++ /dev/null 1970-01-01 00:00:00.000000000 +0000 | 1440 | +++ /dev/null 1970-01-01 00:00:00.000000000 +0000 |
1439 | @@ -1,1307 +0,0 @@ | 1441 | @@ -1,1307 +0,0 @@ |
1440 | -/* | 1442 | -/* |
@@ -2744,9 +2746,9 @@ Index: weston-1.11.0/src/gal2d-renderer.c | |||
2744 | - .output_create = gal2d_renderer_output_create, | 2746 | - .output_create = gal2d_renderer_output_create, |
2745 | - .output_destroy = gal2d_renderer_output_destroy, | 2747 | - .output_destroy = gal2d_renderer_output_destroy, |
2746 | -}; | 2748 | -}; |
2747 | Index: weston-1.11.0/src/gal2d-renderer.h | 2749 | Index: weston-1.11.1/src/gal2d-renderer.h |
2748 | =================================================================== | 2750 | =================================================================== |
2749 | --- weston-1.11.0.orig/src/gal2d-renderer.h 2016-10-06 14:26:20.254564856 -0500 | 2751 | --- weston-1.11.1.orig/src/gal2d-renderer.h 2017-01-14 08:59:52.297865829 -0600 |
2750 | +++ /dev/null 1970-01-01 00:00:00.000000000 +0000 | 2752 | +++ /dev/null 1970-01-01 00:00:00.000000000 +0000 |
2751 | @@ -1,50 +0,0 @@ | 2753 | @@ -1,50 +0,0 @@ |
2752 | -/* | 2754 | -/* |
@@ -2799,64 +2801,36 @@ Index: weston-1.11.0/src/gal2d-renderer.h | |||
2799 | -}; | 2801 | -}; |
2800 | - | 2802 | - |
2801 | -#endif | 2803 | -#endif |
2802 | Index: weston-1.11.0/src/main.c | 2804 | Index: weston-1.11.1/src/main.c |
2803 | =================================================================== | 2805 | =================================================================== |
2804 | --- weston-1.11.0.orig/src/main.c 2016-10-06 14:26:20.258564876 -0500 | 2806 | --- weston-1.11.1.orig/src/main.c 2017-01-14 08:59:52.297865829 -0600 |
2805 | +++ weston-1.11.0/src/main.c 2016-10-06 14:28:47.000000000 -0500 | 2807 | +++ weston-1.11.1/src/main.c 2017-01-14 09:08:38.000000000 -0600 |
2806 | @@ -287,10 +287,10 @@ | 2808 | @@ -287,10 +287,10 @@ |
2807 | " --device=DEVICE\tThe framebuffer device to use\n" | 2809 | " --device=DEVICE\tThe framebuffer device to use\n" |
2808 | #if defined ENABLE_EGL | 2810 | #if defined ENABLE_EGL |
2809 | " --no-use-gl\t\tDo not use the GL renderer\n" | 2811 | " --use-gl=1\t\tUse the GL renderer (default is 1)\n" |
2810 | - " --use-gal2d\t\tUse the GAL2D renderer\n\n"); | 2812 | - " --use-gal2d=1\t\tUse the GAL2D renderer (default is 0)\n\n"); |
2811 | + " --use-g2d\t\tUse the G2D renderer\n\n"); | 2813 | + " --use-g2d=1\t\tUse the G2D renderer (default is 0)\n\n"); |
2812 | #else | 2814 | #else |
2813 | " --use-gl\t\tUse the GL renderer\n" | 2815 | " --use-gl=1\t\tUse the GL renderer (default is 0)\n" |
2814 | - " --no-use-gal2d\t\tDo not use the GAL2D renderer\n\n"); | 2816 | - " --use-gal2d=1\t\tUse the GAL2D renderer (default is 1)\n\n"); |
2815 | + " --no-use-g2d\t\tDo not use the G2D renderer\n\n"); | 2817 | + " --use-g2d=1\t\tUse the G2D renderer (default is 1)\n\n"); |
2816 | #endif | 2818 | #endif |
2817 | #endif | 2819 | #endif |
2818 | 2820 | ||
2819 | @@ -871,11 +871,11 @@ | 2821 | @@ -875,7 +875,7 @@ |
2820 | char *s = NULL; | 2822 | { WESTON_OPTION_INTEGER, "tty", 0, &config.tty }, |
2821 | int ret = 0; | ||
2822 | #ifdef ENABLE_EGL | ||
2823 | - /* GL rendering is default, so user options are --no-use-gl and --use-gal2d */ | ||
2824 | + /* GL rendering is default, so user options are --no-use-gl and --use-g2d */ | ||
2825 | int no_use_gl = 0; | ||
2826 | #else | ||
2827 | - /* GAL2D rendering is default, so user options are --use-gl and --no-use-gal2d */ | ||
2828 | - int no_use_gal2d = 0; | ||
2829 | + /* G2D rendering is default, so user options are --use-gl and --no-use-g2d */ | ||
2830 | + int no_use_g2d = 0; | ||
2831 | #endif | ||
2832 | |||
2833 | const struct weston_option fbdev_options[] = { | ||
2834 | @@ -883,10 +883,10 @@ | ||
2835 | { WESTON_OPTION_STRING, "device", 0, &config.device }, | 2823 | { WESTON_OPTION_STRING, "device", 0, &config.device }, |
2836 | #ifdef ENABLE_EGL | 2824 | { WESTON_OPTION_INTEGER, "use-gl", 0, &config.use_gl }, |
2837 | { WESTON_OPTION_BOOLEAN, "no-use-gl", 0, &no_use_gl }, | 2825 | - { WESTON_OPTION_INTEGER, "use-gal2d", 0, &config.use_gal2d }, |
2838 | - { WESTON_OPTION_BOOLEAN, "use-gal2d", 0, &config.use_gal2d }, | 2826 | + { WESTON_OPTION_INTEGER, "use-g2d", 0, &config.use_g2d }, |
2839 | + { WESTON_OPTION_BOOLEAN, "use-g2d", 0, &config.use_g2d }, | ||
2840 | #else | ||
2841 | { WESTON_OPTION_BOOLEAN, "use-gl", 0, &config.use_gl }, | ||
2842 | - { WESTON_OPTION_BOOLEAN, "no-use-gal2d", 0, &no_use_gal2d }, | ||
2843 | + { WESTON_OPTION_BOOLEAN, "no-use-g2d", 0, &no_use_g2d }, | ||
2844 | #endif | ||
2845 | }; | 2827 | }; |
2846 | 2828 | ||
2847 | @@ -897,7 +897,7 @@ | 2829 | parse_options(fbdev_options, ARRAY_LENGTH(fbdev_options), argc, argv); |
2848 | #ifdef ENABLE_EGL | 2830 | Index: weston-1.11.1/src/compositor-fbdev.h |
2849 | config.use_gl = !no_use_gl; | ||
2850 | #else | ||
2851 | - config.use_gal2d = !no_use_gal2d; | ||
2852 | + config.use_g2d = !no_use_g2d; | ||
2853 | #endif | ||
2854 | section = weston_config_get_section(wc, "output", "name", "fbdev"); | ||
2855 | weston_config_section_get_string(section, "transform", &s, "normal"); | ||
2856 | Index: weston-1.11.0/src/compositor-fbdev.h | ||
2857 | =================================================================== | 2831 | =================================================================== |
2858 | --- weston-1.11.0.orig/src/compositor-fbdev.h 2016-10-06 14:26:20.258564876 -0500 | 2832 | --- weston-1.11.1.orig/src/compositor-fbdev.h 2017-01-14 08:59:52.297865829 -0600 |
2859 | +++ weston-1.11.0/src/compositor-fbdev.h 2016-10-06 14:34:09.000000000 -0500 | 2833 | +++ weston-1.11.1/src/compositor-fbdev.h 2017-01-14 08:59:52.841868527 -0600 |
2860 | @@ -40,7 +40,8 @@ | 2834 | @@ -40,7 +40,8 @@ |
2861 | int tty; | 2835 | int tty; |
2862 | char *device; | 2836 | char *device; |
diff --git a/recipes-graphics/wayland/weston/0011-MGS-1724-xwld-G2D-compositor-build-failed-in-slevk-b.patch b/recipes-graphics/wayland/weston/0011-MGS-1724-xwld-G2D-compositor-build-failed-in-slevk-b.patch index f7bee2fe..42a33394 100644 --- a/recipes-graphics/wayland/weston/0011-MGS-1724-xwld-G2D-compositor-build-failed-in-slevk-b.patch +++ b/recipes-graphics/wayland/weston/0011-MGS-1724-xwld-G2D-compositor-build-failed-in-slevk-b.patch | |||
@@ -15,10 +15,10 @@ Signed-off-by: Yong Gan <yong.gan@nxp.com> | |||
15 | src/g2d-renderer.c | 4 ++-- | 15 | src/g2d-renderer.c | 4 ++-- |
16 | 2 files changed, 12 insertions(+), 3 deletions(-) | 16 | 2 files changed, 12 insertions(+), 3 deletions(-) |
17 | 17 | ||
18 | Index: weston-1.11.0/src/compositor-fbdev.c | 18 | Index: weston-1.11.1/src/compositor-fbdev.c |
19 | =================================================================== | 19 | =================================================================== |
20 | --- weston-1.11.0.orig/src/compositor-fbdev.c 2016-10-06 13:11:53.376414804 -0500 | 20 | --- weston-1.11.1.orig/src/compositor-fbdev.c 2017-01-14 09:47:24.064006974 -0600 |
21 | +++ weston-1.11.0/src/compositor-fbdev.c 2016-10-06 13:19:16.000000000 -0500 | 21 | +++ weston-1.11.1/src/compositor-fbdev.c 2017-01-14 09:55:59.000000000 -0600 |
22 | @@ -63,7 +63,9 @@ | 22 | @@ -63,7 +63,9 @@ |
23 | int use_g2d; | 23 | int use_g2d; |
24 | uint32_t output_transform; | 24 | uint32_t output_transform; |
@@ -86,10 +86,10 @@ Index: weston-1.11.0/src/compositor-fbdev.c | |||
86 | } | 86 | } |
87 | if(!backend->use_g2d) | 87 | if(!backend->use_g2d) |
88 | if (fbdev_output_create(backend, 0, 0, param->device) < 0) | 88 | if (fbdev_output_create(backend, 0, 0, param->device) < 0) |
89 | Index: weston-1.11.0/src/g2d-renderer.c | 89 | Index: weston-1.11.1/src/g2d-renderer.c |
90 | =================================================================== | 90 | =================================================================== |
91 | --- weston-1.11.0.orig/src/g2d-renderer.c 2016-10-06 13:11:53.376414804 -0500 | 91 | --- weston-1.11.1.orig/src/g2d-renderer.c 2017-01-14 09:47:24.152007410 -0600 |
92 | +++ weston-1.11.0/src/g2d-renderer.c 2016-10-06 13:11:53.372414784 -0500 | 92 | +++ weston-1.11.1/src/g2d-renderer.c 2017-01-14 09:48:56.000000000 -0600 |
93 | @@ -756,11 +756,11 @@ | 93 | @@ -756,11 +756,11 @@ |
94 | 94 | ||
95 | switch (wl_shm_buffer_get_format(shm_buffer)) { | 95 | switch (wl_shm_buffer_get_format(shm_buffer)) { |
@@ -104,3 +104,26 @@ Index: weston-1.11.0/src/g2d-renderer.c | |||
104 | gs->bpp = 4; | 104 | gs->bpp = 4; |
105 | break; | 105 | break; |
106 | case WL_SHM_FORMAT_RGB565: | 106 | case WL_SHM_FORMAT_RGB565: |
107 | Index: weston-1.11.1/src/main.c | ||
108 | =================================================================== | ||
109 | --- weston-1.11.1.orig/src/main.c 2017-01-14 10:02:42.000000000 -0600 | ||
110 | +++ weston-1.11.1/src/main.c 2017-01-14 10:02:58.000000000 -0600 | ||
111 | @@ -866,7 +866,17 @@ | ||
112 | load_fbdev_backend(struct weston_compositor *c, char const * backend, | ||
113 | int *argc, char **argv, struct weston_config *wc) | ||
114 | { | ||
115 | - struct weston_fbdev_backend_config config = {{ 0, }}; | ||
116 | + struct weston_fbdev_backend_config config = { | ||
117 | + .base = {0}, | ||
118 | +#ifdef ENABLE_EGL | ||
119 | + .use_gl = 1, | ||
120 | + .use_g2d = 0, | ||
121 | +#else | ||
122 | + .use_gl = 0, | ||
123 | + .use_g2d = 1, | ||
124 | +#endif | ||
125 | + .clone_mode = 0, | ||
126 | + }; | ||
127 | struct weston_config_section *section; | ||
128 | char *s = NULL; | ||
129 | int ret = 0; | ||
diff --git a/recipes-graphics/wayland/weston/0012-MGS-1783-xwld-Add-clone-mode-support-for-multi-displ.patch b/recipes-graphics/wayland/weston/0012-MGS-1783-xwld-Add-clone-mode-support-for-multi-displ.patch index 10bae4d1..e504d677 100644 --- a/recipes-graphics/wayland/weston/0012-MGS-1783-xwld-Add-clone-mode-support-for-multi-displ.patch +++ b/recipes-graphics/wayland/weston/0012-MGS-1783-xwld-Add-clone-mode-support-for-multi-displ.patch | |||
@@ -19,10 +19,10 @@ Signed-off-by: Yong Gan <yong.gan@nxp.com> | |||
19 | src/g2d-renderer.h | 4 +- | 19 | src/g2d-renderer.h | 4 +- |
20 | 3 files changed, 167 insertions(+), 41 deletions(-) | 20 | 3 files changed, 167 insertions(+), 41 deletions(-) |
21 | 21 | ||
22 | Index: weston-1.11.0/src/compositor-fbdev.c | 22 | Index: weston-1.11.1/src/compositor-fbdev.c |
23 | =================================================================== | 23 | =================================================================== |
24 | --- weston-1.11.0.orig/src/compositor-fbdev.c 2016-10-06 13:17:41.738142236 -0500 | 24 | --- weston-1.11.1.orig/src/compositor-fbdev.c 2017-01-16 13:23:48.925264352 -0600 |
25 | +++ weston-1.11.0/src/compositor-fbdev.c 2016-10-06 13:28:22.000000000 -0500 | 25 | +++ weston-1.11.1/src/compositor-fbdev.c 2017-01-16 13:23:49.013264789 -0600 |
26 | @@ -61,6 +61,8 @@ | 26 | @@ -61,6 +61,8 @@ |
27 | struct udev_input input; | 27 | struct udev_input input; |
28 | int use_pixman; | 28 | int use_pixman; |
@@ -88,10 +88,10 @@ Index: weston-1.11.0/src/compositor-fbdev.c | |||
88 | #ifdef ENABLE_EGL | 88 | #ifdef ENABLE_EGL |
89 | gl_renderer = weston_load_module("gl-renderer.so", | 89 | gl_renderer = weston_load_module("gl-renderer.so", |
90 | "gl_renderer_interface"); | 90 | "gl_renderer_interface"); |
91 | Index: weston-1.11.0/src/g2d-renderer.c | 91 | Index: weston-1.11.1/src/g2d-renderer.c |
92 | =================================================================== | 92 | =================================================================== |
93 | --- weston-1.11.0.orig/src/g2d-renderer.c 2016-10-06 13:17:41.738142236 -0500 | 93 | --- weston-1.11.1.orig/src/g2d-renderer.c 2017-01-16 13:23:48.925264352 -0600 |
94 | +++ weston-1.11.0/src/g2d-renderer.c 2016-10-06 13:17:41.734142216 -0500 | 94 | +++ weston-1.11.1/src/g2d-renderer.c 2017-01-16 13:26:17.000000000 -0600 |
95 | @@ -37,15 +37,16 @@ | 95 | @@ -37,15 +37,16 @@ |
96 | #include <sys/ioctl.h> | 96 | #include <sys/ioctl.h> |
97 | #include <fcntl.h> | 97 | #include <fcntl.h> |
@@ -373,10 +373,10 @@ Index: weston-1.11.0/src/g2d-renderer.c | |||
373 | pixman_region32_init(&go->buffer_damage[i]); | 373 | pixman_region32_init(&go->buffer_damage[i]); |
374 | return 0; | 374 | return 0; |
375 | } | 375 | } |
376 | Index: weston-1.11.0/src/g2d-renderer.h | 376 | Index: weston-1.11.1/src/g2d-renderer.h |
377 | =================================================================== | 377 | =================================================================== |
378 | --- weston-1.11.0.orig/src/g2d-renderer.h 2016-10-06 13:17:41.738142236 -0500 | 378 | --- weston-1.11.1.orig/src/g2d-renderer.h 2017-01-16 13:23:48.757263519 -0600 |
379 | +++ weston-1.11.0/src/g2d-renderer.h 2016-10-06 13:17:41.734142216 -0500 | 379 | +++ weston-1.11.1/src/g2d-renderer.h 2017-01-16 13:26:17.000000000 -0600 |
380 | @@ -27,13 +27,11 @@ | 380 | @@ -27,13 +27,11 @@ |
381 | #define __g2d_renderer_h_ | 381 | #define __g2d_renderer_h_ |
382 | 382 | ||
@@ -392,29 +392,29 @@ Index: weston-1.11.0/src/g2d-renderer.h | |||
392 | struct g2d_renderer_interface { | 392 | struct g2d_renderer_interface { |
393 | 393 | ||
394 | int (*create)(struct weston_compositor *ec); | 394 | int (*create)(struct weston_compositor *ec); |
395 | Index: weston-1.11.0/src/main.c | 395 | Index: weston-1.11.1/src/main.c |
396 | =================================================================== | 396 | =================================================================== |
397 | --- weston-1.11.0.orig/src/main.c 2016-10-06 13:39:13.000000000 -0500 | 397 | --- weston-1.11.1.orig/src/main.c 2017-01-16 13:23:48.929264372 -0600 |
398 | +++ weston-1.11.0/src/main.c 2016-10-06 13:39:39.000000000 -0500 | 398 | +++ weston-1.11.1/src/main.c 2017-01-16 13:32:49.000000000 -0600 |
399 | @@ -287,11 +287,12 @@ | 399 | @@ -287,11 +287,12 @@ |
400 | " --device=DEVICE\tThe framebuffer device to use\n" | 400 | " --device=DEVICE\tThe framebuffer device to use\n" |
401 | #if defined ENABLE_EGL | 401 | #if defined ENABLE_EGL |
402 | " --no-use-gl\t\tDo not use the GL renderer\n" | 402 | " --use-gl=1\t\tUse the GL renderer (default is 1)\n" |
403 | - " --use-g2d\t\tUse the G2D renderer\n\n"); | 403 | - " --use-g2d=1\t\tUse the G2D renderer (default is 0)\n\n"); |
404 | + " --use-g2d\t\tUse the G2D renderer\n" | 404 | + " --use-g2d=1\t\tUse the G2D renderer (default is 0)\n" |
405 | #else | 405 | #else |
406 | " --use-gl\t\tUse the GL renderer\n" | 406 | " --use-gl=1\t\tUse the GL renderer (default is 0)\n" |
407 | - " --no-use-g2d\t\tDo not use the G2D renderer\n\n"); | 407 | - " --use-g2d=1\t\tUse the G2D renderer (default is 1)\n\n"); |
408 | + " --no-use-g2d\t\tDo not use the G2D renderer\n" | 408 | + " --use-g2d=1\t\tUse the G2D renderer (default is 1)\n" |
409 | #endif | 409 | #endif |
410 | + " --clone-mode\t\tClone display to multiple devices\n\n"); | 410 | + " --clone-mode\t\tClone display to multiple devices\n\n"); |
411 | #endif | 411 | #endif |
412 | 412 | ||
413 | #if defined(BUILD_HEADLESS_COMPOSITOR) | 413 | #if defined(BUILD_HEADLESS_COMPOSITOR) |
414 | @@ -888,6 +889,7 @@ | 414 | @@ -886,6 +887,7 @@ |
415 | { WESTON_OPTION_BOOLEAN, "use-gl", 0, &config.use_gl }, | 415 | { WESTON_OPTION_STRING, "device", 0, &config.device }, |
416 | { WESTON_OPTION_BOOLEAN, "no-use-g2d", 0, &no_use_g2d }, | 416 | { WESTON_OPTION_INTEGER, "use-gl", 0, &config.use_gl }, |
417 | #endif | 417 | { WESTON_OPTION_INTEGER, "use-g2d", 0, &config.use_g2d }, |
418 | + { WESTON_OPTION_BOOLEAN, "clone-mode", 0, &config.clone_mode }, | 418 | + { WESTON_OPTION_BOOLEAN, "clone-mode", 0, &config.clone_mode }, |
419 | }; | 419 | }; |
420 | 420 | ||