summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-16 18:22:59 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-22 15:06:11 +0800
commit61ec507539c38b4f471410c47cc293c2db108499 (patch)
tree8d683b94071baa81a89651615679df980042a1bb
parent481385cf3d0ff49ef162ad88a019bb9bf0066cad (diff)
downloadmeta-freescale-61ec507539c38b4f471410c47cc293c2db108499.tar.gz
u-boot: use TARGET_VENDOR to compose multilib sys
This aligns with the default setting in Poky. Signed-off-by: Ting Liu <ting.liu@freescale.com>
-rw-r--r--meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
index 43af42d7..b7806584 100644
--- a/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
+++ b/meta-fsl-ppc/recipes-bsp/u-boot/u-boot-qoriq_2014.07.bb
@@ -30,7 +30,7 @@ python () {
30 if "e5500-64b:" in arch or "e6500-64b:" in arch: 30 if "e5500-64b:" in arch or "e6500-64b:" in arch:
31 if not "lib32" in ml: 31 if not "lib32" in ml:
32 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 32 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
33 sys_multilib = 'powerpc-' + d.getVar('DISTRO') + 'mllib32-' + d.getVar('HOST_OS') 33 sys_multilib = 'powerpc' + d.getVar('TARGET_VENDOR') + 'mllib32-' + d.getVar('HOST_OS')
34 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') 34 d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc')
35 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib) 35 d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/' + sys_multilib)
36 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE")) 36 d.setVar('TOOLCHAIN_OPTIONS_append', '/../lib32-' + d.getVar("MACHINE"))