diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2018-01-30 17:09:51 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-02-06 09:58:34 -0200 |
commit | 67050918d2f44e2a6c03971663a03cec55131f1b (patch) | |
tree | 71456f4191bc60bf6e8f6839dd0edadd5b3521ec | |
parent | 689015e019b4c342bec019ed2b0da2ec5f63d5f2 (diff) | |
download | meta-freescale-67050918d2f44e2a6c03971663a03cec55131f1b.tar.gz |
rcw-bin: add recipes
*include the following changes:
bf3ae3c - armv8:LS1012A: Add support for LS1012A-2G5RDB board
e84010a - rcw: remove source files of SoCs
69104c3 - LS1012: Change header location in rcw for Secure Boot
43c79c9 - rcw: ls1088aqds: Add RCW PBL_QSPI_1600_700_2100_0x15_0x0d.bin
6719b04 - Ls1043a: add workaround for pcie errata A-009859
1a6236a - LS1012ARDB: Change rcw for secure boot
cdf4b72 - rcw: ls1088aqds: Add SCSI errata for detecttion of sata
16072f7 - armv8:LS1012A: RCW supporting 1GHz CPU frequency
90aef03 - LS1088ARDB:Reduce size in block copy command
53518dc - rcw: ls1088ardb: Add SCSI errata for detecttion of sata
0a869b3 - ls1021a: add workaround for pcie erratum A-007997 and A-007815
e7f18e5 - ls2088ardb: Add RCW for with platform frequency 700MHz
6f324fc - Use BSD license for both rcw and binary files
c69799f - Added copyright to byte_swap.tcl
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/rcw/rcw-bin_git.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw-bin_git.bb b/recipes-bsp/rcw/rcw-bin_git.bb new file mode 100644 index 00000000..bdb075f3 --- /dev/null +++ b/recipes-bsp/rcw/rcw-bin_git.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "Reset Configuration Word" | ||
2 | DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" | ||
3 | LICENSE = "NXP-Binary-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=ba5ff3a3faf52a38970d0a536ef42df5" | ||
5 | |||
6 | inherit deploy siteinfo | ||
7 | |||
8 | SRC_URI = "git://github.com/qoriq-open-source/rcw-bin.git;nobranch=1" | ||
9 | SRCREV = "bf3ae3cb15829876007c553509501cdaa16745e7" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}" | ||
14 | |||
15 | do_install () { | ||
16 | install -d ${D}/boot/rcw | ||
17 | cp -rf ${S}/${M}* ${D}/boot/rcw/ | ||
18 | chown -R root:root ${D} | ||
19 | } | ||
20 | |||
21 | do_deploy () { | ||
22 | install -d ${DEPLOYDIR}/rcw | ||
23 | cp -rf ${S}/${M}* ${DEPLOYDIR}/rcw/ | ||
24 | } | ||
25 | addtask deploy before do_build after do_install | ||
26 | |||
27 | PACKAGES += "${PN}-image" | ||
28 | FILES_${PN}-image += "/boot" | ||
29 | |||
30 | COMPATIBLE_MACHINE = "(qoriq)" | ||
31 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
32 | COMPATIBLE_MACHINE = "(ls1012a|ls2088a|ls1088a)" | ||