diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-05 17:20:29 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-05 17:20:29 -0300 |
commit | 6fdd26a72b923044351674f4172c85f160c6f301 (patch) | |
tree | 6108bbca6bcdc0b97282df87157afbdcad68f77d | |
parent | 68942ef68aef1ca59f70a4392f839e8c99b0cc02 (diff) | |
download | meta-freescale-6fdd26a72b923044351674f4172c85f160c6f301.tar.gz |
imx-test: Rework DEPENDS and VPU support
All variants depends on `virtual/kernel`, `imx-lib` and `alsa-lib`, so
this can be added by default.
The VPU support has been moved to a `PACKAGECONFIG` so it adds the
respective `make` parameter, and dependency, depending on the
`MACHINEOVERRIDES` value.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 21 |
1 files changed, 6 insertions, 15 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 6e6971e5..0932d410 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -8,16 +8,7 @@ SECTION = "base" | |||
8 | LICENSE = "GPLv2" | 8 | LICENSE = "GPLv2" |
9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
10 | 10 | ||
11 | DEPENDS_mx6q = "virtual/kernel imx-lib" | 11 | DEPENDS = "virtual/kernel imx-lib alsa-lib" |
12 | DEPENDS_mx6dl = "virtual/kernel imx-lib" | ||
13 | DEPENDS_mx6sl = "virtual/kernel imx-lib" | ||
14 | DEPENDS_mx6sll = "virtual/kernel imx-lib" | ||
15 | DEPENDS_mx6sx = "virtual/kernel imx-lib" | ||
16 | DEPENDS_mx6ul = "virtual/kernel imx-lib" | ||
17 | DEPENDS_mx7d = "virtual/kernel imx-lib" | ||
18 | DEPENDS_mx7ulp = "virtual/kernel imx-lib" | ||
19 | DEPENDS_append_imxvpu = " virtual/imxvpu" | ||
20 | DEPENDS_append = " alsa-lib" | ||
21 | 12 | ||
22 | PE = "1" | 13 | PE = "1" |
23 | PV = "7.0+${SRCPV}" | 14 | PV = "7.0+${SRCPV}" |
@@ -46,14 +37,14 @@ PLATFORM_mx6ul = "IMX6UL" | |||
46 | PLATFORM_mx7d = "IMX7D" | 37 | PLATFORM_mx7d = "IMX7D" |
47 | PLATFORM_mx7ulp = "IMX7D" | 38 | PLATFORM_mx7ulp = "IMX7D" |
48 | 39 | ||
49 | PARALLEL_MAKE="-j 1" | 40 | PARALLEL_MAKE = "-j 1" |
41 | EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" | ||
50 | 42 | ||
51 | IMX_HAS_VPU = "false" | 43 | PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" |
52 | IMX_HAS_VPU_imxvpu = "true" | 44 | PACKAGECONFIG_append_imxvpu = " vpu" |
53 | EXTRA_OEMAKE += "HAS_VPU=${IMX_HAS_VPU}" | ||
54 | 45 | ||
55 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" | ||
56 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | 46 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" |
47 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" | ||
57 | 48 | ||
58 | do_compile() { | 49 | do_compile() { |
59 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 50 | CFLAGS="${TOOLCHAIN_OPTIONS}" |