diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-07-16 00:35:42 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-22 11:34:12 -0300 |
commit | 79ba856434b0e2d28352afe7828fd00faa91f71a (patch) | |
tree | c98447aa541594b25e56a3f636d1c269963a0ae6 | |
parent | 530582874ef69e75b638a73de6adc0a6961ea731 (diff) | |
download | meta-freescale-79ba856434b0e2d28352afe7828fd00faa91f71a.tar.gz |
u-boot-qoriq: upgrade to 2016.01 plus fsl patches
The main features are:
* Upgrade to 2016.01
* On ARM platforms, the U-Boot image includes the device tree
* Non-secure and Secure Boot (ESBC)
* Primary Protected Application (PPA) firmware integration [LS1043A]
* Clock, CPLD, DUART, DDR3, DDR4, DSPI, eSDHC, GIC-400, GIC-500, I2C, OCRAM, PCIe, USB 2 & 3, SATA, UART
* Networking support using eTSEC, FMAN Independent Mode or DPAA2 networking
* DCU, eMMC 4.5, I2C3, LPUART, QSPI [LS1021A]
* eLBC and IFC access to NOR and NAND flash
* Boot from NOR, NAND flash, eSPI, SDHC
* Boot from SRIO [B4860, P5020, P4080]
* Voltage ID (board specific)
* CodeWarrior debug patch for U-Boot
Detailed commit log can be found at:
http://git.freescale.com/git/cgit.cgi/ppc/sdk/u-boot.git/log/?h=sdk-v2.0.x
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch | 39 | ||||
-rw-r--r-- | recipes-bsp/u-boot/files/gcc5.patch | 91 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch (renamed from recipes-bsp/u-boot/files/fix-build-error-under-gcc6.patch) | 0 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb) | 6 |
4 files changed, 2 insertions, 134 deletions
diff --git a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch b/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch deleted file mode 100644 index cfe1c07a..00000000 --- a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | From 4d4fcfc41288134b48b72ac69702f68741d7631f Mon Sep 17 00:00:00 2001 | ||
4 | From: Ting Liu <ting.liu@freescale.com> | ||
5 | Date: Tue, 28 Jul 2015 16:29:26 +0800 | ||
6 | Subject: [PATCH] add -fgnu89-inline option for gcc5 | ||
7 | |||
8 | Fix the below build issues: | ||
9 | CC drivers/crypto/fsl/sec.o | ||
10 | LD arch/powerpc/cpu/mpc8xxx/built-in.o | ||
11 | arch/powerpc/cpu/mpc8xxx/fdt.o: In function `ld_le16': | ||
12 | ../arch/powerpc/include/asm/byteorder.h:12: multiple definition of `ld_le16' | ||
13 | |||
14 | The problem is the change of the default C standard from gnu89 to gnu11 | ||
15 | which changes the semantics of 'inline'. The issue is described in the | ||
16 | Porting guide at https://gcc.gnu.org/gcc-5/porting_to.html. Adding the | ||
17 | '-fgnu89-inline' option fixes the issue. | ||
18 | |||
19 | Signed-off-by: Ting Liu <ting.liu@freescale.com> | ||
20 | --- | ||
21 | Makefile | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/Makefile b/Makefile | ||
25 | index 9995e00..00497cc 100644 | ||
26 | --- a/Makefile | ||
27 | +++ b/Makefile | ||
28 | @@ -349,7 +349,7 @@ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \ | ||
29 | |||
30 | KBUILD_CPPFLAGS := -D__KERNEL__ -D__UBOOT__ | ||
31 | |||
32 | -KBUILD_CFLAGS := -Wall -Wstrict-prototypes \ | ||
33 | +KBUILD_CFLAGS := -fgnu89-inline -Wall -Wstrict-prototypes \ | ||
34 | -Wno-format-security \ | ||
35 | -fno-builtin -ffreestanding | ||
36 | KBUILD_AFLAGS := -D__ASSEMBLY__ | ||
37 | -- | ||
38 | 1.9.2 | ||
39 | |||
diff --git a/recipes-bsp/u-boot/files/gcc5.patch b/recipes-bsp/u-boot/files/gcc5.patch deleted file mode 100644 index 12db94ca..00000000 --- a/recipes-bsp/u-boot/files/gcc5.patch +++ /dev/null | |||
@@ -1,91 +0,0 @@ | |||
1 | Upstream-Status: Backport | ||
2 | |||
3 | From 478b02f1a7043b673565075ea5016376f3293b23 Mon Sep 17 00:00:00 2001 | ||
4 | From: Hans de Goede <hdegoede@redhat.com> | ||
5 | Date: Sat, 7 Feb 2015 22:52:40 +0100 | ||
6 | Subject: [PATCH] Add linux/compiler-gcc5.h to fix builds with gcc5 | ||
7 | |||
8 | Add linux/compiler-gcc5/h from the kernel sources at: | ||
9 | |||
10 | commit 5631b8fba640a4ab2f8a954f63a603fa34eda96b | ||
11 | Author: Steven Noonan <steven@uplinklabs.net> | ||
12 | Date: Sat Oct 25 15:09:42 2014 -0700 | ||
13 | |||
14 | compiler/gcc4+: Remove inaccurate comment about 'asm goto' miscompiles | ||
15 | |||
16 | Signed-off-by: Hans de Goede <hdegoede@redhat.com> | ||
17 | --- | ||
18 | include/linux/compiler-gcc5.h | 65 +++++++++++++++++++++++++++++++++++++++++ | ||
19 | 1 file changed, 65 insertions(+) | ||
20 | create mode 100644 include/linux/compiler-gcc5.h | ||
21 | |||
22 | Index: git/include/linux/compiler-gcc5.h | ||
23 | =================================================================== | ||
24 | --- /dev/null | ||
25 | +++ git/include/linux/compiler-gcc5.h | ||
26 | @@ -0,0 +1,65 @@ | ||
27 | +#ifndef __LINUX_COMPILER_H | ||
28 | +#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead." | ||
29 | +#endif | ||
30 | + | ||
31 | +#define __used __attribute__((__used__)) | ||
32 | +#define __must_check __attribute__((warn_unused_result)) | ||
33 | +#define __compiler_offsetof(a, b) __builtin_offsetof(a, b) | ||
34 | + | ||
35 | +/* Mark functions as cold. gcc will assume any path leading to a call | ||
36 | + to them will be unlikely. This means a lot of manual unlikely()s | ||
37 | + are unnecessary now for any paths leading to the usual suspects | ||
38 | + like BUG(), printk(), panic() etc. [but let's keep them for now for | ||
39 | + older compilers] | ||
40 | + | ||
41 | + Early snapshots of gcc 4.3 don't support this and we can't detect this | ||
42 | + in the preprocessor, but we can live with this because they're unreleased. | ||
43 | + Maketime probing would be overkill here. | ||
44 | + | ||
45 | + gcc also has a __attribute__((__hot__)) to move hot functions into | ||
46 | + a special section, but I don't see any sense in this right now in | ||
47 | + the kernel context */ | ||
48 | +#define __cold __attribute__((__cold__)) | ||
49 | + | ||
50 | +#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__) | ||
51 | + | ||
52 | +#ifndef __CHECKER__ | ||
53 | +# define __compiletime_warning(message) __attribute__((warning(message))) | ||
54 | +# define __compiletime_error(message) __attribute__((error(message))) | ||
55 | +#endif /* __CHECKER__ */ | ||
56 | + | ||
57 | +/* | ||
58 | + * Mark a position in code as unreachable. This can be used to | ||
59 | + * suppress control flow warnings after asm blocks that transfer | ||
60 | + * control elsewhere. | ||
61 | + * | ||
62 | + * Early snapshots of gcc 4.5 don't support this and we can't detect | ||
63 | + * this in the preprocessor, but we can live with this because they're | ||
64 | + * unreleased. Really, we need to have autoconf for the kernel. | ||
65 | + */ | ||
66 | +#define unreachable() __builtin_unreachable() | ||
67 | + | ||
68 | +/* Mark a function definition as prohibited from being cloned. */ | ||
69 | +#define __noclone __attribute__((__noclone__)) | ||
70 | + | ||
71 | +/* | ||
72 | + * Tell the optimizer that something else uses this function or variable. | ||
73 | + */ | ||
74 | +#define __visible __attribute__((externally_visible)) | ||
75 | + | ||
76 | +/* | ||
77 | + * GCC 'asm goto' miscompiles certain code sequences: | ||
78 | + * | ||
79 | + * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670 | ||
80 | + * | ||
81 | + * Work it around via a compiler barrier quirk suggested by Jakub Jelinek. | ||
82 | + * | ||
83 | + * (asm goto is automatically volatile - the naming reflects this.) | ||
84 | + */ | ||
85 | +#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0) | ||
86 | + | ||
87 | +#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP | ||
88 | +#define __HAVE_BUILTIN_BSWAP32__ | ||
89 | +#define __HAVE_BUILTIN_BSWAP64__ | ||
90 | +#define __HAVE_BUILTIN_BSWAP16__ | ||
91 | +#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */ | ||
diff --git a/recipes-bsp/u-boot/files/fix-build-error-under-gcc6.patch b/recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch index 839cd7df..839cd7df 100644 --- a/recipes-bsp/u-boot/files/fix-build-error-under-gcc6.patch +++ b/recipes-bsp/u-boot/u-boot-qoriq/fix-build-error-under-gcc6.patch | |||
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb index 8b20b5ad..601edbd3 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb | |||
@@ -22,13 +22,11 @@ DEPENDS_append_qoriq-ppc = " boot-format-native" | |||
22 | 22 | ||
23 | inherit deploy | 23 | inherit deploy |
24 | 24 | ||
25 | SRCBRANCH = "sdk-v1.9.x" | 25 | SRCBRANCH = "sdk-v2.0.x" |
26 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \ | 26 | SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \ |
27 | file://gcc5.patch \ | ||
28 | file://add-fgnu89-inline-option-for-gcc5.patch \ | ||
29 | file://fix-build-error-under-gcc6.patch \ | 27 | file://fix-build-error-under-gcc6.patch \ |
30 | " | 28 | " |
31 | SRCREV = "eb3d4fc5759729d7af71ac31ebf6a7e8d0e79da3" | 29 | SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e" |
32 | 30 | ||
33 | python () { | 31 | python () { |
34 | if d.getVar("TCMODE", True) == "external-fsl": | 32 | if d.getVar("TCMODE", True) == "external-fsl": |