diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-10-18 13:06:24 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-18 11:42:30 -0200 |
commit | 8e0fadef91bfc9e7528da6424b1701079c0e9f33 (patch) | |
tree | 626cbacac6269c34a424048150e8eb7acb3a6a3e | |
parent | 79db6f98e92d3f37b42b0f2a3863594afea01d94 (diff) | |
download | meta-freescale-8e0fadef91bfc9e7528da6424b1701079c0e9f33.tar.gz |
ppa :update recipes
*update to 92b208b
This includes the following changes:
92b208b - Added usb and mmc as wakeup src for LS1088 system suspend; Fixed stack alignment issue.
999e6be - Correcting stack reference issue in LS1088 _soc_sys_entr_pwrdn().
4d43c10 - Adding cpu_suspend.system support to LS1088.
8a2e7ee - Disambiguating uart driver from ddr driver and from dbg builds.
d455113 - Fixing offset into bootcore data area.
87b117e - Moving Chassis defs out of soc.h and into lsch3/lsch2.h.
93f17b3 - Releasing cores from reset that are marked "to be disabled".
2872682 - Fixing ordering problem in makefile.inc which caused builds using earlier than GCC 6.2 to fail.
f52a4a9 - Adding separate folders for each driver; Adding rdb board for LA17xx.
b003ea1 - Adding initial ppa for soc LA17xx.
ce7f372 - Changing secondary core release method to reduce risk of race condition between ppa and bootrom.
78b8281 - Fixing psci data area initialization.
bed0d04 - Eliminating race condition between psci and bootrom on core release.
89ddb56 - Cleanup of prefetch disable function.
8781337 - Fix for QPPA-23: overwriting saved link register in _soc_init_start when bootcore used to initialize ocram.
4ee3738 - Adding header file left out of last commit.
cc33e5e - Adding smc function prefetch disable.
2de51a3 - Changing psci call to _soc_core_rls_wait into a call to _soc_core_release.
12be3c6 - Updating text in license file.
76a61f5 - Added release note deprecating build methods using "make".
*fix the below error:
|Makefile:58: ../armv8/gic.mk: No such file or directory
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/ppa/ppa/0001-fix-path-error.patch | 79 | ||||
-rw-r--r-- | recipes-bsp/ppa/ppa_git.bb | 6 |
2 files changed, 83 insertions, 2 deletions
diff --git a/recipes-bsp/ppa/ppa/0001-fix-path-error.patch b/recipes-bsp/ppa/ppa/0001-fix-path-error.patch new file mode 100644 index 00000000..891a6e75 --- /dev/null +++ b/recipes-bsp/ppa/ppa/0001-fix-path-error.patch | |||
@@ -0,0 +1,79 @@ | |||
1 | From aa3b419876af9c2a9265fba7c7264130e1bc4926 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Wed, 27 Sep 2017 10:45:04 +0800 | ||
4 | Subject: [PATCH] fix path error | ||
5 | |||
6 | fix the below error: | ||
7 | |Makefile:58: ../armv8/gic.mk: No such file or directory | ||
8 | |||
9 | Upstream-Status: Submitted | ||
10 | |||
11 | Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> | ||
12 | --- | ||
13 | ppa/soc-ls1046/Makefile | 4 ++-- | ||
14 | ppa/soc-ls1088/Makefile | 4 ++-- | ||
15 | ppa/soc-ls2088/Makefile | 5 +++-- | ||
16 | 3 files changed, 7 insertions(+), 6 deletions(-) | ||
17 | |||
18 | diff --git a/ppa/soc-ls1046/Makefile b/ppa/soc-ls1046/Makefile | ||
19 | index 34ffe2d..6a06514 100644 | ||
20 | --- a/ppa/soc-ls1046/Makefile | ||
21 | +++ b/ppa/soc-ls1046/Makefile | ||
22 | @@ -55,12 +55,12 @@ include $(PRE_PATH)soc.def | ||
23 | # ----------------------------------------------------------------------------- | ||
24 | |||
25 | # include the gic architecture file | ||
26 | -include ../armv8/gic.mk | ||
27 | +include $(PRE_PATH)../armv8/gic.mk | ||
28 | |||
29 | # ----------------------------------------------------------------------------- | ||
30 | |||
31 | # include the interconnect architecture file | ||
32 | -include ../armv8/inter.mk | ||
33 | +include $(PRE_PATH)../armv8/inter.mk | ||
34 | |||
35 | # ----------------------------------------------------------------------------- | ||
36 | |||
37 | diff --git a/ppa/soc-ls1088/Makefile b/ppa/soc-ls1088/Makefile | ||
38 | index 7fc5db9..6472408 100644 | ||
39 | --- a/ppa/soc-ls1088/Makefile | ||
40 | +++ b/ppa/soc-ls1088/Makefile | ||
41 | @@ -55,12 +55,12 @@ include $(PRE_PATH)soc.def | ||
42 | # ----------------------------------------------------------------------------- | ||
43 | |||
44 | # include the gic architecture file | ||
45 | -include ../armv8/gic.mk | ||
46 | +include $(PRE_PATH)../armv8/gic.mk | ||
47 | |||
48 | # ----------------------------------------------------------------------------- | ||
49 | |||
50 | # include the interconnect architecture file | ||
51 | -include ../armv8/inter.mk | ||
52 | +include $(PRE_PATH)../armv8/inter.mk | ||
53 | |||
54 | # ----------------------------------------------------------------------------- | ||
55 | |||
56 | diff --git a/ppa/soc-ls2088/Makefile b/ppa/soc-ls2088/Makefile | ||
57 | index de3a06c..2fe23e2 100644 | ||
58 | --- a/ppa/soc-ls2088/Makefile | ||
59 | +++ b/ppa/soc-ls2088/Makefile | ||
60 | @@ -54,13 +54,14 @@ include $(PRE_PATH)soc.def | ||
61 | |||
62 | # ----------------------------------------------------------------------------- | ||
63 | |||
64 | +include $(PRE_PATH)../armv8/gic.mk | ||
65 | # include the gic architecture file | ||
66 | -include ../armv8/gic.mk | ||
67 | +include $(PRE_PATH)../armv8/gic.mk | ||
68 | |||
69 | # ----------------------------------------------------------------------------- | ||
70 | |||
71 | # include the interconnect architecture file | ||
72 | -include ../armv8/inter.mk | ||
73 | +include $(PRE_PATH)../armv8/inter.mk | ||
74 | |||
75 | # ----------------------------------------------------------------------------- | ||
76 | |||
77 | -- | ||
78 | 2.7.4 | ||
79 | |||
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb index ede3b643..c4f81bc5 100644 --- a/recipes-bsp/ppa/ppa_git.bb +++ b/recipes-bsp/ppa/ppa_git.bb | |||
@@ -6,8 +6,10 @@ DEPENDS += "u-boot-mkimage-native dtc-native" | |||
6 | 6 | ||
7 | inherit deploy | 7 | inherit deploy |
8 | 8 | ||
9 | SRC_URI = "git://github.com/qoriq-open-source/ppa-generic.git;nobranch=1" | 9 | SRC_URI = "git://github.com/qoriq-open-source/ppa-generic.git;nobranch=1 \ |
10 | SRCREV = "265d766de8c7f3161f2580af18558af35e114845" | 10 | file://0001-fix-path-error.patch \ |
11 | " | ||
12 | SRCREV = "92b208b0dbb5a47b06627ec62824cb5790b3f482" | ||
11 | 13 | ||
12 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
13 | 15 | ||