diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-01-13 17:22:54 +0800 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2015-01-13 17:44:54 +0800 |
commit | 95a9bd749b4159e1e52a832e588253e66f96725f (patch) | |
tree | a3ddfc3ef943f070d8657b358fac94a38f676b03 | |
parent | dc2e2ff97a6f8a83ac922c395f70d21eecc60fce (diff) | |
download | meta-freescale-95a9bd749b4159e1e52a832e588253e66f96725f.tar.gz |
qe-ucode: install if QE_UCODE defined
* QE_UCODE definition is moved to <machine>.conf
* add check if QE_UCODE defined in anonymous python function
* install the binary into /boot
Signed-off-by: Ting Liu <ting.liu@freescale.com>
-rw-r--r-- | meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb | 29 |
1 files changed, 13 insertions, 16 deletions
diff --git a/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb b/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb index 06a7298c..028d9bcd 100644 --- a/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb +++ b/meta-fsl-ppc/recipes-bsp/qe-ucode/qe-ucode_git.bb | |||
@@ -3,6 +3,13 @@ SECTION = "qe-ucode" | |||
3 | LICENSE = "Freescale-EULA" | 3 | LICENSE = "Freescale-EULA" |
4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" | 4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" |
5 | 5 | ||
6 | python () { | ||
7 | if not d.getVar("QE_UCODE", True): | ||
8 | machine = d.getVar("MACHINE", True) | ||
9 | raise bb.parse.SkipPackage("QE_UCODE not set in \ | ||
10 | meta-fsl-ppc/conf/machine/%s.conf" % machine) | ||
11 | } | ||
12 | |||
6 | inherit deploy | 13 | inherit deploy |
7 | 14 | ||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1" | 15 | SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1" |
@@ -11,28 +18,18 @@ SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c" | |||
11 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
12 | 19 | ||
13 | do_install () { | 20 | do_install () { |
14 | case ${MACHINE} in | 21 | install -d ${D}/boot |
15 | p1025rdb|p1021rdb|p1025twr) QE_UCODE="fsl_qe_ucode_1021_10_A.bin";; | 22 | install -m 644 ${QE_UCODE} ${D}/boot/ |
16 | t1040rdb|t1040rdb-64b) QE_UCODE="iram_Type_A_T1040_r1.0.bin";; | ||
17 | *) QE_UCODE="";; | ||
18 | esac | ||
19 | install -d ${D}/ | ||
20 | install -m 644 ${QE_UCODE} ${D}/ | ||
21 | } | 23 | } |
22 | 24 | ||
23 | do_deploy () { | 25 | do_deploy () { |
24 | case ${MACHINE} in | 26 | install -d ${DEPLOYDIR}/boot |
25 | p1025rdb|p1021rdb|p1025twr) QE_UCODE="fsl_qe_ucode_1021_10_A.bin";; | 27 | install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot/ |
26 | t1040rdb|t1040rdb-64b) QE_UCODE="iram_Type_A_T1040_r1.0.bin";; | ||
27 | *) QE_UCODE="";; | ||
28 | esac | ||
29 | install -d ${DEPLOYDIR}/ | ||
30 | install -m 644 ${QE_UCODE} ${DEPLOYDIR}/ | ||
31 | } | 28 | } |
32 | addtask deploy before do_build after do_install | 29 | addtask deploy before do_build after do_install |
33 | 30 | ||
34 | PACKAGES += "${PN}-image" | 31 | PACKAGES += "${PN}-image" |
35 | FILES_${PN}-image += "/*" | 32 | FILES_${PN}-image += "/boot/*" |
36 | ALLOW_EMPTY_${PN} = "1" | 33 | ALLOW_EMPTY_${PN} = "1" |
37 | COMPATIBLE_MACHINE = "(p1025rdb|p1021rdb|p1025twr|t1040rdb|t1040rdb-64b)" | 34 | COMPATIBLE_MACHINE = "(p1021rdb|p1025twr|t1)" |
38 | 35 | ||