diff options
author | Sona Sarmadi <sona.sarmadi@enea.com> | 2015-03-02 11:44:00 +0100 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2015-03-06 16:28:59 +0800 |
commit | 95b506386d128a715c389cf2aa67b3468a1cf2cc (patch) | |
tree | abe376861cd06ded587ad4de1fbe9cd19bbe96b2 | |
parent | d8309b272f69eae18c73c1eab3b96e094826b58b (diff) | |
download | meta-freescale-95b506386d128a715c389cf2aa67b3468a1cf2cc.tar.gz |
security-keys: CVE-2014-9529
Fixes memory corruption or panic during key garbage collection
Reference:
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9529
Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch | 53 | ||||
-rw-r--r-- | meta-fsl-ppc/recipes-kernel/linux/linux-qoriq_3.12.bb | 1 |
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch b/meta-fsl-ppc/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch new file mode 100644 index 00000000..573b5300 --- /dev/null +++ b/meta-fsl-ppc/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch | |||
@@ -0,0 +1,53 @@ | |||
1 | From a7033e302dcd38bb4333f46b3fdcd930955e402d Mon Sep 17 00:00:00 2001 | ||
2 | From: Sasha Levin <sasha.levin@oracle.com> | ||
3 | Date: Mon, 29 Dec 2014 09:39:01 -0500 | ||
4 | Subject: [PATCH] KEYS: close race between key lookup and freeing | ||
5 | |||
6 | commit a3a8784454692dd72e5d5d34dcdab17b4420e74c upstream. | ||
7 | |||
8 | When a key is being garbage collected, it's key->user would get put before | ||
9 | the ->destroy() callback is called, where the key is removed from it's | ||
10 | respective tracking structures. | ||
11 | |||
12 | This leaves a key hanging in a semi-invalid state which leaves a window open | ||
13 | for a different task to try an access key->user. An example is | ||
14 | find_keyring_by_name() which would dereference key->user for a key that is | ||
15 | in the process of being garbage collected (where key->user was freed but | ||
16 | ->destroy() wasn't called yet - so it's still present in the linked list). | ||
17 | |||
18 | This would cause either a panic, or corrupt memory. | ||
19 | |||
20 | Fixes CVE-2014-9529. | ||
21 | |||
22 | Upstream-Status: Backport | ||
23 | |||
24 | Signed-off-by: Sasha Levin <sasha.levin@oracle.com> | ||
25 | Signed-off-by: David Howells <dhowells@redhat.com> | ||
26 | Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org> | ||
27 | Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> | ||
28 | --- | ||
29 | security/keys/gc.c | 4 ++-- | ||
30 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
31 | |||
32 | diff --git a/security/keys/gc.c b/security/keys/gc.c | ||
33 | index d67c97b..7978186 100644 | ||
34 | --- a/security/keys/gc.c | ||
35 | +++ b/security/keys/gc.c | ||
36 | @@ -201,12 +201,12 @@ static noinline void key_gc_unused_keys(struct list_head *keys) | ||
37 | if (test_bit(KEY_FLAG_INSTANTIATED, &key->flags)) | ||
38 | atomic_dec(&key->user->nikeys); | ||
39 | |||
40 | - key_user_put(key->user); | ||
41 | - | ||
42 | /* now throw away the key memory */ | ||
43 | if (key->type->destroy) | ||
44 | key->type->destroy(key); | ||
45 | |||
46 | + key_user_put(key->user); | ||
47 | + | ||
48 | kfree(key->description); | ||
49 | |||
50 | #ifdef KEY_DEBUGGING | ||
51 | -- | ||
52 | 1.9.1 | ||
53 | |||
diff --git a/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq_3.12.bb b/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq_3.12.bb index e7af6274..f082b046 100644 --- a/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq_3.12.bb +++ b/meta-fsl-ppc/recipes-kernel/linux/linux-qoriq_3.12.bb | |||
@@ -36,6 +36,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \ | |||
36 | file://0003-shmem-CVE-2014-4171.patch \ | 36 | file://0003-shmem-CVE-2014-4171.patch \ |
37 | file://fs-CVE-2014-4014.patch \ | 37 | file://fs-CVE-2014-4014.patch \ |
38 | file://tracing-CVE-2014-7825_CVE-2014-7826.patch \ | 38 | file://tracing-CVE-2014-7825_CVE-2014-7826.patch \ |
39 | file://security-keys-CVE-2014-9529.patch \ | ||
39 | " | 40 | " |
40 | SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229" | 41 | SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229" |
41 | 42 | ||