diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-09-09 13:31:28 -0700 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-09-21 20:55:30 -0300 |
commit | b61675eccc5ac3cf73f9e24bc651a08ab37110de (patch) | |
tree | f2562743f3bf7cd49c5e7e2295ce40b3db8b51bf | |
parent | bacf6dd96784a814b6a0ec48d7de1f783ffaae52 (diff) | |
download | meta-freescale-b61675eccc5ac3cf73f9e24bc651a08ab37110de.tar.gz |
weston-init: Adjust to match recent oe-core changes
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 5 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init/weston.service | 38 |
2 files changed, 0 insertions, 43 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index 76aadf94..13818bc3 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -13,11 +13,6 @@ HAS_XWAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', 'true', ' | |||
13 | 13 | ||
14 | do_install_append() { | 14 | do_install_append() { |
15 | if ${HAS_SYSTEMD}; then | 15 | if ${HAS_SYSTEMD}; then |
16 | sed -i \ | ||
17 | -e 's,/usr/bin,${bindir},g' \ | ||
18 | -e 's,/etc,${sysconfdir},g' \ | ||
19 | -e 's,/var,${localstatedir},g' \ | ||
20 | ${D}${systemd_system_unitdir}/weston.service | ||
21 | if ${HAS_XWAYLAND}; then | 16 | if ${HAS_XWAYLAND}; then |
22 | install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston | 17 | install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston |
23 | fi | 18 | fi |
diff --git a/recipes-graphics/wayland/weston-init/weston.service b/recipes-graphics/wayland/weston-init/weston.service deleted file mode 100644 index 44c5a82f..00000000 --- a/recipes-graphics/wayland/weston-init/weston.service +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Weston Wayland Compositor (on tty7) | ||
3 | RequiresMountsFor=/run | ||
4 | Conflicts=getty@tty7.service plymouth-quit.service | ||
5 | After=systemd-user-sessions.service getty@tty7.service plymouth-quit-wait.service | ||
6 | |||
7 | [Service] | ||
8 | User=root | ||
9 | PermissionsStartOnly=true | ||
10 | |||
11 | # Log us in via PAM so we get our XDG & co. environment and | ||
12 | # are treated as logged in so we can use the tty: | ||
13 | PAMName=login | ||
14 | |||
15 | # Grab tty7 | ||
16 | UtmpIdentifier=tty7 | ||
17 | TTYPath=/dev/tty7 | ||
18 | TTYReset=yes | ||
19 | TTYVHangup=yes | ||
20 | TTYVTDisallocate=yes | ||
21 | |||
22 | # stderr to journal so our logging doesn't get thrown into /dev/null | ||
23 | StandardOutput=tty | ||
24 | StandardInput=tty | ||
25 | StandardError=journal | ||
26 | |||
27 | EnvironmentFile=-/etc/default/weston | ||
28 | |||
29 | # Weston does not successfully change VT, nor does systemd place us on | ||
30 | # the VT it just activated for us. Switch manually: | ||
31 | ExecStartPre=/usr/bin/chvt 7 | ||
32 | ExecStart=/usr/bin/weston-launch -- --log=/var/log/weston.log $OPTARGS | ||
33 | |||
34 | IgnoreSIGPIPE=no | ||
35 | |||
36 | [Install] | ||
37 | WantedBy=multi-user.target | ||
38 | |||