diff options
author | Lauren Post <lauren.post@freescale.com> | 2015-09-17 14:27:38 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:19 -0300 |
commit | beed2eb2475971b94ffa583c0b57a0222869be03 (patch) | |
tree | 35df2f747c613e89c4c5a2a20e93c38aff779aa4 | |
parent | a8e6b271b22e9f20539117090eebbc1bd4ab2302 (diff) | |
download | meta-freescale-beed2eb2475971b94ffa583c0b57a0222869be03.tar.gz |
firmware-imx: Update to 5.2 version
The package adds the EPDC waveforms and the needed changes to properly
install those were done in the firmware-imx.inc file.
Another change was to include the i.MX 7 in the COMPATIBLE_MACHINE
list.
Signed-off-by: Lauren Post <lauren.post@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx.inc | 13 | ||||
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx_5.0.bb | 8 | ||||
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx_5.2.bb | 8 |
3 files changed, 19 insertions, 10 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx.inc b/recipes-bsp/firmware-imx/firmware-imx.inc index 558c6246..fc49669d 100644 --- a/recipes-bsp/firmware-imx/firmware-imx.inc +++ b/recipes-bsp/firmware-imx/firmware-imx.inc | |||
@@ -11,12 +11,17 @@ SRC_URI = "${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true" | |||
11 | inherit fsl-eula-unpack | 11 | inherit fsl-eula-unpack |
12 | 12 | ||
13 | do_install() { | 13 | do_install() { |
14 | install -d ${D}/lib/firmware | 14 | install -d ${D}/lib/firmware/imx |
15 | cp -rfv firmware/* ${D}/lib/firmware/ | 15 | cp -rfv firmware/* ${D}/lib/firmware/ |
16 | |||
17 | mv ${D}/lib/firmware/epdc/ ${D}/lib/firmware/imx/epdc/ | ||
18 | mv ${D}/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw.nonrestricted ${D}/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw | ||
19 | |||
16 | find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';' | 20 | find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';' |
21 | find ${D}/lib/firmware -type f -exec chown root:root '{}' ';' | ||
17 | 22 | ||
18 | # Remove files not going to be installed | 23 | # Remove files not going to be installed |
19 | find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';' | 24 | find ${D}/lib/firmware/ -name '*.mk' -exec rm '{}' ';' |
20 | } | 25 | } |
21 | 26 | ||
22 | python populate_packages_prepend() { | 27 | python populate_packages_prepend() { |
@@ -39,4 +44,8 @@ ALLOW_EMPTY_${PN} = "1" | |||
39 | 44 | ||
40 | PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*" | 45 | PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*" |
41 | 46 | ||
47 | PACKAGES =+ "${PN}-epdc" | ||
48 | |||
49 | FILES_${PN}-epdc = "/lib/firmware/imx/epdc/" | ||
50 | |||
42 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 51 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
diff --git a/recipes-bsp/firmware-imx/firmware-imx_5.0.bb b/recipes-bsp/firmware-imx/firmware-imx_5.0.bb deleted file mode 100644 index cb131101..00000000 --- a/recipes-bsp/firmware-imx/firmware-imx_5.0.bb +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | # Copyright (C) 2012-2015 Freescale Semiconductor | ||
2 | |||
3 | require firmware-imx.inc | ||
4 | |||
5 | SRC_URI[md5sum] = "543210d17971f61c7c1829d2c160dc4e" | ||
6 | SRC_URI[sha256sum] = "6c1a383d6f40ae79f7da85584fdf90a6718538bc87f02c3037bcd6b8cb748483" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(mx5|mx6)" | ||
diff --git a/recipes-bsp/firmware-imx/firmware-imx_5.2.bb b/recipes-bsp/firmware-imx/firmware-imx_5.2.bb new file mode 100644 index 00000000..f8a08513 --- /dev/null +++ b/recipes-bsp/firmware-imx/firmware-imx_5.2.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | # Copyright (C) 2012-2015 Freescale Semiconductor | ||
2 | |||
3 | require recipes-bsp/firmware-imx/firmware-imx.inc | ||
4 | |||
5 | SRC_URI[md5sum] = "e466839e2cfbbcacb974b872c0b063e7" | ||
6 | SRC_URI[sha256sum] = "8cc2df128c0e2d2f5224d73389fbe6e4d6fa9ede76f8c0a9adaf7ec0986d0f1f" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(mx5|mx6|mx7)" | ||