diff options
author | Peter Griffin <peter.griffin@linaro.org> | 2019-09-12 11:32:51 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-09-12 14:45:07 -0300 |
commit | d5e848a20ad6b58cd6187ac12fc41e8b79865a3e (patch) | |
tree | f5632661a92290353e2e3927be41cd14a05e8a00 | |
parent | 98afe0f018691f8a03316c28c88170e8f9964818 (diff) | |
download | meta-freescale-d5e848a20ad6b58cd6187ac12fc41e8b79865a3e.tar.gz |
wayland-protocols_1.17.imx: add missing DTRC meta protocol
Add missing protocol from wayland-protocols-imx fork. This
is required to use waylandsink from gst-plugins-bad-imx
fork.
This protocol supports passing pass offset to DTRC in drm
DCSS driver to enable video tile compress.
Signed-off-by: Peter Griffin <peter.griffin@linaro.org>
-rw-r--r-- | recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch | 49 | ||||
-rw-r--r-- | recipes-graphics/wayland/wayland-protocols_1.17.imx.bb | 4 |
2 files changed, 52 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch b/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch new file mode 100644 index 00000000..16aabec8 --- /dev/null +++ b/recipes-graphics/wayland/wayland-protocols/0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 50ea8fbdd1b768ccaa33dfee43b0f12245ef09b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Haihua Hu <jared.hu@nxp.com> | ||
3 | Date: Wed, 5 Sep 2018 13:00:47 +0800 | ||
4 | Subject: [PATCH] linux-dmabuf: support passing buffer DTRC meta to compositor | ||
5 | |||
6 | DTRC meta is untilized to pass offset to DTRC in drm dcss driver | ||
7 | to enable video tile compress | ||
8 | |||
9 | Signed-off-by: Haihua Hu <jared.hu@nxp.com> | ||
10 | --- | ||
11 | unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml | 22 ++++++++++++++++++++++ | ||
12 | 1 file changed, 22 insertions(+) | ||
13 | |||
14 | diff --git a/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml b/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml | ||
15 | index 154afe2..9c955c7 100644 | ||
16 | --- a/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml | ||
17 | +++ b/unstable/linux-dmabuf/linux-dmabuf-unstable-v1.xml | ||
18 | @@ -343,6 +343,28 @@ | ||
19 | <arg name="flags" type="uint" summary="see enum flags"/> | ||
20 | </request> | ||
21 | |||
22 | + <request name="add_dtrc_meta"> | ||
23 | + <description summary="add dtrc meta in this dmabuf"> | ||
24 | + This request adds one dmabuf to the set in this | ||
25 | + zwp_linux_buffer_params_v1. | ||
26 | + | ||
27 | + The 64-bit unsigned value combined from modifier_hi and modifier_lo | ||
28 | + is the dmabuf layout modifier. DRM AddFB2 ioctl calls this the | ||
29 | + fb modifier, which is defined in drm_mode.h of Linux UAPI. | ||
30 | + This is an opaque token. Drivers use this token to express tiling, | ||
31 | + compression, etc. driver-specific modifications to the base format | ||
32 | + defined by the DRM fourcc code. | ||
33 | + | ||
34 | + This request raises the PLANE_IDX error if plane_idx is too large. | ||
35 | + The error PLANE_SET is raised if attempting to set a plane that | ||
36 | + was already set. | ||
37 | + </description> | ||
38 | + <arg name="rfc_chroma_offset" type="uint" | ||
39 | + summary="high 32 bits of DTRC offset"/> | ||
40 | + <arg name="rfc_luma_offset" type="uint" | ||
41 | + summary="low 32 bits of DTRC offset"/> | ||
42 | + </request> | ||
43 | + | ||
44 | </interface> | ||
45 | |||
46 | </protocol> | ||
47 | -- | ||
48 | 2.7.4 | ||
49 | |||
diff --git a/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb b/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb index d070f03f..069bbea0 100644 --- a/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb +++ b/recipes-graphics/wayland/wayland-protocols_1.17.imx.bb | |||
@@ -12,7 +12,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c7b12b6702da38ca028ace54aae3d484 \ | |||
12 | ARCHIVE_NAME = "${BPN}-1.17" | 12 | ARCHIVE_NAME = "${BPN}-1.17" |
13 | SRC_URI = "https://wayland.freedesktop.org/releases/${ARCHIVE_NAME}.tar.xz \ | 13 | SRC_URI = "https://wayland.freedesktop.org/releases/${ARCHIVE_NAME}.tar.xz \ |
14 | file://0001-unstable-Add-alpha-compositing-protocol.patch \ | 14 | file://0001-unstable-Add-alpha-compositing-protocol.patch \ |
15 | file://0002-unstable-Add-hdr10-metadata-protocol.patch" | 15 | file://0002-unstable-Add-hdr10-metadata-protocol.patch \ |
16 | file://0001-linux-dmabuf-support-passing-buffer-DTRC-meta-to-com.patch \ | ||
17 | " | ||
16 | SRC_URI[md5sum] = "55ddd5fdb02b73b9de9559aaec267315" | 18 | SRC_URI[md5sum] = "55ddd5fdb02b73b9de9559aaec267315" |
17 | SRC_URI[sha256sum] = "df1319cf9705643aea9fd16f9056f4e5b2471bd10c0cc3713d4a4cdc23d6812f" | 19 | SRC_URI[sha256sum] = "df1319cf9705643aea9fd16f9056f4e5b2471bd10c0cc3713d4a4cdc23d6812f" |
18 | S = "${WORKDIR}/${ARCHIVE_NAME}" | 20 | S = "${WORKDIR}/${ARCHIVE_NAME}" |