diff options
author | Jens Rehsack <jens.rehsack.ext@safrangroup.com> | 2019-12-16 10:20:47 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-12-16 18:01:10 -0300 |
commit | eab80ecde3618b1b16555ccfbcefb6df8c86aae1 (patch) | |
tree | 07a8bb8b7e1d01587229d6b51d8fb620e59a2c8d | |
parent | f4d05aa18c0192fea2eef3fbfb3390bdb5033c64 (diff) | |
download | meta-freescale-eab80ecde3618b1b16555ccfbcefb6df8c86aae1.tar.gz |
Revert "linux-qoriq recipes: reorder merge_delta_config task"
This reverts commit 6e0b6f295fa7f62484b7a448fb729fbd32191a6b,
which unfortunately causes a blank build for e.g. ls2088ardb fail as that
ERROR: linux-qoriq-4.19-r0 do_preconfigure: Execution of 'mp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614' failed with exit code 2:
tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: 119: tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: cannot open tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/defconfig: No such file
WARNING: exit code 2 from a shell command.
ERROR: Logfile of failure stored in: tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/log.do_preconfigure.13614
Log data follows:
| DEBUG: Executing shell function do_preconfigure
| tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: 119: tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: cannot open tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/defconfig: No such file
| WARNING: exit code 2 from a shell command.
| ERROR: Execution of 'tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614' failed with exit code 2:
| tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: 119: tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/temp/run.do_preconfigure.13614: cannot open tmp/work/ls2088ardb-poky-linux/linux-qoriq/4.19-r0/defconfig: No such file
| WARNING: exit code 2 from a shell command.
|
ERROR: Task (/build/sno/sources/meta-freescale/recipes-kernel/linux/linux-qoriq_4.19.bb:do_preconfigure) failed with exit code '1'
This is caused by do_preconfigure() from classes/fsl-kernel-localversion.bbclass
expects a ${WORKDIR}/defconfig which was earlier created by merge_delta_config.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
-rw-r--r-- | recipes-kernel/linux/linux-qoriq-rt_4.14.bb | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.14.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.19.bb | 2 |
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-rt_4.14.bb b/recipes-kernel/linux/linux-qoriq-rt_4.14.bb index 5a1147e5..e880081a 100644 --- a/recipes-kernel/linux/linux-qoriq-rt_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq-rt_4.14.bb | |||
@@ -37,7 +37,7 @@ do_merge_delta_config[dirs] = "${B}" | |||
37 | do_merge_delta_config() { | 37 | do_merge_delta_config() { |
38 | # create config with make config | 38 | # create config with make config |
39 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | 39 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} |
40 | 40 | ||
41 | # check if bigendian is enabled | 41 | # check if bigendian is enabled |
42 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | 42 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then |
43 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | 43 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config |
@@ -56,7 +56,7 @@ do_merge_delta_config() { | |||
56 | done | 56 | done |
57 | cp .config ${WORKDIR}/defconfig | 57 | cp .config ${WORKDIR}/defconfig |
58 | } | 58 | } |
59 | addtask merge_delta_config before do_configure after do_patch do_preconfigure | 59 | addtask merge_delta_config before do_preconfigure after do_patch |
60 | 60 | ||
61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
62 | do_compile_prepend_fsl-lsch2-32b() { | 62 | do_compile_prepend_fsl-lsch2-32b() { |
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb index 8a28918c..f2e0a4b8 100644 --- a/recipes-kernel/linux/linux-qoriq_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq_4.14.bb | |||
@@ -56,7 +56,7 @@ do_merge_delta_config() { | |||
56 | done | 56 | done |
57 | cp .config ${WORKDIR}/defconfig | 57 | cp .config ${WORKDIR}/defconfig |
58 | } | 58 | } |
59 | addtask merge_delta_config before do_configure after do_patch do_preconfigure | 59 | addtask merge_delta_config before do_preconfigure after do_patch |
60 | 60 | ||
61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
62 | do_compile_prepend_fsl-lsch2-32b() { | 62 | do_compile_prepend_fsl-lsch2-32b() { |
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb index 78125352..aed29df6 100644 --- a/recipes-kernel/linux/linux-qoriq_4.19.bb +++ b/recipes-kernel/linux/linux-qoriq_4.19.bb | |||
@@ -57,7 +57,7 @@ do_merge_delta_config() { | |||
57 | done | 57 | done |
58 | cp .config ${WORKDIR}/defconfig | 58 | cp .config ${WORKDIR}/defconfig |
59 | } | 59 | } |
60 | addtask merge_delta_config before do_configure after do_patch do_preconfigure | 60 | addtask merge_delta_config before do_preconfigure after do_patch |
61 | 61 | ||
62 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 62 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
63 | do_compile_prepend_fsl-lsch2-32b() { | 63 | do_compile_prepend_fsl-lsch2-32b() { |